取消
显示结果 
搜索替代 
您的意思是: 
cancel
3227
查看次数
0
有帮助
4
评论
碧云天
Spotlight
Spotlight
本帖最后由 碧云天 于 2020-2-26 10:00 编辑
一.测试拓扑
095841zh77fhv7vv9vzg78.png
测试总结:
1.ISIS的区域是基于路由器的,不像OSPF是基于接口的
2.ISIS的非骨干区域类似OSPF的Totall NSSA区域,会自动产生一条全0的默认路由,并且不会有其他区域的路由
3.ISIS的非骨干区域连接骨干区域的路由器,类似OSPF的ABR,需要为L1/2路由器,其他的路由器可以为L1或L1/2
二.基本配置
1.R1路由器

hostname R1
interface Loopback0
ip address 1.1.1.1 255.255.255.0
interface Ethernet0/0
ip address 12.1.1.1 255.255.255.0
no shutdown
interface Ethernet0/1
ip address 13.1.1.1 255.255.255.0
no shutdown
interface Ethernet0/2
ip address 14.1.1.1 255.255.255.0
no shutdown
2.R2路由器
hostname R2
interface Loopback0
ip address 2.2.2.2 255.255.255.0
interface Ethernet0/0
ip address 12.1.1.2 255.255.255.0
no shutdown
3.R3路由器
hostname R3
interface Loopback0
ip address 3.3.3.3 255.255.255.0
interface Ethernet0/0
ip address 13.1.1.3 255.255.255.0
no shutdown
4.R4路由器
hostname R4
interface Loopback0
ip address 4.4.4.4 255.255.255.0
no shutdown
interface Ethernet0/0
ip address 14.1.1.4 255.255.255.0
no shutdown
interface Ethernet0/1
ip address 45.1.1.4 255.255.255.0
no shutdown
5.R5路由器
hostname R5
interface Loopback0
ip address 5.5.5.5 255.255.255.0
no shutdown
interface Ethernet0/0
ip address 56.1.1.5 255.255.255.0
no shutdown
interface Ethernet0/1
ip address 45.1.1.5 255.255.255.0
no shutdown
6.R6路由器
hostname R6
interface Loopback0
ip address 6.6.6.6 255.255.255.0
interface Ethernet0/0
ip address 67.1.1.6 255.255.255.0
no shutdown
interface Ethernet0/1
ip address 68.1.1.6 255.255.255.0
no shutdown
interface Ethernet0/2
ip address 56.1.1.6 255.255.255.0
no shutdown
7.R7路由器
hostname R7
interface Loopback0
ip address 7.7.7.7 255.255.255.0
interface Ethernet0/0
ip address 67.1.1.7 255.255.255.0
no shutdown
8.R8路由器
hostname R8
interface Loopback0
ip address 8.8.8.8 255.255.255.0
interface Ethernet0/0
ip address 68.1.1.8 255.255.255.0
no shutdown
三.ISIS配置
1.R1路由器

router isis
net 49.0001.1111.1111.1111.00
log-adjacency-changes all
passive-interface Loopback0
interface Loopback0
ip router isis
interface Ethernet0/0
ip router isis
isis network point-to-point
interface Ethernet0/1
ip router isis
isis network point-to-point
interface Ethernet0/2
ip router isis
isis network point-to-point
2.R2路由器
router isis
net 49.0001.2222.2222.2222.00
is-type level-1
log-adjacency-changes all
passive-interface Loopback0
interface Loopback0
ip router isis
interface Ethernet0/0
ip router isis
isis network point-to-point
3.R3路由器
router isis
net 49.0001.3333.3333.3333.00
is-type level-1
log-adjacency-changes all
passive-interface Loopback0
interface Loopback0
ip router isis
interface Ethernet0/0
ip router isis
isis network point-to-point
4.R4路由器
router isis
net 49.0000.4444.4444.4444.00
is-type level-2-only
log-adjacency-changes all
passive-interface Loopback0
interface Loopback0
ip router isis
interface Ethernet0/0
ip router isis
isis network point-to-point
interface Ethernet0/1
ip router isis
isis network point-to-point
5.R5路由器
router isis
net 49.0000.5555.5555.5555.00
is-type level-2-only
log-adjacency-changes all
passive-interface Loopback0
interface Loopback0
ip router isis
interface Ethernet0/0
ip router isis
isis network point-to-point
interface Ethernet0/1
ip router isis
isis network point-to-point
6.R6路由器
router isis
net 49.0002.6666.6666.6666.00
log-adjacency-changes all
passive-interface Loopback0
interface Loopback0
ip router isis
interface Ethernet0/0
ip router isis
isis network point-to-point
interface Ethernet0/1
ip router isis
isis network point-to-point
interface Ethernet0/2
ip router isis
isis network point-to-point
7.R7路由器
router isis
net 49.0002.7777.7777.7777.00
is-type level-1
log-adjacency-changes all
passive-interface Loopback0
interface Loopback0
ip router isis
interface Ethernet0/0
ip router isis
isis network point-to-point
8.R8路由器
router isis
net 49.0002.8888.8888.8888.00
is-type level-1
log-adjacency-changes all
passive-interface Loopback0
interface Loopback0
ip router isis
interface Ethernet0/0
ip router isis
isis network point-to-point
四.验证
1.非骨干区域没有其他区域的路由,只有一条全0的默认路由

R2#show ip route isis | begin Gate
Gateway of last resort is 12.1.1.1 to network 0.0.0.0
i*L1 0.0.0.0/0 [115/10] via 12.1.1.1, 00:24:29, Ethernet0/0
1.0.0.0/24 is subnetted, 1 subnets
i L1 1.1.1.0 [115/20] via 12.1.1.1, 00:24:29, Ethernet0/0
3.0.0.0/24 is subnetted, 1 subnets
i L1 3.3.3.0 [115/30] via 12.1.1.1, 00:23:25, Ethernet0/0
13.0.0.0/24 is subnetted, 1 subnets
i L1 13.1.1.0 [115/20] via 12.1.1.1, 00:24:29, Ethernet0/0
14.0.0.0/24 is subnetted, 1 subnets
i L1 14.1.1.0 [115/20] via 12.1.1.1, 00:24:29, Ethernet0/0
R2#
R7#show ip route isis | begin Gate
Gateway of last resort is 67.1.1.6 to network 0.0.0.0
i*L1 0.0.0.0/0 [115/10] via 67.1.1.6, 00:56:12, Ethernet0/0
6.0.0.0/24 is subnetted, 1 subnets
i L1 6.6.6.0 [115/20] via 67.1.1.6, 00:15:35, Ethernet0/0
8.0.0.0/24 is subnetted, 1 subnets
i L1 8.8.8.0 [115/30] via 67.1.1.6, 00:15:27, Ethernet0/0
56.0.0.0/24 is subnetted, 1 subnets
i L1 56.1.1.0 [115/20] via 67.1.1.6, 00:15:35, Ethernet0/0
68.0.0.0/24 is subnetted, 1 subnets
i L1 68.1.1.0 [115/20] via 67.1.1.6, 00:15:35, Ethernet0/0
R7#
2.非骨干区域连接骨干区域的L1/2的路由器,与骨干区域路由器一样,都有全网的路由
R1#show ip route isis | begin Gate
Gateway of last resort is not set
2.0.0.0/24 is subnetted, 1 subnets
i L1 2.2.2.0 [115/20] via 12.1.1.2, 00:01:58, Ethernet0/0
3.0.0.0/24 is subnetted, 1 subnets
i L1 3.3.3.0 [115/20] via 13.1.1.3, 00:25:11, Ethernet0/1
4.0.0.0/24 is subnetted, 1 subnets
i L2 4.4.4.0 [115/20] via 14.1.1.4, 00:51:30, Ethernet0/2
5.0.0.0/24 is subnetted, 1 subnets
i L2 5.5.5.0 [115/30] via 14.1.1.4, 00:21:02, Ethernet0/2
6.0.0.0/24 is subnetted, 1 subnets
i L2 6.6.6.0 [115/40] via 14.1.1.4, 00:15:58, Ethernet0/2
7.0.0.0/24 is subnetted, 1 subnets
i L2 7.7.7.0 [115/50] via 14.1.1.4, 00:15:58, Ethernet0/2
8.0.0.0/24 is subnetted, 1 subnets
i L2 8.8.8.0 [115/50] via 14.1.1.4, 00:15:58, Ethernet0/2
45.0.0.0/24 is subnetted, 1 subnets
i L2 45.1.1.0 [115/20] via 14.1.1.4, 00:51:30, Ethernet0/2
56.0.0.0/24 is subnetted, 1 subnets
i L2 56.1.1.0 [115/30] via 14.1.1.4, 00:21:02, Ethernet0/2
67.0.0.0/24 is subnetted, 1 subnets
i L2 67.1.1.0 [115/40] via 14.1.1.4, 00:15:58, Ethernet0/2
68.0.0.0/24 is subnetted, 1 subnets
i L2 68.1.1.0 [115/40] via 14.1.1.4, 00:15:58, Ethernet0/2
R1#
R4#show ip route isis | begin Gate
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
i L2 1.1.1.0 [115/20] via 14.1.1.1, 00:04:27, Ethernet0/0
2.0.0.0/24 is subnetted, 1 subnets
i L2 2.2.2.0 [115/30] via 14.1.1.1, 00:04:27, Ethernet0/0
3.0.0.0/24 is subnetted, 1 subnets
i L2 3.3.3.0 [115/30] via 14.1.1.1, 00:04:27, Ethernet0/0
5.0.0.0/24 is subnetted, 1 subnets
i L2 5.5.5.0 [115/20] via 45.1.1.5, 00:23:33, Ethernet0/1
6.0.0.0/24 is subnetted, 1 subnets
i L2 6.6.6.0 [115/30] via 45.1.1.5, 00:18:29, Ethernet0/1
7.0.0.0/24 is subnetted, 1 subnets
i L2 7.7.7.0 [115/40] via 45.1.1.5, 00:18:29, Ethernet0/1
8.0.0.0/24 is subnetted, 1 subnets
i L2 8.8.8.0 [115/40] via 45.1.1.5, 00:18:29, Ethernet0/1
12.0.0.0/24 is subnetted, 1 subnets
i L2 12.1.1.0 [115/20] via 14.1.1.1, 00:04:27, Ethernet0/0
13.0.0.0/24 is subnetted, 1 subnets
i L2 13.1.1.0 [115/20] via 14.1.1.1, 00:04:27, Ethernet0/0
56.0.0.0/24 is subnetted, 1 subnets
i L2 56.1.1.0 [115/20] via 45.1.1.5, 00:23:33, Ethernet0/1
67.0.0.0/24 is subnetted, 1 subnets
i L2 67.1.1.0 [115/30] via 45.1.1.5, 00:18:29, Ethernet0/1
68.0.0.0/24 is subnetted, 1 subnets
i L2 68.1.1.0 [115/30] via 45.1.1.5, 00:18:29, Ethernet0/1
R4#
评论
one-time
Level 13
Level 13
感谢楼主分享,谢谢~
robortlin
Spotlight
Spotlight
感谢楼主分享,谢谢
Stan Huang
Cisco Employee
Cisco Employee
lollol:lol 感謝分享
likuo
Spotlight
Spotlight
确实很好。
入门指南

使用上面的搜索栏输入关键字、短语或问题,搜索问题的答案。

我们希望您在这里的旅程尽可能顺利,因此这里有一些链接可以帮助您快速熟悉思科社区:









快捷链接