请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

   思科 CCO 登录 推荐
 找回密码
 立即注册

搜索
热搜: 邮件服务器
查看: 4585|回复: 16

[工具分享]手把手教你-利用VACL抓包

[复制链接]
发表于 2015-4-14 00:09:47 | 显示全部楼层 |阅读模式
本帖最后由 xupeng 于 2015-4-19 21:22 编辑

VACL Capture(VACL抓包)


-VLAN ACL(VACL)可以对数据包提供访问控制, 包括同一VLAN内转发的数据包,以及跨VLAN转发的数据包.
-VACL的行为包括:
   Drop (丢弃)
   Forward [capture] (转发[抓包])
   Redirect (重定向)
-capture的行为会将被转发的数据包的capture bit置位,因此,在抓包的接口会收到这些数据包.
-只在Catalyst 6500 / Cisco 7600 支持VACL Capture.


=========
配置案例
=========


ip access-list extended INTERESTING_TRAFFIC  //定义ACL来匹配感兴趣流量,这些流量将被发送到抓包的接口.
permit ip host 10.1.100.1 any
permit ip any host 10.1.100.1
ip access-list extended PERMIT_ALL //定义ACL放行剩下的流量
permit ip any any
!
vlan access-map VACL_CAPTURE 10  //定义一个VLAN access-map, 名称是'VACL_CAPTURE'
match ip address INTERESTING_TRAFFIC //匹配定义好的ACL 'INTERESTING_TRAFFIC'
action forward capture //将流量放行并且抓包(关键字capture)
vlan access-map VACL_CAPTURE 20
match ip address PERMIT_ALL   //匹配定义好的ACL 'PERMIT_ALL'
action forward  //将匹配的流量放行
!
vlan filter VACL_CAPTURE vlan-list 10 //定义VLAN filter名'VACL_CAPTURE',并应用到VLAN 10
!
interface GigabitEthernet1/9 //将Gi1/9作为接收数据包的接口
switchport
switchport trunk encapsulation dot1q
switchport mode trunk  
switchport capture //配置接口接收被VACL filter抓到的流量.
!

  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分5 (7 评价)
发表于 2015-4-14 08:58:56 | 显示全部楼层
支持下!
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2015-4-14 10:13:33 | 显示全部楼层
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2015-4-14 10:14:18 | 显示全部楼层
谢谢楼主分享
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2015-4-14 10:17:09 | 显示全部楼层
Engineer Peng, galivable !
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2015-4-14 10:20:39 | 显示全部楼层
赞,支持
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2015-4-14 10:24:34 | 显示全部楼层
谢谢楼主分享
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2015-4-14 10:24:37 | 显示全部楼层
赞一个
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2015-4-14 10:27:06 | 显示全部楼层

赞~~~~
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2015-4-14 10:28:57 | 显示全部楼层
赞赞赞
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科社区  

GMT+8, 2019-5-23 06:10 , Processed in 0.235426 second(s), 59 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表