请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科服务支持社区 点击关注
思科服务支持社区

  
 找回密码
 立即注册

扫一扫,访问微社区

搜索
热搜: 邮件服务器
查看: 2072|回复: 9

思科2911路由器nat及负载均衡 求教各位大神

[复制链接]
发表于 2015-9-19 18:49:09 | 显示全部楼层 |阅读模式
5可用金钱
各位大神,请教一下问题:
1.2911接入电信和联通两条专线来实现链路冗余及负载均衡,负载均衡如何配置
2.内网ip做NAT转换如何配置
3.其中一条专线down后,nat如何变化


附件: 您需要 登录 才可以下载或查看,没有帐号?立即注册

最佳答案

查看完整内容

给你一个 配置吧,GNS测过好用,应该没啥问题,具体细化自己做做 GW路由器配置 实现双出口双NAT + SLA监控链路有效性实验 GW#sh run Building configuration... Current configuration : 1871 bytes ! version 12.4 service timestamps debug datetime msec service timestamps log datetime msec no service password-encryption ! hostname GW ! boot-start-marker boot-end-marker ! ! no aaa new-mo ...
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分1 (1 评价)
发表于 2015-9-19 18:49:10 | 显示全部楼层
给你一个 配置吧,GNS测过好用,应该没啥问题,具体细化自己做做

GW路由器配置       
实现双出口双NAT + SLA监控链路有效性实验

GW#sh run
Building configuration...

Current configuration : 1871 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname GW
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
ip dhcp excluded-address 10.1.1.1 10.1.1.10
ip dhcp excluded-address 10.1.2.1 10.1.2.20
!         
ip dhcp pool P1
   network 10.1.1.0 255.255.255.0
   default-router 10.1.1.1
!
ip dhcp pool P2
   network 10.1.2.0 255.255.255.0
   default-router 10.1.2.1 255.255.255.0
!
!
ip sla monitor 10
type echo protocol ipIcmpEcho 60.30.1.2 source-interface FastEthernet1/0
frequency 10
ip sla monitor schedule 10 start-time now recurring
!
track 100 rtr 10 reachability
!
interface FastEthernet0/0
ip address 202.100.1.1 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 60.30.1.1 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 10.1.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 FastEthernet1/0 track 100
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 2
!
ip nat inside source route-map LianTong interface FastEthernet1/0 overload
ip nat inside source route-map Yidong interface FastEthernet0/0 overload
!
access-list 100 permit ip 10.1.0.0 0.0.255.255 any
!
route-map LianTong permit 10
match ip address 100
match interface FastEthernet1/0        
!
route-map LianTong permit 20
!
route-map Yidong permit 10
match ip address 100
match interface FastEthernet0/0
!
route-map Yidong permit 20
!
control-plane
!     
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分3 (2 评价)
发表于 2015-9-20 12:43:21 | 显示全部楼层
我写过专门的案例视频,由于是付费的,就不提供链接了

网上有差不多的配置

你可以参考一下


http://wenku.baidu.com/link?url=TjEI3s-LRrRKfc9MNumJh7BFLDBR_oOg7gsp7nh1_MHPXnbsZ14Dp6GWKGVd1hNavlDVR2Qlgs_I0986jYLYkg55kvMndVXyKDv3movc7ru
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分3 (2 评价)
 楼主| 发表于 2015-9-21 08:01:52 | 显示全部楼层
suzhouxiaoniu 发表于 2015-9-20 12:43
我写过专门的案例视频,由于是付费的,就不提供链接了

网上有差不多的配置

十分感谢啊 !
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分3 (2 评价)
发表于 2015-9-22 10:18:49 | 显示全部楼层
995011402 发表于 2015-9-21 08:01
十分感谢啊 !

不客气
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分1 (1 评价)
 楼主| 发表于 2015-10-28 09:35:16 | 显示全部楼层
yanzha4 发表于 2015-10-15 16:12
给你一个 配置吧,GNS测过好用,应该没啥问题,具体细化自己做做

GW路由器配置       

非常感谢大神的回复 也相当有帮助  再次感谢啊!
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分1 (1 评价)
发表于 2017-4-4 16:22:16 | 显示全部楼层
楼主  这个方法可以解决问题吗?
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分1 (1 评价)
发表于 2017-4-5 09:13:11 | 显示全部楼层
学习了、学习了、
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分1 (1 评价)
发表于 2017-4-25 16:13:08 | 显示全部楼层
学习了、学习了、
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分3 (2 评价)
发表于 2018-8-9 14:42:30 | 显示全部楼层
论坛 还是个好地方呀
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分1 (1 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科服务支持社区  

GMT+8, 2018-8-21 03:59 , Processed in 0.108685 second(s), 60 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表