请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

   思科 CCO 登录 推荐
 找回密码
 立即注册

搜索
热搜: 邮件服务器
查看: 4554|回复: 8

关于VPC的问题?

[复制链接]
发表于 2016-8-25 08:28:56 | 显示全部楼层 |阅读模式
5可用金钱
各位看官:
              汇聚交换机N3K-3548P-10G  接入用的2960x-48TD-L ,之间可以做VPC吗?
N3K边的配置
interface ethernet 1/3-4
switchport
no shutdown
switchport mode trunk
channel-group 1 mode on
exit

interface ethernet 1/5-6
switchport
no shutdown
switchport mode trunk
channel-group 2 mode on
exit

interface Port-channel1
switchport mode trunk

interface Port-channel2
switchport mode trunk

2960边的配置
interface range TenGigabitEthernet1/0/1 - 2
no shutdown
switchport mode trunk
channel-group 1 mode on
exit

interface Port-channel 1
switchport mode trunk
no shutdown

现在的问题是接口 3-4 Port-channel协商成功 另一路1/5-6port-channel只有一路灯正常 6口不正常显示linkflap
重新 shutdown  no shutdown  没有成功
删除 重新建 还是没有成功
请大侠给出建议谢谢!

最佳答案

查看完整内容

您好! 应该是vpc配置有问题。请参见以下文档,虽然该文档是n7k平台,但是原理是一样的,命令行基本也相同。 http://www.cisco.com/c/dam/en/us/td/docs/switches/datacenter/sw/design/vpc_design/vpc_best_practices_design_guide.pdf 谢谢!
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2016-8-25 08:28:57 | 显示全部楼层
您好!
应该是vpc配置有问题。请参见以下文档,虽然该文档是n7k平台,但是原理是一样的,命令行基本也相同。
http://www.cisco.com/c/dam/en/us ... es_design_guide.pdf

谢谢!
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分5 (1 评价)
发表于 2016-8-26 10:17:51 | 显示全部楼层
你这个VPC的配置都是缺的吧
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2016-8-26 23:11:13 | 显示全部楼层
N3K-3548P-10G可以配vPC,但你根本就没配,只配了普通的port channel。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2016-9-1 11:27:22 | 显示全部楼层
可以捆绑 你图划清楚!
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2016-9-9 13:08:44 | 显示全部楼层
VPC是指1台接入交换机上联到2台汇聚交换机,这3台机器之间做的port channel叫VPC,对于接入交换机来说,是把汇聚交换机逻辑上看成一台交换机。
这里要求:1)2台汇聚交换机之间需要2条10G线路做成port channel,这个pc作为VPC的peer-link;
2)2台汇聚交换机之间还需要有layer 3连接,最简单的就是用mgmt接口;
3)做好相应的配置:汇聚交换机做VPC配置,官网上可以找到配置案例,接入交换机仍然按照传统做port channel。
供参考。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2016-10-24 14:34:16 | 显示全部楼层
本帖最后由 zeroarynas 于 2016-10-24 14:35 编辑

N3K-01上的配置:
vpc domain 10         //配置VPC域
  role priority 10       //配置优先级
  peer-keepalive destination 172.30.1.2 source 172.30.1.1 vrf management   
//配置peer-keepalive-link,不一定要像我这样走管理口,两台N3K之间连接一条线,2边接口配置同一个网段的不同IP,然后互ping一下,能通就没问题

interface mgmt 0
  ip address
172.30.1.1/24       //用来做peer-keepalive-link,如之前所说,不一定要管理口
  vrf member management

interface
Ethernet1/32
  switchport mode trunk   
  channel-group 10 mode active         //peer-link相关配置

interface port-channel10
  switchport mode trunk
  spanning-tree port type network
  vpc peer-link                                  //配置peer-link,要10G的接口,这个也是和另外一台N3K连接,2层链路(也就是说做vpc,2台nexus交换机之间最少要2根线连接,一根做peer-link,另一根做peer-keepalive)

interface ethernet1/1
  switchport mode trunk
  channel-group 10 mode active              //VPC相关配置

interface port-channel 10
  switchport mode trunk
  vpc 10                                               //配置VPC10(另外一台N3K的接口也要配置相同的VPC编号)                 


N3K-02配置:
vpc domain 10         
  role priority 20      
  peer-keepalive destination 172.30.1.1 source 172.30.1.2 vrf management


interface mgmt 0
  ip address
172.30.1.2/24
  vrf member management

interface Ethernet
1/32
  switchport mode trunk   
  channel-group 10 mode active      

interface port-channel10
  switchport mode trunk
  spanning-tree port type network
  vpc peer-link                                 

interface ethernet1/1
  switchport mode trunk
  channel-group 10 mode active              

interface port-channel 10
  switchport mode trunk
  vpc 10




接入层交换机配置:
interface ethernet1/1
  switchport mode trunk
  channel-group 10 mode active            

interface ethernet1/2
  switchport mode trunk
  channel-group 10 mode active             //接入层交换机的e1/1和e1/2分别连接至2台N3K的e1/1口

interface port-channel 10
  switchport mode trunk



仅供参考,如果哪位兄弟发现了错误,烦请指正,谢谢。
















  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2016-10-25 08:41:03 | 显示全部楼层
zeroarynas 发表于 2016-10-24 14:34
N3K-01上的配置:
vpc domain 10         //配置VPC域
  role priority 10       //配置优先级

N3k上peer-link和vpc不能使用相同的channel-group
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-4-12 14:45:37 | 显示全部楼层
zeroarynas 发表于 2016-10-24 14:34
N3K-01上的配置:
vpc domain 10         //配置VPC域
  role priority 10       //配置优先级

peer-link的channel-group编号和下联接入交换机的channel-group的编号是不是重复了,应该是不同的吧?
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科社区  

GMT+8, 2019-8-22 16:26 , Processed in 0.103917 second(s), 51 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表