请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科服务支持社区 点击关注
思科服务支持社区

  
 找回密码
 立即注册

扫一扫,访问微社区

搜索
热搜: 邮件服务器
查看: 502|回复: 6

cisco vss 内网丢包

[复制链接]
发表于 2017-8-8 10:23:00 | 显示全部楼层 |阅读模式
20可用金钱
现有2台4500系列交换机,配置了VSS,通过板卡的万兆口连接Dell 交换机。Dell交换机配置了类似VSS的vlt。
问题是:Dell下联设备ping同vlan机器不丢包,跨vlan会不时出现丢包。
具体配置和拓扑如下:
2台cisco设备为WS-C4507R+E 、WS-C4503-E,版本为IOS-XE Software, Catalyst 4500 L3 Switch  Software (cat4500e-UNIVERSAL-M), Version 03.09.01.E RELEASE SOFTWARE (fc1)。
设备端口信息如下:
4507:
WS-X4612-SFP-E
WS-X45-SUP7-E  
WS-X4648-RJ45V+E
4503:
WS-X45-SUP7-E
WS-X4624-SFP-E
WS-X4648-RJ45-E

VSS配置如下:
switch virtual domain 1
switch mode virtual
switch asymmetric
switch 1 priority 255
mac-address use-virtual


Dell 配置如下:
vlt domain 1
peer-link port-channel 100
back-up destination 10.222.1.1
primary-priority 4096
system-mac mac-address 00:1b:00:13:22:33
unit-id 0
delay-restore 10


设备互联配置:
cisco:
interface Port-channel3
description <TO-DellS4048>
switchport
switchport mode trunk
end

interface TenGigabitEthernet1/3/3
switchport mode trunk
channel-group 3 mode active
end

interface TenGigabitEthernet1/3/4
switchport mode trunk
channel-group 3 mode active
end

interface TenGigabitEthernet2/1/3
switchport mode trunk
channel-group 3 mode active
end

interface TenGigabitEthernet2/1/4
switchport mode trunk
channel-group 3 mode active
end


Dell:
interface Port-channel 1
description Uplink to Cisco
no ip address
mtu 9216
switchport
vlt-peer-lag port-channel 1
no shutdown


网络拓扑

网络拓扑

最佳答案

查看完整内容

1.我看到你在DELL的port-channel 1 上配置的MTUWEI 9126, 但是思科的MTU却没有配置,可以尝试将两端的MTU更改为同一的参数 2.还有一个检查的地方,看看STP的配置,模式是否为统一模式,思科默认为PVST,dell应该为MST
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2017-8-8 10:23:01 | 显示全部楼层
gongsunyu 发表于 2017-8-15 17:09
谢谢,我的拓扑图没有画全,2台Dell设备是有互联的,我把配置贴上来,请您补充
互联配置:
interface fo ...

1.我看到你在DELL的port-channel 1 上配置的MTUWEI 9126, 但是思科的MTU却没有配置,可以尝试将两端的MTU更改为同一的参数
2.还有一个检查的地方,看看STP的配置,模式是否为统一模式,思科默认为PVST,dell应该为MST
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2017-8-9 12:43:17 | 显示全部楼层
DELL VLT 不是VSS,而是当Cisco的vPC去理解;
如果是VPC,这拓扑连线是否存在问题?
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2017-8-9 15:20:29 | 显示全部楼层
YilinChen 发表于 2017-8-9 12:43
DELL VLT 不是VSS,而是当Cisco的vPC去理解;
如果是VPC,这拓扑连线是否存在问题?

所以怎么说?
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2017-8-15 12:15:36 | 显示全部楼层
1.你的拓扑结构不正确,VLT需要DELL交换机也互联,思科和DELL是二层互联,使用port chanel,你的4500的配置是没有问题的,DELL上联端口需要配置类似思科VPC的设置才可以。下联端口启用portchanel 和VLT
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2017-8-15 17:09:10 | 显示全部楼层
本帖最后由 gongsunyu 于 2017-8-15 17:10 编辑
arvinjing 发表于 2017-8-15 12:15
1.你的拓扑结构不正确,VLT需要DELL交换机也互联,思科和DELL是二层互联,使用port chanel,你的4500的配置 ...

谢谢,我的拓扑图没有画全,2台Dell设备是有互联的,我把配置贴上来,请您补充
互联配置:
interface fortyGigE 1/49
no ip address
no shutdown
!
interface fortyGigE 1/50
no ip address
no shutdown
!      
interface Port-channel 100
description VLTi
no ip address
channel-member fortyGigE 1/49,1/50
no shutdown
!
上联配置:
interface TenGigabitEthernet 1/47
description Uplink to Cisco
no ip address
!  
port-channel-protocol LACP
  port-channel 1 mode active
no shutdown
!
interface TenGigabitEthernet 1/48
description Uplink to Cisco
no ip address
!  
port-channel-protocol LACP
  port-channel 1 mode active
no shutdown
interface Port-channel 1
description Uplink to Cisco
no ip address
mtu 9216
switchport
vlt-peer-lag port-channel 1
no shutdown
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2017-8-31 10:03:59 | 显示全部楼层
arvinjing 发表于 2017-8-17 13:16
1.我看到你在DELL的port-channel 1 上配置的MTUWEI 9126, 但是思科的MTU却没有配置,可以尝试将两端的MTU ...

谢谢了,思科和dell的STP模式都已设置为RSTP;
现在问题已解决,之前的版本是:cat4500e-universal.SPA.03.09.01.E.152-5.E1.bin,更换为cat4500e-universal.SPA.03.06.06.E.152-2.E6.bin,观察了2周没有出现丢包了。

点评

感谢楼主分享解决方案 如果楼上同学的回复对您有帮助,请标记最佳答案  发表于 2017-9-14 10:50
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科服务支持社区  

GMT+8, 2017-12-18 05:35 , Processed in 0.093691 second(s), 47 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表