请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科服务支持社区 点击关注
思科服务支持社区

  
 找回密码
 立即注册

扫一扫,访问微社区

搜索
热搜: 邮件服务器
查看: 207|回复: 10

vpn不能连接

[复制链接]
发表于 2017-11-28 11:11:11 | 显示全部楼层 |阅读模式
0可用金钱
asa5512 ,以前一直正常,今天突然出现不能连接,提示connection attempt has timed out.please verify Internet connecticity.

试了要连的vpn那端,外网正常,ping vpn的ip也能ping通,这是什么问题,有谁知道,该怎么解决

  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2017-11-28 13:46:15 | 显示全部楼层
因为ISP会限制80,443这些端口,如果你们没有做端口备案的话,建议更改一下端口号吧,可以把443端口更改为4433
可以使用以下命令:
webvpn
no enable outside
port 4433
enable outside
在客户端输入VPN地址的后面加上:4433的端口号即可
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2017-11-28 13:53:20 | 显示全部楼层
interface GigabitEthernet0/1
nameif outside
security-level 0
ip address 60.191.39.1 255.255.255.248

在这里加上port?
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2017-11-28 14:04:18 | 显示全部楼层
crypto ikev2 enable outside client-services port 443   这里改吗
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2017-11-28 16:33:30 | 显示全部楼层
改了端口后报 user not authorized for anyconnect client access,是要重新加载客户端吗?
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2017-11-29 09:41:02 | 显示全部楼层
terry9020 发表于 2017-11-28 13:53
interface GigabitEthernet0/1
nameif outside
security-level 0

配置模式下,执行以下命令
webvpn
no enable outside
port 4433
enable outside
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分5 (1 评价)
发表于 2017-11-29 09:50:03 | 显示全部楼层
1. 首先确定一下ASA是否接收到了SSL报文,用capture test in interface outside host x.x.x.x(PC的公网IP) host x.x.x.x(ASA outside接口IP)。
2. 如果ASA收到了SSL报文,可以通过debug看一下为什么连接不上,“debug webvpn anyconnect 255”,“debug ssl 255”,“debug vpn-sessiondb 255”。
3. 在PC上安装DART,然后通过DART查看anyconnect为什么连接不上。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2017-11-29 11:16:01 | 显示全部楼层
被封掉443的概率较高,建议改端口号测试一下。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2017-11-29 12:47:32 | 显示全部楼层
arvinjing 发表于 2017-11-29 09:41
配置模式下,执行以下命令
webvpn
no enable outside

感谢,按你的做,在webvpn改端口后就可以了
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2017-11-29 14:58:14 | 显示全部楼层
terry9020 发表于 2017-11-29 12:47
感谢,按你的做,在webvpn改端口后就可以了

如何已经成功解决问题,请将此问题标注为已解决,供其他小伙伴们参考,谢谢
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科服务支持社区  

GMT+8, 2017-12-15 00:51 , Processed in 0.092474 second(s), 52 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表