请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科服务支持社区 点击关注
思科服务支持社区

  
 找回密码
 立即注册

扫一扫,访问微社区

搜索
热搜: 邮件服务器
查看: 180|回复: 3

1941W放出无线信号,client获取不到地址

[复制链接]
发表于 2017-11-29 11:12:43 | 显示全部楼层 |阅读模式
4可用金钱
hi ,

最近做实验使用cisco-1941遇到问题,
1941能够放出信号,但是client获取不到地址:
1941配置:
Building configuration...

Current configuration : 3394 bytes
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IPV6-Test
!
boot-start-marker
boot system flash0:/c1900-universalk9-mz.SPA.154-3.M8.bin
boot-end-marker
!
!
enable password cisco123
!
no aaa new-model
service-module wlan-ap 0 bootimage autonomous
!
!
!
!
!         
!
!
!
!
!
!
ip dhcp excluded-address 172.29.29.1
!
ip dhcp pool vlan100v4
network 172.29.29.0 255.255.255.0
default-router 172.29.29.1
dns-server 8.8.8.8 10.96.1.18
!
!
!
ip domain name lenovo.com
ip cef
ipv6 unicast-routing
ipv6 dhcp pool vlan100v6
address prefix 2403:5000:171:98::/80
address prefix 2403:5000:171:98::/64
dns-server 2001:4860:4860::8888
domain-name lenovo.com
!
ipv6 dhcp pool test
address prefix 2010:AA01:10::/80
dns-server AAAA:BBBB:10FE:100::15
dns-server 2010:AA01::15
domain-name example.com
!
ipv6 cef
multilink bundle-name authenticated
!
cts logging verbose
!
!
license udi pid CISCO1941W-C/K9 sn FGL15322615
hw-module ism 0
!
!
!
vtp mode transparent
username lenovo privilege 15 password 0 lenovo,!
!
redundancy
!         
!
vlan 10
name Wireless
!
vlan 100
name management
!
!
!
!
!
interface Tunnel100
no ip address
ipv6 address FEC0::1/64
tunnel source GigabitEthernet0/1
tunnel mode ipv6ip
tunnel destination 10.99.93.204
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2010:AA01:10::2/80
ipv6 enable
ipv6 dhcp server test
!
interface wlan-ap0
description Service module interface to manage the embedded AP
ip address 5.5.5.5 255.255.255.255
arp timeout 0
no mop enabled
no mop sysid
!
interface GigabitEthernet0/1
ip address 10.100.77.245 255.255.254.0
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Wlan-GigabitEthernet0/0
description Internal switch interface connecting to the embedded AP
switchport mode trunk
no ip address
!
interface GigabitEthernet0/1/0
no ip address
!
interface GigabitEthernet0/1/1
no ip address
!
interface GigabitEthernet0/1/2
no ip address
!
interface GigabitEthernet0/1/3
no ip address
!
interface GigabitEthernet0/1/4
no ip address
!
interface GigabitEthernet0/1/5
no ip address
!
interface GigabitEthernet0/1/6
no ip address
!
interface GigabitEthernet0/1/7
no ip address
!
interface Vlan1
ip address 10.1.1.1 255.255.255.0
ipv6 address 2001:1:1:1::1/64
!
interface Vlan100
ip address 172.29.29.1 255.255.255.0
ip nat inside
no ip virtual-reassembly in
ipv6 address 2403:5000:171:98::1/64
ipv6 enable
ipv6 nd managed-config-flag
ipv6 nd other-config-flag
ipv6 dhcp server vlan100v6
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!         
ip nat inside source list natacl interface GigabitEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 10.100.76.2
ip ssh version 2
!
ip access-list extended natacl
permit ip 172.29.29.0 0.0.0.255 any
!
ipv6 route ::/0 Tunnel100
!
!
!
control-plane
!
!
vstack
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line 67
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
login local
transport input ssh
!
scheduler allocate 20000 1000
!
end
-------------------------------------------------------------
AP配置:
Building configuration...

Current configuration : 2102 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ap
!
enable secret 5 $1$nP4/$.kqFOmuhSgPy4Gg6bzIml1
!
no aaa new-model
!
!
dot11 syslog
dot11 vlan-name userwifi vlan 100
!
dot11 ssid userwifi
   vlan 100
   authentication open
   authentication key-management wpa version 2
   guest-mode
   wpa-psk ascii 7 050703012E5A414558
!
!
!
username Cisco password 7 05280F1C2243
!
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
shutdown
antenna gain 0
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!         
interface Dot11Radio1
no ip address
no ip route-cache
!
encryption vlan 100 mode ciphers aes-ccm tkip
!
ssid userwifi
!
antenna gain 5
station-role root
bridge-group 1
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio1.100
encapsulation dot1Q 100
no ip route-cache
bridge-group 100
bridge-group 100 subscriber-loop-control
bridge-group 100 block-unknown-source
no bridge-group 100 source-learning
no bridge-group 100 unicast-flooding
bridge-group 100 spanning-disabled
!
interface GigabitEthernet0
description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router
no ip address
no ip route-cache
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface GigabitEthernet0.100
encapsulation dot1Q 100
no ip route-cache
bridge-group 100
no bridge-group 100 source-learning
bridge-group 100 spanning-disabled
!
interface BVI1
ip address 10.1.1.2 255.255.255.0
no ip route-cache
!         
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip
!
!
!
line con 0
no activation-character
line vty 0 4
login local
!
end
----------------------------------------------------------------
1941上debug ip dhcp server packet detail
IPV6-Test#
*Feb  7 03:15:00.743: DHCPD: client's VPN is .
*Feb  7 03:15:00.743: DHCPD: No option 125
*Feb  7 03:15:00.743: DHCPD: DHCPDISCOVER received from client 683e.34f5.29b4 on interface Vlan100.
*Feb  7 03:15:00.743: DHCPD: Sending DHCPOFFER to client 683e.34f5.29b4 (172.29.29.14).DHCPD: Setting only requested parameters

*Feb  7 03:15:00.743: DHCPD: no option 125
*Feb  7 03:15:00.743: DHCPD: ARP entry exists (172.29.29.14, 683e.34f5.29b4).
*Feb  7 03:15:00.743: DHCPD: unicasting BOOTREPLY to client 683e.34f5.29b4 (172.29.29.14).
*Feb  7 03:15:00.779: DHCPD: client's VPN is .
*Feb  7 03:15:00.779: DHCPD: No option 125
*Feb  7 03:15:00.779: DHCPD: DHCPREQUEST received from client 683e.34f5.29b4.
*Feb  7 03:15:00.779: DHCPD: Appending system default domain
*Feb  7 03:15:00.779: DHCPD: Using hostname 'MEIZU-MX6.lenovo.com.' for dynamic update (from hostname option)
*Feb  7 03:15:00.779: DHCPD: Sending DHCPACK to client 683e.34f5.29b4 (172.29.29.14).DHCPD: Setting only requested parameters

*Feb  7 03:15:03.019: DHCPD: client's VPN is .
*Feb  7 03:15:03.019: DHCPD: No option 125
*Feb  7 03:15:03.019: DHCPD: DHCPREQUEST received from client 683e.34f5.29b4.
*Feb  7 03:15:03.019: DHCPD: Appending system default domain
*Feb  7 03:15:03.019: DHCPD: Using hostname 'MEIZU-MX6.lenovo.com.' for dynamic update (from hostname option)
*Feb  7 03:15:03.019: DHCPD: Sending DHCPACK to client 683e.34f5.29b4 (172.29.29.14).DHCPD: Setting only requested parameters

*Feb  7 03:15:08.067: DHCPD: client's VPN is .
*Feb  7 03:15:08.067: DHCPD: No option 125
*Feb  7 03:15:08.067: DHCPD: DHCPREQUEST received from client 683e.34f5.29b4.
*Feb  7 03:15:08.067: DHCPD: Appending system default domain
*Feb  7 03:15:08.067: DHCPD: Using hostname 'MEIZU-MX6.lenovo.com.' for dynamic update (from hostname option)
*Feb  7 03:15:08.067: DHCPD: Sending DHCPACK to client 683e.34f5.29b4 (172.29.29.14).DHCPD: Setting only requested parameters

dhcp server回应了
DHCPACK,但是client一直获取不到地址。


  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2017-11-29 17:45:38 | 显示全部楼层
interface BVI1
ip address 10.1.1.2 255.255.255.0    为什么没有配置成跟内网地址一个网段?
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2017-12-5 13:59:17 | 显示全部楼层
楼主请参考一下:
1941W Can't Get IP via DHCP on BVI1
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 前天 10:58 | 显示全部楼层
您好,已有用户解答了您的问题,若您的问题已被解决,快来标记最佳答案吧!
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科服务支持社区  

GMT+8, 2017-12-13 07:30 , Processed in 0.085280 second(s), 33 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表