请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科服务支持社区 点击关注
思科服务支持社区

  
 找回密码
 立即注册

扫一扫,访问微社区

搜索
热搜: 邮件服务器
查看: 774|回复: 4

思科2921 路由器PPPoE 拨号后无法打开网页故障一例

[复制链接]
发表于 2017-12-13 10:11:19 | 显示全部楼层 |阅读模式
这几天有个客户说自己试着调试购买的思科2921路由,配置ADSL拨号上网,客户端电脑可以自动获取IP地址,但是上不了网,打不开网页。

配置如下:
Router>enable
Router#
Router#show running-config
Building configuration...

Current configuration : 1869 bytes
!
! Last configuration change at 23:47:22 UTC Mon Dec 11 2017
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
ip dhcp excluded-address 10.2.0.240 10.2.0.253
!
ip dhcp pool local
network 10.2.0.0 255.255.255.0
default-router 10.2.0.254
dns-server 10.2.0.254
!
!
!
ip name-server 202.96.128.86
ip name-server 202.96.134.133
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
vpdn enable
!
!
!
!
license udi pid CISCO2911/K9 sn FGL183010L9
!
!
!
redundancy
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description TO-ADSL
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface GigabitEthernet0/1
description INSIDE
ip address 10.2.0.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
interface Dialer1
description Vir-ADSL
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp pap sent-username xxxxxxxx@163.gd password 0 xxxxxxx
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip dns server
ip nat inside source list 10 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit
!
!
access-list 10 permit 10.2.0.0 0.0.0.255
!
control-plane
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
privilege level 15
password cisco
login local
transport input none
!
scheduler allocate 20000 1000
!
end

Router#
Router#
通过show interface dialer 1也可以获取到
Internetaddress ,可以ping 114.114.114.114 、ping www.baidu.com、ping 8.8.8.8但是,无法打开网页。

其实认真想一下就应该知道大概是什么原因了,就是MTU  、TCP-MSS,  先简单说一下这两个术语:
MTU: Maxitum Transmission Unit 最大传输单元
MSS: Maxitum Segment Size 最大分段大小


由于以太网EthernetII最大的数据帧是1518Bytes这样,刨去以太网帧的帧头(DMAC目的地址MAC48bit=6Bytes+SMAC源MAC地址48bit=6Bytes+Type域2bytes)14Bytes和帧尾CRC校验部分4Bytes(这个部门有时候大家也把它叫做FCS),那么剩下承载上层协议的地方也就是Data域最大就只能有1500Bytes. 这个值我们就把它称之为MTU。

以太网的MTU是1500,再减去PPP的包头包尾的开销(8Bytes),就变成1492。

MSS就是TCP数据包每次能够传输的最大数据分段。为了达到最佳的传输效能TCP协议在建立连接的时候通常要协商双方的MSS值,这个值TCP协议在实现的时候往往用MTU值代替(需要减去IP数据包包头的大小20Bytes和TCP数据段的包头20Bytes)所以往往MSS为1460。通讯双方会根据双方提供的MSS值得最小值确定为这次连接的最大MSS值。


故障分析:  
PPPoE 拨号需要额外8Byte 的开销,所以MTU 超过了其他通信设备默认的1500 最大值,导致某些不能分片的应用无法通讯

故障处理:
在dialer 接口下配置MTU  跟MSS 值为1400 后上网正常

ip mtu 1400
ip tcp adjust-mss 1400

  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分4 (3 评价)
发表于 2017-12-13 11:12:31 | 显示全部楼层
嗯,MTU在配置ADSL拨号的时候会被忽略,这个问题很早实施中遇到过一次
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分3 (2 评价)
发表于 2017-12-13 15:05:39 | 显示全部楼层
之前配置过1941,没在意这MTU的事,刚看了下MTU值是1492,这是默认值??
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分2 (2 评价)
发表于 2017-12-13 17:30:11 | 显示全部楼层
MTU这个是重点
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分2 (1 评价)
发表于 2017-12-19 08:47:44 | 显示全部楼层
这篇值得推荐,实际情况会遇到
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科服务支持社区  

GMT+8, 2018-1-19 01:36 , Processed in 0.080830 second(s), 38 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表