请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科服务支持社区 点击关注
思科服务支持社区

  
 找回密码
 立即注册

扫一扫,访问微社区

搜索
热搜: 邮件服务器
查看: 494|回复: 16

2911映射问题

[复制链接]
发表于 2017-12-27 11:22:13 | 显示全部楼层 |阅读模式
0可用金钱
大神 请教一下思科端口映射问题  2911的路由器下面直接接交换机  局域网内都可以正常上网  外网一个固定ip。1  做了映射 192.168.1.1 3389 10.1.1.1 3389 这样可以远程到1.1的桌面。但是改成192.168.1.1 3389 10.1.1.1 3390  只是把3389改成3390了 为什么就不能远程到1.1了? 求解答!!!

  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2017-12-27 14:10:18 | 显示全部楼层
重启试了吗,建议清一下映射表。或者看一下log
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2017-12-27 14:47:31 | 显示全部楼层
CSCO12370587 发表于 2017-12-27 14:10
重启试了吗,建议清一下映射表。或者看一下log

路由器和服务器都重启了,故障依旧···
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2017-12-28 08:57:43 | 显示全部楼层
这么说吧,技术上肯定可以实现的,要想判断问题出在哪里,还是贴一下完整配置,比较好。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2017-12-28 10:23:37 | 显示全部楼层
YilinChen 发表于 2017-12-28 08:57
这么说吧,技术上肯定可以实现的,要想判断问题出在哪里,还是贴一下完整配置,比较好。

Router#show running-config
Building configuration...

Current configuration : 2161 bytes
!
! Last configuration change at 03:07:24 UTC Tue Dec 26 2017 by bj
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
enable password
!
no aaa new-model
!
!
!
!
!
!
!
!
!
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.10
ip dhcp excluded-address 192.168.1.253
ip dhcp excluded-address 192.168.1.254
!
ip dhcp pool bj
network 192.168.1.0 255.255.255.0
default-router 192.168.1.254
dns-server 111.11.11.1
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
cts logging verbose
!
!
license udi pid CISCO2911/K9 sn FGL214190ML
!
!
username bj password 0 cisco
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 10.1.1.1  255.255.255.0
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface GigabitEthernet0/0 overload
ip nat inside source static tcp 192.168.1.1 3389 10.1.1.1 3390 extendable

ip route 0.0.0.0 0.0.0.0 10.1.1.2
!
!
!
access-list 1 permit 192.168.1.0 0.255.255.255
!
control-plane
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password cisco
login local
transport input telnet
!
scheduler allocate 20000 1000
!
end
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2017-12-28 11:06:09 | 显示全部楼层
1、先配置成3389端口,让远程桌面能正常运行,在内网抓一下包,看看整个连接建立的流程,然后以此建立模板。
2、修改端口到3390,确认一下客户端远程到10.1.1.1时,客户端确实是访问的3390端口而不是之前的3389端口。
3、在内网抓一下包,看看192.168.1.1的3389端口是不是收到了客户端的请求,把这个流程和之前能够正常连接的流程做一下对比,看看有什么不同,然后确认问题出在哪里。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2017-12-28 12:14:02 | 显示全部楼层
看配置没啥问题,show ip nat translations  看看 映射状态对不对,另,抓包是个好办法。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2017-12-28 14:54:06 | 显示全部楼层
cruiseluo 发表于 2017-12-28 11:06
1、先配置成3389端口,让远程桌面能正常运行,在内网抓一下包,看看整个连接建立的流程,然后以此建立模板 ...

你好 我按照你的方法做了 第一次用3389成功远程桌面后 可以看到并捕捉到抓包信息 而且信息正确
但我改了端口后 在抓包  客户端显示不能远程连接  内网抓包根本抓不到
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2017-12-28 18:29:34 来自手机 | 显示全部楼层
F22 发表于 2017-12-28 14:54
你好 我按照你的方法做了 第一次用3389成功远程桌面后 可以看到并捕捉到抓包信息 而且信息正确
但我改了 ...

如果有条件的话可以在2911的10.1.1.1那个端口上接台交换机,然后做端口映射,抓一下包,看看客户端的请求过来没有,如果请求都是正确的,就按照上面说的看看nat translation
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2017-12-28 18:29:57 来自手机 | 显示全部楼层
F22 发表于 2017-12-28 14:54
你好 我按照你的方法做了 第一次用3389成功远程桌面后 可以看到并捕捉到抓包信息 而且信息正确
但我改了 ...

如果有条件的话可以在2911的10.1.1.1那个端口上接台交换机,然后做端口映射,抓一下包,看看客户端的请求过来没有,如果请求都是正确的,就按照上面说的看看nat translation
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科服务支持社区  

GMT+8, 2018-1-19 01:31 , Processed in 0.091232 second(s), 50 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表