请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科服务支持社区 点击关注
思科服务支持社区

  
 找回密码
 立即注册

扫一扫,访问微社区

搜索
热搜: 邮件服务器
查看: 775|回复: 4

【原创】思科Nexus 9000交换机EPLD升级

[复制链接]
发表于 2018-1-10 10:29:47 | 显示全部楼层 |阅读模式

第一步:将epld镜像copy 到bootflash中
switch# copy usb1:n9000-epld.7.0.3.I7.2.img bootflash:
第二步:检查epld的兼容性,确认是否需要升级
switch# show install all impact epldbootflash:n9000-epld.7.0.3.I7.2.img
Retrieving EPLD versions... Please wait.
Images will be upgraded according tofollowing table:
Module Type   EPLD              Running-Version   New-Version Upg-Required
------ ----  -------------      ---------------   ----------- ------------
    1   SUP  MI FPGA                   0x05        0x07             Yes
    1   SUP  IO FPGA                   0x17        0x17             No
    1   SUP  MI FPGA2                  0x01       0x02             Yes
Compatibility check:
Module        Type         Upgradable        Impact  Reason
-------------------------------------------------
    1            SUP           Yes       disruptive   Module Upgradable
第三步:执行epld升级,EPLD升级完成之后,系统会自动重启
switch# install epld bootflash:n9000-epld.7.0.3.I7.2.imgmodule all
Compatibility check:
Module        Type         Upgradable        Impact  Reason
------ -----------------  ----------    ----------  ------
    1            SUP           Yes       disruptive   Module Upgradable
Retrieving EPLD versions... Please wait.
Images will be upgraded according tofollowing table:
Module Type   EPLD              Running-Version   New-Version Upg-Required
------ ----  -------------      ---------------   ----------- ------------
    1   SUP  MI FPGA                   0x05        0x07            Yes
    1   SUP  IO FPGA                   0x17        0x17             No
    1   SUP  MI FPGA2                  0x01        0x02            Yes
The above modules require upgrade.
The switch will be reloaded at the end ofthe upgrade
Do you want to continue (y/n) ?  [n] y
Proceeding to upgrade Modules.
Starting Module 1 EPLD Upgrade
2018 Jan 9 10:38:36 switch %$ VDC-1 %$ %USER-2-SYSTEM_MSG: <<%USBHSD-2-USB_SWAP>> USB insertion orremoval detected - usbhsd
2018 Jan 9 10:38:36 switch %$ VDC-1 %$ %USER-2-SYSTEM_MSG: <<%USBHSD-2-UMOUNT>> USB1: offline  - usbhsd
Module 1 : MI FPGA [Programming] :  42.19% (    27 of      64 sectors)
Module 1 : MI FPGA [Programming] : 100.00%(     64 of      64 sectors)
Module 2 : MI FPGA2 [Programming] : 100.00%(     64 of      64 sectors)
Module 1 EPLD upgrade is successful.
Module        Type Upgrade-Result
------ ------------------  --------------
    1         SUP         Success
EPLDs upgraded.
Module 1 EPLD upgrade is successful.
Reseting Active SUP (Module 1) FPGAs.Please wait...
[ 398.161483] [1515494467] Preparations for deep sleep now complete.

  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分5 (1 评价)
发表于 2018-1-10 14:18:50 | 显示全部楼层
N9K,市场上应用的多吗
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2018-1-10 15:04:12 | 显示全部楼层
13nash 发表于 2018-1-10 14:18
N9K,市场上应用的多吗

目前N9K在OTT行业应用的比较多,在企业网因为比6500,6800系列更具性价比,所以在企业网核心、企业网数据中心也有大规模的应用。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分3 (1 评价)
发表于 2018-1-10 16:50:06 | 显示全部楼层
感谢楼主分享,请问这个升级后,对IOS,KICKSTART之类的没影响吧。记得有一个表格是说这个对应匹配的版本号的。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2018-1-10 17:37:19 | 显示全部楼层
yiqilin 发表于 2018-1-10 16:50
感谢楼主分享,请问这个升级后,对IOS,KICKSTART之类的没影响吧。记得有一个表格是说这个对应匹配的版本号 ...

先升级NX-OS,然后在升级对应的EPLD,版本号需要一致
IOS和NX-OS没有任何联系
kickstart在7.0版本已经内置在NX-OS中,没有单独的kickstart了
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分3 (1 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科服务支持社区  

GMT+8, 2018-7-16 11:09 , Processed in 0.081453 second(s), 42 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表