请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

  思科 CCO 登录 推荐
 找回密码
 立即注册

搜索
热搜: 邮件服务器
查看: 1288|回复: 2

【原创】ASA Anyconnect 使用ISE认证

[复制链接]
发表于 2018-3-22 23:53:25 | 显示全部楼层 |阅读模式
第一部分

ASA anyconnect 基本配置
!
interface Ethernet0/0
switchport access vlan 10
!
interface Ethernet0/1
switchport access vlan 20
!

interface Vlan10
nameif outside
security-level 0
ip address 123.123.123.76 255.255.255.0
!
interface Vlan20
nameif inside
security-level 100
ip address 172.16.1.21 255.255.255.0
!
ip local pool Anyconnect-client 172.16.4.10-172.16.4.20 mask 255.255.255.0

object network inside
subnet 172.16.0.0 255.255.0.0
object network Anyconnect
subnet 172.16.4.0 255.255.255.0

access-list Anyconnect-split extended permit ip 172.16.1.0 255.255.255.0 any
access-list Anyconnect-split extended permit ip 172.16.2.0 255.255.255.0 any
access-list Anyconnect-split extended permit ip 172.16.3.0 255.255.255.0 any


nat (inside,outside) source static inside inside destination static Anyconnect Anyconnect  ###NAT环境下必须配置
!
object network inside
nat (inside,outside) dynamic interface
o
aaa-server ISE protocol radius       #########定义ISE
aaa-server ISE (inside) host 172.16.1.17
key cisco

webvpn
port 4433
enable outside
anyconnect image disk0:/anyconnect-win-2.5.2014-k9.pkg 1
anyconnect enable
tunnel-group-list enable

group-policy Anyconnect internal
group-policy Anyconnect attributes
vpn-tunnel-protocol ikev1 ikev2 ssl-client ssl-clientless
split-tunnel-policy tunnelspecified
split-tunnel-network-list value Anyconnect-split
address-pools value Anyconnect-client

vpn-group-policy Anyconnect
tunnel-group Anyconnect type remote-access
tunnel-group Anyconnect general-attributes
authentication-server-group ISE    ############制定采用ISE认证
default-group-policy Anyconnect
tunnel-group Anyconnect webvpn-attributes
group-alias Anyconnect enable

!

第二部分 ISE配置
添加ASA


修改默认认证策略,使用AD域作为认证数据库




创建授权策略,匹配AD的VPN 组时,permit access



本以为很简单的可以完成任务了,但是始终验证不通过,出现了下图的报错信息,中间在ISE删除ASA,然后重新添加,在ASA上重新添加ISE,都没有解决问题,最后实在没办法了,打上了最新的patch,问题就解决了。
所以当大家以后遇到无解的问题的时候不妨尝试软件版本试试
最后感谢CSC微信群中的同学@G_Chunlin 给予的建议与帮助。





本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分5 (2 评价)
发表于 2018-3-23 11:30:35 | 显示全部楼层
哈哈,这样的喜欢,支持
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分3 (1 评价)
发表于 2018-3-23 12:37:37 | 显示全部楼层
版本bug无处不在啊!
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分3 (1 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科社区  

GMT+8, 2018-11-21 22:55 , Processed in 0.090621 second(s), 40 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表