请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科服务支持社区 点击关注
思科服务支持社区

  
 找回密码
 立即注册

扫一扫,访问微社区

搜索
热搜: 邮件服务器
查看: 1194|回复: 16

一道NAT面试题引起的疑问

[复制链接]
发表于 2018-5-21 17:49:10 | 显示全部楼层 |阅读模式
0可用金钱
最初在网上看到一个公司的关于NAT的面试题目,内容如下:
————————————————————————————topo图和配置————————————————————————————

(lo0-outside)R1(f0/0-inside)--------------------------------(f0/0)R2

R1 config:
interface f0/0
  ip add 172.168.1.1 255.255.255.252
  ip nat inside
interface loopback 0
  ip add 10.10.10.1 255.255.255.0
  ip nat outside

ip nat inside source static tcp 20.20.20.1 23 10.10.10.254 23
ip route 20.20.20.0 255.255.255.0 172.168.1.2


R2 config:
interface f0/0
  ip add 172.168.1.2 255.255.255.252
interface loopback 0
  ip add 20.20.20.1 255.255.255.0

ip route 10.10.10.0 255.255.255.0 172.168.1.1

line vty 0 4
  password cisco
  login

————————————————————————————题目要求————————————————————————————
问题:如果在R1上telnet 10.10.10.254 会通吗?
如果通,请说明原因
如不通,请给出solution(只能修改R1配置)

——————————————————————————————————————————
大家先做做看,看能否搞定。
等有了答案后疑问才能发出来,得先卖个关子~~

  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分4 (3 评价)
发表于 2018-5-21 22:10:38 | 显示全部楼层
有意思的题目,应该是跟ip redirect 和arp 有关吧,明天试试
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分2 (1 评价)
发表于 2018-5-22 11:03:11 | 显示全部楼层
想了好久都没有看出来哪点有问题
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分2 (1 评价)
发表于 2018-5-22 16:54:30 | 显示全部楼层
TCP连接建立不了,第二个包是syn ack,之后R1没有ack,直接发了reset……
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分2 (1 评价)
 楼主| 发表于 2018-5-22 19:09:16 | 显示全部楼层
maguanghua2013 发表于 2018-5-22 16:54
TCP连接建立不了,第二个包是syn ack,之后R1没有ack,直接发了reset……

嗯,问题找到了,如何解决喃~~
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2018-5-23 19:55:07 | 显示全部楼层
Liyongg3135 发表于 2018-5-22 19:09
嗯,问题找到了,如何解决喃~~

R1发出的是映射了的,R2返回的包是inside到local,不是inside到outside,所以没匹配原来的nat条目……这咋解决
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2018-5-24 09:43:18 | 显示全部楼层
maguanghua2013 发表于 2018-5-23 19:55
R1发出的是映射了的,R2返回的包是inside到local,不是inside到outside,所以没匹配原来的nat条目……这 ...

没有匹配的条目,可想办法创建一条,找到了问题,离解决它就不远了~~~
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分5 (1 评价)
发表于 2018-5-28 12:04:11 | 显示全部楼层
本帖最后由 liuyj 于 2018-6-5 11:09 编辑

这个有点问题啊,回来的包不是指向outside的,而是指向local的
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2018-5-29 09:03:20 | 显示全部楼层
这题目有意思,但实际生产环境用不上
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2018-5-29 09:51:51 | 显示全部楼层
实验配置修改了好多次,就是不能!楼主赶快公布答案
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科服务支持社区  

GMT+8, 2018-6-22 00:29 , Processed in 0.092920 second(s), 58 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表