请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科服务支持社区 点击关注
思科服务支持社区

  
 找回密码
 立即注册

扫一扫,访问微社区

搜索
热搜: 邮件服务器
楼主: nmyp007

【跟我一起读】Cisco IPSec VPN实战指南

[复制链接]
发表于 2018-6-25 10:42:53 | 显示全部楼层

5、查看IPSec VPN的相关状态的命令?
sh crypto engine connections active
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分4 (4 评价)
发表于 2018-6-25 13:47:02 | 显示全部楼层
7、DMVPN相比于传统的IPSec VPN技术有哪些优点?
DMVPN相比于传统的IPSec VPN技术有如下4个优点:
·简单的星形拓扑配置,提供了虚拟网状连通性。
·分支站点支持动态IP地址。
·增加新的分支站点,无需更改中心站点配置。
·分支站点间流量,通过动态产生的站点间隧道进行封装。

8、DMVPN的4大组成协议?
·动态多点GRE(Multipoint GRE,mGRE)协议
·下一跳解析协议 (Next Hop Resolution Protocol,NHRP)
·动态路由协议
·IPSec技术

9、配置DMVPN的三大步骤?
环境:
1.R1:拥有固定公网IP地址:HUB
2.R2/R3:拨号上网,动态获得公网IP地址:SPOKE

1.配置Tunnel GRE
HUB配置:                                                         SPOKE 配置:
interface Tunnel0                                              interface Tunnel0
ip address 172.16.1.1 255.255.255.0                   ip address 172.16.1.2 255.255.255.0
tunnel source FastEthernet1/0                             tunnel source FastEthernet1/0
tunnel mode gre multipoint                                 tunnel mode gre multipoint
tunnel key 123            

2.配置NHRP协议:
HUB配置:                                                        SPOKE配置:
interface Tunnel0                                             interface Tunnel0
ip nhrp network-id 10                                       ip nhrp network-id 10
ip nhrp key 123                                               ip nhrp key 123
                                                                     ip nhrp nhs 172.16.1.1
                                                                     ip nhrp map 172.16.1.1 1.1.14.1


3.配置动态路由协议:(EIGRP)
HUB配置                                                                      SPOKE配置
HUB(config)#router eigrp 90                                          SPOKE(config)#router eigrp 90
HUB(config-router)#no au                                             SPOKE(config-router)#no au
HUB(config-router)#net 172.16.1.0 0.0.0.255                  SPOKE(config-router)#net 172.16.1.0 0.0.0.255
HUB(config-router)#net 1.1.1.1 0.0.0.0                           SPOKE(config-router)#net 1.1.1.1 0.0.0.0


4.配置IPSec VPN
HUB(config)#crypto isakmp policy 10
HUB(config-isakmp)#authentication pre
HUB(config-isakmp)#encryption des
HUB(config-isakmp)#hash md5
HUB(config-isakmp)#group 2
HUB(config-isakmp)#exit
HUB(config)#crypto isakmp key cisco add 0.0.0.0
HUB(config)#crypto ipsec transform-set TS esp-des esp-md5-hmac
HUB(config)#crypto ipsec profile POLICY
HUB(ipsec-profile)#exit
HUB(config)#int tunnel 0
HUB(config-if)#tunnel protection ipsec profile POLICY

R2/R3的配置:
crypto isakmp policy 10
hash md5
authentication pre-share
group 2
crypto isakmp key cisco address 0.0.0.0 0.0.0.0
crypto ipsec transform-set TS esp-des esp-md5-hmac
crypto ipsec profile POLICY
set transform-set TS
int tun 0
tunnel prote ipsec pro POLICY

HUB(ipsec-profile)#set transform-set TS

10、GETVPN的特点?
·可以实现任意的连接(Any-to Any Connectivity)
·扩展性高(Scalable)
·可以实现实时连接(Real Time)





  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分2 (1 评价)
发表于 2018-6-25 22:13:21 | 显示全部楼层
优点
1.  简单的星形拓扑配置,提供了虚拟网状连通性。
2.  分支站点支持动态获取地址。
3.  增加新的分支站点,无需更改中心站点配置。
4.  分支站点到分支站点动态产生隧道。
DMVPN的4大组成协议
1Multiple GRE(MGRE)---动态多点GRE
2Next Hop Resolution Protocol(NHRP)---下一跳解析协议
3:动态路由协议
4:IPSec技术

GETVPN的特点
实现任意到任意的连接;扩展性高;实时连接;
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分2 (1 评价)
发表于 2018-6-25 23:34:45 | 显示全部楼层
IPSec VPN 这本书我也有,明天看看再来回答问题
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分2 (1 评价)
发表于 2018-6-26 20:40:47 | 显示全部楼层
7、DMVPN相比于传统的IPSec VPN技术有哪些优点?
DMVPN相比于传统的IPSec VPN技术有如下四个有点:
一、简单的星型拓扑配置,提供了虚拟网状连通性
二、分支站点支持动态IP地址
三、增加新的分支站点,无需更改中心站点配置
四、分支站点间流量,通过动态产生的站点间隧道进行封装

8、DMVPN的4大组成协议?
一、动态多点GRE(Multipoint GRE,mGRE)协议
二、下一跳解析协议(Next Hop Resolution Protocol,NHRP)
三、动态路由协议
四、IPsec技术
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分4 (2 评价)
发表于 2018-6-27 07:51:35 | 显示全部楼层
7.
DMVPN相比于传统的IPSec VPN技术有哪些优点?
DMVPN相比于传统的IPSec VPN技术有如下4个优点:
·简单的星形拓扑配置,提供了虚拟网状连通性。
·分支站点支持动态IP地址。
·增加新的分支站点,无需更改中心站点配置。
·分支站点间流量,通过动态产生的站点间隧道进行封装。

8、
·动态多点GRE(Multipoint GRE,mGRE)协议
·下一跳解析协议 (Next Hop Resolution Protocol,NHRP)
·动态路由协议
·IPSec技术
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分4 (2 评价)
发表于 2018-6-27 16:45:06 | 显示全部楼层
7、DMVPN相比于传统的IPSec VPN技术有哪些优点?
答:1).支持分支采用动态地址 2).扩展性好——增加分支站点后无需修改中心站点的配置。3).分支节点的流量可以不通过hub ,分担中心流量。4).使用虚拟网络保证连通性(tunnel)
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分2 (1 评价)
发表于 2018-6-27 16:45:44 | 显示全部楼层
8、DMVPN的4大组成协议?
答:(1).动态多点 GRE(mGRE)协议(2).下一跳解析协议(NHRP)(3).动态路由协议(4).ipsec 技术
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分2 (1 评价)
发表于 2018-6-27 16:46:54 | 显示全部楼层
9、配置DMVPN的三大步骤?
答:(1)通过mGRE的封装代替p-t-p GRE封装来减少手动tunnel 数量及有效结合NHRP。 (2)mGRE的下一跳动态解析功能通过NHRP来实现,以便动态建立保护网络间的临时tunnel.(保护网络要路由通告出去或分布) (3)通过ipsec profile 实现 ipsec automatic proxy 功能;保护GRE封装流量,加密根据NHRP和动态路由协议建立起来的保护网络间的临时tunnel。(由于是动态方式,IKE 的远程对端IP为0.0.0.0)
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分2 (1 评价)
发表于 2018-6-27 16:55:30 | 显示全部楼层
10、GETVPN的特点?
答:第一是任意到任意连接,第二是高扩展性,第三是实时连接。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分2 (1 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科服务支持社区  

GMT+8, 2018-7-23 21:37 , Processed in 0.105828 second(s), 54 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表