请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

  思科 CCO 登录 推荐
 找回密码
 立即注册

搜索
热搜: 邮件服务器
查看: 769|回复: 11

求教最快速查看交换机各端口当前设备IP地址的命令组合

[复制链接]
发表于 2018-12-5 20:30:00 | 显示全部楼层 |阅读模式
1可用金钱
求教最快速查看交换机各端口当前设备IP地址的命令组合。
因为单位有大量的POE交换机,也使用了大量的IP话机(Avaya),交换机端口都配置了data VLAN和voice VLAN,有些端口接两个设备(先连接到话机,话机上有网口再连接电脑),话机和电脑都是DHCP,但是获取的地址网段不同;有些端口则只连接了一台电脑。
问题来了,如何快速从交换机上查看到所有端口,哪些连接了话机和电脑,哪些只连接了电脑,它们的IP地址分别是什么?
附上接入交换机的端口配置

vlan internal allocation policy ascending
!
vlan 100
name Video_Conference
!
vlan 200
name PBX
!
!
!
!
!
!
!
!
!
!
!
interface Port-channel10
switchport mode trunk
speed nonegotiate
!
interface FastEthernet0
no ip address
shutdown
!
interface GigabitEthernet1/0/1
switchport mode access
switchport voice vlan 200
switchport port-security maximum 2
switchport port-security violation  restrict
switchport port-security aging time 2
switchport port-security aging type inactivity
switchport port-security
macro description cisco-desktop | cisco-desktop
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/2
switchport mode access
switchport voice vlan 200
switchport port-security maximum 2
switchport port-security violation  restrict
switchport port-security aging time 2
switchport port-security aging type inactivity
switchport port-security
macro description cisco-desktop | cisco-desktop
spanning-tree portfast
spanning-tree bpduguard enable
!




interface GigabitEthernet1/0/25
description link to 3850_Coreswitch
switchport mode trunk
speed nonegotiate
channel-group 10 mode on
!
interface GigabitEthernet1/0/26
description link to 3850_Coreswitch
switchport mode trunk
speed nonegotiate
channel-group 10 mode on
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
ip address 10.12.124.57 255.255.252.0
no ip route-cache
!


最佳答案

查看完整内容

show ip arp 找出 ip地址对应的mac地址 show mac address-table 找出 MAC地址对应的接口 把两部分信息放到excel里,已mac地址排序,就能对应起来了。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2018-12-5 20:30:01 | 显示全部楼层
show ip arp 找出  ip地址对应的mac地址
show mac address-table 找出  MAC地址对应的接口
把两部分信息放到excel里,已mac地址排序,就能对应起来了。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分5 (1 评价)
发表于 2018-12-7 13:07:13 | 显示全部楼层
show arp可以看下
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2018-12-8 03:18:17 | 显示全部楼层

很多在用的设备IP地址用show arp看不到的。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2018-12-10 11:28:10 | 显示全部楼层
show ip int b
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2018-12-11 11:35:31 | 显示全部楼层
show ip arp?
show cdp nei 不过这个是针对思科的话机,SEP开头
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2018-12-11 15:19:41 | 显示全部楼层
show ip source binding,会显示该交换机所连的所有设备的动态ip地址。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2018-12-12 11:02:00 | 显示全部楼层
show ip int bri
show ip source bind
show ip dhcp bind
show ip arp dynamic
差不多就这些吧。。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分3 (1 评价)
发表于 2018-12-12 16:40:50 | 显示全部楼层
show ip inter brief
show ip dh b
show ip arp
show mac address-table
show inter status
show inter brief
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2018-12-13 08:15:32 | 显示全部楼层
fengxue801568 发表于 2018-12-8 03:18
很多在用的设备IP地址用show arp看不到的。

那就show mac address-table然后根据mac地址去查arp
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科社区  

GMT+8, 2019-2-23 11:29 , Processed in 0.104755 second(s), 55 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表