请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

  思科 CCO 登录 推荐
 找回密码
 立即注册

搜索
热搜: 邮件服务器
查看: 519|回复: 2

MPLS-CSC简单实验(一)

[复制链接]
发表于 2018-12-29 17:18:01 | 显示全部楼层 |阅读模式













MPLS inter-AS CSC Model









版本记录
文档属性
  属性
  
  内容
  
  名称:
  
  MPLS inter-AS CSC Model
  
  编号:
  
  WTJCZ2017200-1
  
  标题:
  

  
  版本号:
  
  
  
  版本日期:
  
  2018年11月19日
  
  作    者:
  
  



文档变更过程
  版本
  
  修正日期
  
  修正人
  
  修正内容描述
  
  Ver 1.0.1
  
  11月14

  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  



   

1      前言. 4
2      使用的组件. 5
3      网络拓扑. 5
4      骨干AS控制层面配置. 6
4.1           域内ipv4路由. 6
4.2           域内VPNv4路由. 7
4.3           域间ipv4路由(可选). 8
4.4           域间VPNv4路由. 8
5      次级AS控制层面配置. 9
5.1           域内ipv4路由. 10
5.2           域内VPNv4/l2VPN路由. 10
5.3           域间ipv4路由(可选). 10
5.4           跨域ipv4路由. 10
5.5           跨域VPNv4/l2VPN路由. 12
6      转发平面配置思路. 13
6.1           构建LSP隧道. 13
6.2           流量工程:邻接转发(可选). 13
6.3           流量工程:隧道保护(可选). 14
6.3.1     路径保护. 14
6.3.2     快速重路由. 15
6.4           验证LSP隧道. 16
6.5           标签分析. 16
6.5.1     PE端标签分析. 17
6.5.2     P节点标签分析. 18
7      CE与PE设备对接. 19
7.1           OSPF双点接入. 19
7.1.1     环路问题. 20
7.1.2     次优路径. 22
7.1.3     虚电路Sham-link 23
7.2           Overlay双点接入. 24
7.2.1     解决方案. 25
7.2.2     配置思路. 26
7.3           l2VPN多点接入. 28
7.3.1     基于LDP信令. 28
7.3.2     基于BGP信令. 29
7.4           BGP双点接入. 29

1  前言CSC(Carrier Supporting Carrier)通常应用于一个运营商需要通过另一运营商提供传输服务的场景,提供传输服务的运营商称为“backbone carrier”,被传输的运营商称为“customer carrier”,可以是ISP服务商,也可以是MPLS VPN服务商。
Backbone carrier提供MPLS VPN服务给Customer Carrier,Customer Carrier给最终用户提供MPLS VPN(Internet)服务。Customer Carrier的ISPX-POP1和ISPX-POP2维护VRF路由信息(最终用户),使用MP-BGP会话来传输VPNv4信息。VPNv4标签交换对于backbone carrier来说是透明的,backbone carrier只维护customer Carrier的interanl路由,不包含最终用户的路由。


2  使用的组件firmware版本
CSR-1000V:Cisco IOS Software [Fuji], Virtual XE Software(X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 16.7.1, RELEASE SOFTWARE (fc6)
XRv: CiscoIOS XR Software, Version 6.1.3
VPCS: VirtualPC Simulator, version 1.0 (0.8c)

3  网络拓扑




4  骨干AS控制层面配置

骨干自治系统内使用OPTIONB跨域也叫单跳MP-EBGP跨域,AS内通过正常的MPLS/BGP传递VPN信息和构建LSP隧道,AS之间通过单跳的MP-EBGP协议传递VPN信息并构建LSP隧道。

该方式需要在ASBR之间运行MP-eBGP,当ASBR学习到本端自治域PE所通告的VPN路由后,进行一个标签替换,将路由信息和新的标签通告给对端ASBR。在进行报文转发时,域内使用两层标签转发,ASBR之间采用一层标签转发,并且根据实现的细节可能需要在ASBR上完成对内层标签的替换。
优点:ASBR之间一条链路传递所有VPN信息。不需要ASBR为每个VPN配置VRF,不需要导入VPN路由,不需要为每个VPN分配接口。
缺点:ASBR仍需要维护所有的VPN路由,并且为每个标签分配新的标签,在本地安装新老标签转换的ILM表项,因此对于ASBR路由器的设备性能要求比较高。
特点:当VPN业务发展到一定阶段,ASBR之间的链路受限时,可以考虑OPTIONB跨域方法。对于一些超大型网络不太适合,但对于一般中型或大型网络是合适的。



4.1  域内ipv4路由在各AS内部使用链路状态IGP,ISIS使得路由器环回口可达。
router isis 65001
is-type level-2-only
net49.10.0000.0000.0001.00
logadjacency changes
address-family ipv4 unicast
metric-style wide
segment-routing mpls
!
interface Loopback0
point-to-point
address-family ipv4 unicast
  prefix-sid index 1
  !
!
interface GigabitEthernet0/0/0/0
point-to-point
address-family ipv4 unicast
  !
!
interface GigabitEthernet0/0/0/1
point-to-point
address-family ipv4 unicast
  !
!
interface GigabitEthernet0/0/0/2
point-to-point
address-family ipv4 unicast
  !
!
interface GigabitEthernet0/0/0/3
point-to-point
address-family ipv4 unicast
  !
!
interface GigabitEthernet0/0/0/4
point-to-point
address-family ipv4 unicast
  !
!
!
4.2  域内VPNv4路由在各AS内的RR与PE之间,RR与ASBR之间,使用MP-iBGP建立VPNv4-unicast邻居关系,由RR反射VPNv4路由前缀信息给MP-iBGP邻居。
router bgp 65001
bgprouter-id 10.255.255.1
bgpcluster-id 10.255.255.1
address-family vpnv4 unicast
!
neighbor-group ibgp
remote-as 65001
update-source Loopback0
address-family vpnv4 unicast
  route-reflector-client
  !
!
neighbor 10.255.255.7
  useneighbor-group ibgp
!
neighbor 10.255.255.8
  useneighbor-group ibgp
!
neighbor 10.255.255.9
  useneighbor-group ibgp
!
neighbor 10.255.255.10
  useneighbor-group ibgp
!
4.3  域间ipv4路由(可选)
1.        使用接口直连,无需配置。
2.        在AS之间的ASBR之间使用静态路由方式指向对端设备环回接口。
4.4  域间VPNv4路由在ASBR上关闭route-target过滤来接收VPNv4路由前缀,使用RPL放行EBGP邻居更新过来的VPNV4路由前缀。
1.        在AS之间的ASBR之间使用单跳MP-eBGP建立VPNV4-unicast邻居关系,相互更新VPNv4路由前缀信息,并使用next-hop-self优化RR上VPNv4路由前缀的下一跳可达性,即内层标签为AS内ASBR设备分发。(cisco option2a)

router bgp65001

bgp router-id 10.255.255.7
address-family vpnv4 unicast
  retain route-target all
!
neighbor-group ebgp
  remote-as 65003
  address-family vpnv4 unicast
   route-policy pass in
   route-policy pass out
  !
!
neighbor-group ibgp
  remote-as 65001
  update-source Loopback0
  address-family vpnv4 unicast
   next-hop-self
  !
!
neighbor 16.7.0.16
  use neighbor-group ebgp
!
neighbor 10.255.255.1
  use neighbor-group ibgp
!
neighbor 10.255.255.2
  use neighbor-group ibgp
!
!
2.        在AS之间的ASBR之间使用静态路由方式指向对端设备环回接口,并使用多跳MP-eBGP建立VPNv4-unicast邻居关系,相互更新VPNv4路由前缀信息,并使用next-hop-self优化RR上VPNv4路由前缀的下一跳可达性,即内层标签为AS内ASBR设备分发。(cisco option2b)
3.        在AS之间的ASBR之间使用静态路由方式指向对端设备环回接口,并使用多跳MP-eBGP建立VPNv4-unicast邻居关系,相互更新VPNv4路由前缀信息。采用在IGP中重分发静态路由方式来优化RR上VPNv4路由前缀的下一跳可达性,即内层标签为对端ASBR设备分发。(ciscooption2c)


5     次级AS控制层面配置各地次级AS内使用OPTION C跨域也叫多跳MP-EBGP跨域,由于BGP只要能建立TCP连接,就能成为BGP邻居并传递路由信息,因此,OPTIONC通过多跳的MP-EBGP直接在源、宿端PE之间传递VPN路由信息,然后在源、宿端PE之间构建LSP公网隧道。
该方式首先需要在不同AS域的PE之间建立跨域的LSP(域内采用LDP分发标签,域间采用单跳eBGP分发标签),然后不同AS域的PE通过多跳MP-eBGP传播VPN路由信息。在进行报文转发时,域内使用三层标签转发,ASBR之间采用两层标签转发。
优点:ASBR不需要处理VPN信息,最符合VPN的要求,即中间设备不感知VPN信息。
缺点:这种方式需要在域之间互相通告环回接口的路由,造成所谓的路由泄漏问题。同时由于需要建立跨域的LSP,在管理上带来较大的麻烦。另外,由于跨域同一VPN的所有PE之间都要建立eBGP连接,存在严重的扩展性问题。
特点:这种方式主要针对B方式的不足加以解决,不需要在ASBR上维护具体用户的VPN路由信息,将VPN路由的处理处理压力分散到PE上,它适合于大型的网络。当VPN业务大规模发展时,可以使用OPTIONC跨域方法。


5.1  域内ipv4路由在各次级运营商AS内部使用IGP,链路状态协议OSPF使得路由器环回口可达。
router ospf 65108
router-id 0.0.0.23
mpls ldp autoconfig area 0
!
interface GigabitEthernet1
ip ospf network point-to-point
ip ospf 65108 area 0
5.2  域内VPNv4/l2VPN路由在各次级运营商AS内的RR与PE上使用MP-iBGP建立VPNv4-unicast邻居关系,由RR反射VPNv4路由前缀信息,在RR上检查VPNv4路由前缀信息。
在各次级运营商AS内的RR与PE上使用MP-iBGP建立l2VPN-vpls邻居关系,由RR反射l2VPN-vpls路由前缀信息,在RR上检查l2VPN-vpls路由前缀信息。
===============================================PE设备============================================
router bgp 65108
bgp router-id 192.168.255.26
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 192.168.255.24 remote-as 65108
neighbor 192.168.255.24 update-sourceLoopback0
!
address-family vpnv4
neighbor 192.168.255.24 activate
neighbor 192.168.255.24 send-community extended
exit-address-family
!
address-family l2VPN vpls
neighbor 192.168.255.24 activate
neighbor 192.168.255.24 send-community both
neighbor 192.168.255.24 suppress-signaling-protocol ldp
exit-address-family
!
exit-address-family
5.3  域间ipv4路由(可选)
1.        使用接口直连,无需配置。
2.        在ASBR与骨干PE之间使用静态路由方式指向对端设备环回接口。
5.4  跨域ipv4路由在域内ASBR与骨干区域PE之间使用单跳MP-eBGP构建ipv4 labele-unicast邻居关系。使用路由策略语言匹配域内设备环回口,并且单向重分部IGP进入BGP。
在域内ASBR与RR之间,RR与PE之间,使用MP-iBGP构建ipv4 labele-unicast邻居关系。由ASBR更新ipv4路由前缀给RR,再反射ipv4路由前缀信息给PE,并在ASBR上使用next-hop-self优化RR与PE上的ipv4路由前缀下一跳可达性。
在各域的ASBR和RR、PE上检查ipv4路由前缀信息,保证主机路由可达性,即32位环回口地址到任意节点可达。
================================================骨干PE设备===============================================
router bgp 65002
vrf SP
  rdauto
address-family ipv4 unicast
  allocate-label all
  !
neighbor 14.22.0.22
  remote-as 65108
  address-family ipv4 labeled-unicast
   route-policy pass in
   route-policy pass out
!
=================================================ASBR设备================================================
router bgp 65108
bgprouter-id 14.22.0.14
bgplog-neighbor-changes
nobgp default ipv4-unicast
neighbor 14.22.0.14 remote-as 65002
neighbor 192.168.255.24 remote-as 65108
neighbor 192.168.255.24 update-sourceLoopback0
!
address-family ipv4
redistribute ospf 65108
neighbor 14.22.0.14 activate
neighbor 14.22.0.14 send-label
neighbor 192.168.255.24 activate
neighbor 192.168.255.24 next-hop-self
neighbor 192.168.255.24 send-label
exit-address-family
==================================================RR设备=================================================
router bgp 65108
bgprouter-id 192.168.255.24
bgpcluster-id 192.168.255.24
bgplog-neighbor-changes
nobgp default ipv4-unicast
neighbor 192.168.254.34 remote-as 65109
neighbor 192.168.254.34 ebgp-multihop 255
neighbor 192.168.254.34 update-sourceLoopback0
neighbor 192.168.255.22 remote-as 65108
neighbor 192.168.255.22 update-sourceLoopback0
neighbor 192.168.255.25 remote-as 65108
neighbor 192.168.255.25 update-sourceLoopback0
neighbor 192.168.255.26 remote-as 65108
neighbor 192.168.255.26 update-sourceLoopback0
!
address-family ipv4
neighbor 192.168.255.22 activate
neighbor 192.168.255.22 route-reflector-client
neighbor 192.168.255.22 send-label
neighbor 192.168.255.25 activate
neighbor 192.168.255.25 route-reflector-client
neighbor 192.168.255.25 send-label
neighbor 192.168.255.26 activate
neighbor 192.168.255.26 route-reflector-client
neighbor 192.168.255.26 send-label
exit-address-family
!
=================================================PE设备==================================================
router bgp 65108
bgprouter-id 192.168.255.26
bgplog-neighbor-changes
nobgp default ipv4-unicast
neighbor 192.168.255.24 remote-as 65108
neighbor 192.168.255.24 update-sourceLoopback0
!
address-family ipv4
neighbor 192.168.255.24 activate
neighbor 192.168.255.24 send-label
exit-address-family
5.5  跨域VPNv4/l2VPN路由在次级AS之间的RR上使用多跳MP-eBGP建立VPNV4-unicast邻居关系,相互更新VPNv4路由前缀信息,并使用next-hop-unchanged优化PE-PE路径,即内层标签为对端PE分发。
在次级AS之间的RR上使用多跳MP-eBGP建立l2VPN-vpls邻居关系,相互更新VPNv4路由前缀信息,并使用next-hop-unchanged优化PE-PE路径,即内层标签为对端PE分发。
===================================================RR设备================================================
router bgp 65108
bgprouter-id 192.168.255.24
bgpcluster-id 192.168.255.24
bgplog-neighbor-changes
nobgp default ipv4-unicast
neighbor 192.168.254.34 remote-as 65109
neighbor 192.168.254.34 ebgp-multihop 255
neighbor 192.168.254.34 update-sourceLoopback0
neighbor 192.168.255.22 remote-as 65108
neighbor 192.168.255.22 update-sourceLoopback0
neighbor 192.168.255.25 remote-as 65108
neighbor 192.168.255.25 update-sourceLoopback0
neighbor 192.168.255.26 remote-as 65108
neighbor 192.168.255.26 update-sourceLoopback0
!
address-family vpnv4
neighbor 192.168.254.34 activate
neighbor 192.168.254.34 send-community extended
neighbor 192.168.254.34 next-hop-unchanged
neighbor 192.168.255.26 activate
neighbor 192.168.255.26 send-community extended
neighbor 192.168.255.26 route-reflector-client
exit-address-family
!
address-family l2vpn vpls
neighbor 192.168.254.34 activate
neighbor 192.168.254.34 send-community both
  neighbor192.168.254.34 next-hop-unchanged
neighbor 192.168.254.34 suppress-signaling-protocol ldp
neighbor 192.168.255.25 activate
neighbor 192.168.255.25 send-community both
neighbor 192.168.255.25 route-reflector-client
neighbor 192.168.255.25 suppress-signaling-protocol ldp
neighbor 192.168.255.26 activate
neighbor 192.168.255.26 send-community both
neighbor 192.168.255.26 route-reflector-client
neighbor 192.168.255.26 suppress-signaling-protocol ldp
exit-address-family




相关分享
MPLS-CSC简单实验(二)标签分析

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 7 天前 | 显示全部楼层
学习了,很好的分享,赞
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 7 天前 | 显示全部楼层
谢谢楼主分享,赞一个
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科社区  

GMT+8, 2019-3-25 00:34 , Processed in 0.103106 second(s), 38 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表