请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

   思科 CCO 登录 推荐
 找回密码
 立即注册

搜索
热搜: 邮件服务器
查看: 646|回复: 7

请教一个主备网络中,主机频繁切换导致闪断问题

[复制链接]
发表于 2019-1-2 12:04:12 | 显示全部楼层 |阅读模式
10可用金钱
本帖最后由 xy411381121 于 2019-1-2 12:05 编辑

网络结构如下:

两台N7K将各自的E1/1与E2/1口聚合后连接;
N7K的E1/9与E2/9口聚合后与楼层接入交换机的T1/1/1与T1/1/2口连接;
终端主机采用双网卡绑定,主备模式,分别连接两台接入交换机。

配置如下:
N7K_01:
interface Vlan11
  no shutdown
  ip address 172.26.11.2/25
  ip router eigrp 600
  hsrp 11
    preempt
    priority 110
    ip 172.26.11.1
interface port-channel1
  description to N7K_02
  switchport
  switchport mode trunk
interface port-channel9
  switchport
  switchport mode trunk
interface Ethernet1/1
  description to N7K_02
  switchport
  switchport mode trunk
  channel-group 1
  no shutdown
interface Ethernet1/9
  description TO 6A_SW01
  switchport
  switchport mode trunk
  channel-group 9 mode active
  no shutdown
interface Ethernet2/1
  description to N7K_02
  switchport
  switchport mode trunk
  channel-group 1
  no shutdown
interface Ethernet2/9
  description TO 6A_SW01
  switchport
  switchport mode trunk
  channel-group 9 mode active
  no shutdown

N7K_02:
interface Vlan11
  no shutdown
  ip address 172.26.11.3/25
  ip router eigrp 600
  hsrp 11
    preempt
    ip 172.26.11.1
interface port-channel1
  description to N7K_01
  switchport
  switchport mode trunk
interface port-channel9
  switchport
  switchport mode trunk
interface Ethernet1/1
  description to N7K_01
  switchport
  switchport mode trunk
  channel-group 1
  no shutdown
interface Ethernet1/9
  description TO 6A_SW02
  switchport
  switchport mode trunk
  channel-group 9 mode active
  no shutdown
interface Ethernet2/1
  description to N7K_01
  switchport
  switchport mode trunk
  channel-group 1
  no shutdown
interface Ethernet2/9
  description TO 6A_SW02
  switchport
  switchport mode trunk
  channel-group 9 mode active
  no shutdown

6A_SW01:
vlan 11
interface Port-channel1
  switchport trunk encapsulation dot1q
  switchport mode trunk
interface GigabitEthernet1/0/38
  switchport access vlan 11
  switchport mode access
interface TenGigabitEthernet1/1/1
  description TO N7K_01
  switchport trunk encapsulation dot1q
  switchport mode trunk
  channel-group 1 mode active
interface TenGigabitEthernet1/1/2
  description TO N7K_01
  switchport trunk encapsulation dot1q
  switchport mode trunk
  channel-group 1 mode active
interface Vlan11
  ip address 172.26.11.117 255.255.255.128
ip route 0.0.0.0 0.0.0.0 172.26.11.1

6A_SW02:
vlan 11
interface Port-channel1
  switchport trunk encapsulation dot1q
  switchport mode trunk
interface GigabitEthernet1/0/38
  switchport access vlan 11
interface TenGigabitEthernet1/1/1
  description TO N7K_02
  switchport trunk encapsulation dot1q
  switchport mode trunk
  channel-group 1 mode active
interface TenGigabitEthernet1/1/2
  description TO N7K_02
  switchport trunk encapsulation dot1q
  switchport mode trunk
  channel-group 1 mode active
interface Vlan11
  ip address 172.26.11.118 255.255.255.128
ip route 0.0.0.0 0.0.0.0 172.26.11.1

前段时间,工作站网络断开,登录到接入路由器,发现如下日志:
6A_SW01:
Dec 27 20:21:32.020: %SW_MATM-4-MACFLAP_NOTIF: Host fc4d.d43d.59cc in vlan 11 is flapping between port Gi1/0/38 and port Po1
Dec 27 20:21:33.455: %SW_MATM-4-MACFLAP_NOTIF: Host 6805.ca17.94c5 in vlan 11 is flapping between port Po1 and port Gi1/0/38
Dec 27 20:22:51.607: %SW_MATM-4-MACFLAP_NOTIF: Host fc4d.d43d.59cc in vlan 11 is flapping between port Gi1/0/38 and port Po1
Dec 27 20:28:12.967: %SW_MATM-4-MACFLAP_NOTIF: Host fc4d.d43d.59cc in vlan 11 is flapping between port Gi1/0/38 and port Po1
Dec 27 20:31:04.329: %SW_MATM-4-MACFLAP_NOTIF: Host 6805.ca17.94c5 in vlan 11 is flapping between port Gi1/0/38 and port Po1
Dec 27 20:37:15.413: %SW_MATM-4-MACFLAP_NOTIF: Host fc4d.d43d.59cc in vlan 11 is flapping between port Gi1/0/38 and port Po1
Dec 27 20:37:16.822: %SW_MATM-4-MACFLAP_NOTIF: Host 6805.ca17.94c5 in vlan 11 is flapping between port Po1 and port Gi1/0/38
Dec 27 20:38:42.348: %SW_MATM-4-MACFLAP_NOTIF: Host fc4d.d43d.59cc in vlan 11 is flapping between port Gi1/0/38 and port Po1
Dec 27 20:41:49.983: %SW_MATM-4-MACFLAP_NOTIF: Host 6805.ca17.94c5 in vlan 11 is flapping between port Gi1/0/38 and port Po1
Dec 27 20:42:10.132: %SW_MATM-4-MACFLAP_NOTIF: Host 6805.ca17.94c5 in vlan 11 is flapping between port Po1 and port Gi1/0/38
Dec 27 20:44:08.908: %SW_MATM-4-MACFLAP_NOTIF: Host 6805.ca17.94c5 in vlan 11 is flapping between port Po1 and port Gi1/0/38
Dec 27 20:46:39.677: %SW_MATM-4-MACFLAP_NOTIF: Host fc4d.d43d.59cc in vlan 11 is flapping between port Gi1/0/38 and port Po1
Dec 27 20:46:40.961: %SW_MATM-4-MACFLAP_NOTIF: Host 6805.ca17.94c5 in vlan 11 is flapping between port Po1 and port Gi1/0/38
Dec 27 20:54:29.499: %SW_MATM-4-MACFLAP_NOTIF: Host fc4d.d43d.59cc in vlan 11 is flapping between port Gi1/0/38 and port Po1
Dec 27 20:56:14.485: %SW_MATM-4-MACFLAP_NOTIF: Host fc4d.d43d.59cc in vlan 11 is flapping between port Gi1/0/38 and port Po1
Dec 27 20:56:15.777: %SW_MATM-4-MACFLAP_NOTIF: Host 6805.ca17.94c5 in vlan 11 is flapping between port Po1 and port Gi1/0/38
Dec 27 20:58:50.908: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/38, changed state to down
Dec 27 20:58:51.923: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/38, changed state to down
Dec 27 20:58:54.683: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/38, changed state to up
Dec 27 20:58:55.689: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/38, changed state to up
Dec 28 01:20:12.879: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/38, changed state to down
Dec 28 01:20:13.894: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/38, changed state to down
Dec 28 01:21:50.350: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/38, changed state to up
Dec 28 01:21:51.356: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/38, changed state to up

6A_SW02:
Dec 27 19:39:42.383: %SW_MATM-4-MACFLAP_NOTIF: Host 6805.ca17.94c5 in vlan 11 is flapping between port Gi1/0/38 and port Po1
Dec 27 20:21:32.025: %SW_MATM-4-MACFLAP_NOTIF: Host fc4d.d43d.59cc in vlan 11 is flapping between port Po1 and port Gi1/0/38
Dec 27 20:22:43.117: %SW_MATM-4-MACFLAP_NOTIF: Host fc4d.d43d.59cc in vlan 11 is flapping between port Po1 and port Gi1/0/38
Dec 27 20:25:15.869: %SW_MATM-4-MACFLAP_NOTIF: Host fc4d.d43d.59cc in vlan 11 is flapping between port Po1 and port Gi1/0/38
Dec 27 20:26:39.619: %SW_MATM-4-MACFLAP_NOTIF: Host fc4d.d43d.59cc in vlan 11 is flapping between port Po1 and port Gi1/0/38
Dec 27 20:28:17.201: %SW_MATM-4-MACFLAP_NOTIF: Host fc4d.d43d.59cc in vlan 11 is flapping between port Po1 and port Gi1/0/38
Dec 27 20:30:42.187: %SW_MATM-4-MACFLAP_NOTIF: Host fc4d.d43d.59cc in vlan 11 is flapping between port Po1 and port Gi1/0/38
Dec 27 20:31:01.648: %SW_MATM-4-MACFLAP_NOTIF: Host 6805.ca17.94c5 in vlan 11 is flapping between port Gi1/0/38 and port Po1
Dec 27 20:33:16.726: %SW_MATM-4-MACFLAP_NOTIF: Host fc4d.d43d.59cc in vlan 11 is flapping between port Po1 and port Gi1/0/38
Dec 27 20:33:17.934: %SW_MATM-4-MACFLAP_NOTIF: Host 6805.ca17.94c5 in vlan 11 is flapping between port Gi1/0/38 and port Po1
Dec 27 20:33:59.180: %SW_MATM-4-MACFLAP_NOTIF: Host 6805.ca17.94c5 in vlan 11 is flapping between port Gi1/0/38 and port Po1
Dec 27 20:37:36.590: %SW_MATM-4-MACFLAP_NOTIF: Host 6805.ca17.94c5 in vlan 11 is flapping between port Gi1/0/38 and port Po1
Dec 27 20:38:42.339: %SW_MATM-4-MACFLAP_NOTIF: Host fc4d.d43d.59cc in vlan 11 is flapping between port Po1 and port Gi1/0/38
Dec 27 20:41:47.856: %SW_MATM-4-MACFLAP_NOTIF: Host 6805.ca17.94c5 in vlan 11 is flapping between port Gi1/0/38 and port Po1
Dec 27 20:42:02.830: %SW_MATM-4-MACFLAP_NOTIF: Host fc4d.d43d.59cc in vlan 11 is flapping between port Po1 and port Gi1/0/38
Dec 27 20:42:04.155: %SW_MATM-4-MACFLAP_NOTIF: Host 6805.ca17.94c5 in vlan 11 is flapping between port Gi1/0/38 and port Po1
Dec 27 20:46:39.672: %SW_MATM-4-MACFLAP_NOTIF: Host fc4d.d43d.59cc in vlan 11 is flapping between port Po1 and port Gi1/0/38
Dec 27 20:46:40.972: %SW_MATM-4-MACFLAP_NOTIF: Host 6805.ca17.94c5 in vlan 11 is flapping between port Gi1/0/38 and port Po1
Dec 27 20:55:21.431: %SW_MATM-4-MACFLAP_NOTIF: Host fc4d.d43d.59cc in vlan 11 is flapping between port Po1 and port Gi1/0/38
Dec 27 20:56:18.581: %SW_MATM-4-MACFLAP_NOTIF: Host 6805.ca17.94c5 in vlan 11 is flapping between port Gi1/0/38 and port Po1
Dec 27 20:58:24.935: %SW_MATM-4-MACFLAP_NOTIF: Host fc4d.d43d.59cc in vlan 11 is flapping between port Po1 and port Gi1/0/38
Dec 27 20:58:29.071: %SW_MATM-4-MACFLAP_NOTIF: Host 6805.ca17.94c5 in vlan 11 is flapping between port Po1 and port Gi1/0/38
Dec 28 01:22:05.129: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/38, changed state to down
Dec 28 01:22:06.135: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/38, changed state to down
Dec 28 01:22:36.568: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/38, changed state to up
Dec 28 01:22:37.575: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/38, changed state to up

请问,端口不停的切换,是什么原因啊?时不时的端口还down一下。

附件: 您需要 登录 才可以下载或查看,没有帐号?立即注册
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-1-2 17:43:25 | 显示全部楼层
本帖最后由 suzhouxiaoniu 于 2019-2-20 16:52 编辑

先检查环路问题,可以尝试先关闭一个端口,是否停止报错
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-1-3 09:01:11 | 显示全部楼层
来回翻动的两个MAC地址是工作站两块网卡的地址么?
是的话建议查一下工作站的配置,网卡主备模式是bond1吧?
bond1按理说交换机应该只会看到一个MAC地址,可能是配置问题引起了环路。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-1-3 09:07:13 | 显示全部楼层
本帖最后由 LiuHongbo4567 于 2019-1-3 09:14 编辑

可以尝试把两台交换机堆叠,配置bond4
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-1-3 09:08:30 | 显示全部楼层
本帖最后由 LiuHongbo4567 于 2019-1-3 09:11 编辑

#全网四个相同的IP地址,不会冲突吗PS:看错了
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-1-3 09:28:08 | 显示全部楼层
suzhouxiaoniu 发表于 2019-1-2 17:43
主要检查环路问题,可以尝试先关闭一个网站,是否停止报错

网络中没有二层交换机,都只光纤直连的,接入层看CDP邻居,也只有各自的N7K,应该不会存在环路
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-1-3 09:30:29 | 显示全部楼层
wunai1700 发表于 2019-1-3 09:01
来回翻动的两个MAC地址是工作站两块网卡的地址么?
是的话建议查一下工作站的配置,网卡主备模式是bond1吧 ...

就是同一个工作站的两块网卡MAC。
所有工作站主机都是一个模版配置的,我等下联系下,看看是不是bond1
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-1-3 09:33:17 | 显示全部楼层
LiuHongbo4567 发表于 2019-1-3 09:07
可以尝试把两台交换机堆叠,配置bond4

因为都是思科的设备,所以最初建网的时候,就直接用的HSRP
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科社区  

GMT+8, 2019-6-17 05:32 , Processed in 0.088072 second(s), 48 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表