请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

   思科 CCO 登录 推荐
 找回密码
 立即注册

搜索
热搜: 邮件服务器
查看: 382|回复: 3

求助关于IPv6配置的问题

[复制链接]
发表于 2019-4-16 03:56:59 | 显示全部楼层 |阅读模式
0可用金钱
起因:联通网络支持了IPv6,电脑直接接光猫拨号可以实现ipv4 ipv6双栈。
目的:通过路由器实现局域网内所有设备均可通过ipv6出口访问互联网
设备:路由cisco isr4000 交换机C2960L AP1850
现在的情况是:
基本配置就绪,遇到了奇怪的问题。设备连接到WiFi后可以获得内网ipv6地址和公网地址。但是测试访问ipv6站点无法访问,test-ipv6.com提示未检测到ipv6地址。ping路由器ipv6可以通,但是ping ipv6的外网或者dns都不行。曾尝试手机开热点连接(现在移动4G也有ipv6)发现ipv6是正常的,所以应该不是客户端问题。而且这个问题不是所有设备都有,windows电脑正常,mac和手机都存在此问题。还有,诡异的是windows电脑第一次连接也存在这个问题,只要连一下手机热点然后再切换回来就正常了。。。

路由器配置参考的这篇文章:https://blog.csdn.net/robur/article/details/86156957
其中ip cef命令我这设备提示不完整% Incomplete command.经查资料show ipv6 cef是有显示的,应该是已经打开了。


我的路由器ipv6有关配置如下:

!
ip dhcp pool Local
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 192.168.10.1
!         
!         
!         
subscriber templating
ipv6 unicast-routing
ipv6 dhcp pool STATELESS
dns-server FE80::2EE:ABFF:FE15:5401
dns-server 2408:8000:1010:1::8
dns-server 2408:8000:1010:2::8  
!         
interface GigabitEthernet0/0/0
description bind-dialer
no ip address
negotiation auto
pppoe enable group global
ipv6 enable
pppoe-client dial-pool-number 1
spanning-tree portfast
!         
interface GigabitEthernet0/0/1
ip address 192.168.10.1 255.255.255.0
ip nat inside
negotiation auto
ipv6 address isp ::1/64
ipv6 enable
ipv6 nd other-config-flag
ipv6 dhcp server STATELESS
spanning-tree portfast
!         
interface Dialer1
description adsl-dialer
ip address negotiated
ip mtu 1452
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1412
dialer pool 1
ipv6 address autoconfig default
ipv6 enable
ipv6 mtu 1452
ipv6 dhcp client pd isp
ipv6 dhcp client request vendor
ppp mtu adaptive
ppp authentication chap pap callin
ppp chap hostname 123
ppp chap password 7 123
ppp pap sent-username 123 password 7 123
ppp ipcp dns request
!         
ip nat inside source list 10 interface Dialer1 overload
ip nat inside source route-map track-primary-if interface Dialer1 overload
ip forward-protocol nd
no ip http server
ip http authentication local
ip http secure-server
ip dns server
ip route 0.0.0.0 0.0.0.0 Dialer1
!         
ip ssh version 2
!         
access-list 10 permit 192.168.10.0 0.0.0.255
ipv6 route ::/0 Dialer1
!         
!         
route-map track-primary-if permit 1
match ip address 197
set interface Dialer1
!




  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-4-16 10:02:36 | 显示全部楼层
确认你的ISP是否有dhcp-pd。通过debug进行查看。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-4-16 14:37:10 | 显示全部楼层
wuhao0015 发表于 2019-4-16 10:02
确认你的ISP是否有dhcp-pd。通过debug进行查看。

请问是那条命令?谢谢
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-4-17 11:10:17 | 显示全部楼层
chengl031 发表于 2019-4-16 14:37
请问是那条命令?谢谢

debug ipv6 dhcp
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分5 (1 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科社区  

GMT+8, 2019-7-22 07:59 , Processed in 0.081719 second(s), 36 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表