请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

   思科 CCO 登录 推荐
 找回密码
 立即注册

搜索
热搜: 邮件服务器
查看: 416|回复: 14

请教一个N7K网络的问题

[复制链接]
发表于 2019-5-6 11:06:51 | 显示全部楼层 |阅读模式
10可用金钱
本帖最后由 xy411381121 于 2019-5-6 11:08 编辑

中心机房的数据库P780最近告警,然后发现192.168.30.25与192.168.30.26这两个IP相互之间无法ping通。
经过测试,发现当业务IP 172.26.10.143漂在黄线上时,25与26可互通;将143切换到紫线上后,25与26不通。
数据库工程师检查后,更换192.168.30.25/26的IP也未能解决问题。将主机网卡A与备机网卡A的紫线不接入N2K,直接连接,则25与26可以互通。故数据库工程师怀疑问题出在N7K网络层面。
拓扑图如下:

主备两台P780做了集群。192.168.30.25与192.168.30.26做集群,192.168.40.21与192.168.40.22做集群,192段IP仅二层通信,N7K上无该段网关。
172.26.10.143用于业务,172.26.10.144/145用于管理。这3个IP可漂在任意网卡上。默认情况下,业务IP在主机网卡A紫线上。网关在N7K上。

P780数据库图如下:
主机


备机


N7K_01上相关配置:
fex 106
  pinning max-links 1
  description "TO_N2K_701"
  type N2248T

vlan 1,8-10,90,780,800
vlan configuration 10
spanning-tree vlan 1,9-10,90 priority 28672

interface Vlan10
  description to Server
  no shutdown
  ip address 172.26.10.2/24
  ip router eigrp 600
  hsrp 10
    preempt
    priority 110
    ip 172.26.10.1

interface port-channel1
  switchport
  switchport mode trunk

interface port-channel106
  description TO_N2K_701
  switchport
  switchport mode fex-fabric
  fex associate 106

interface Ethernet1/1
  switchport
  switchport mode trunk
  channel-group 1
  no shutdown

interface Ethernet1/8
  description TO_N2K_701
  switchport
  switchport mode fex-fabric
  fex associate 106
  channel-group 106
  no shutdown

interface Ethernet2/1
  switchport
  switchport mode trunk
  channel-group 1
  no shutdown

interface Ethernet2/8
  description TO_N2K_701
  switchport
  switchport mode fex-fabric
  fex associate 106
  channel-group 106
  no shutdown

interface range Ethernet106/1/1 -32
  switchport
  switchport access vlan 10
  no shutdown

N7K_02上相关配置:
fex 106
  pinning max-links 1
  description "TO_N2K_702"
  type N2248T

vlan 1,8-10,90,750
spanning-tree vlan 1,8 priority 28672

interface Vlan10
  description to PS-Server
  no shutdown
  ip address 172.26.10.3/24
  ip router eigrp 600
  hsrp 10
    preempt
    ip 172.26.10.1

interface port-channel1
  switchport
  switchport mode trunk

interface port-channel106
  description TO_N2K_702
  switchport
  switchport mode fex-fabric
  fex associate 106

interface Ethernet1/1
  switchport
  switchport mode trunk
  channel-group 1
  no shutdown

interface Ethernet1/8
  description TO_N2K_702
  switchport
  switchport mode fex-fabric
  fex associate 106
  channel-group 106
  no shutdown

interface Ethernet2/1
  switchport
  switchport mode trunk
  channel-group 1
  no shutdown

interface Ethernet2/8
  description TO_N2K_702
  switchport
  switchport mode fex-fabric
  fex associate 106
  channel-group 106
  no shutdown

interface range Ethernet106/1/1 -32
  switchport
  switchport access vlan 10
  no shutdown

N7K上配置应该是没问题的,但暂时没有个网络排查的头绪。希望各位能提供点儿意见参考。谢谢!

附件: 您需要 登录 才可以下载或查看,没有帐号?立即注册
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-5-6 11:24:18 | 显示全部楼层
这个问题是,最近才有,还是以前就有,只是没发现?
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-5-6 11:39:52 | 显示全部楼层
ts1110 发表于 2019-5-6 11:24
这个问题是,最近才有,还是以前就有,只是没发现?

应该是近期才出现的,以前定期数据库工程师都会来巡检,以前都没说有这问题
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-5-6 15:35:36 | 显示全部楼层
先检查一下N7K01和N2K01之间的Channel状态吧
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-5-6 21:58:08 | 显示全部楼层
是不是生成树问题,你把黄线全shutdown,紫线正常连接看看
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-5-6 22:52:13 | 显示全部楼层
ts1110 发表于 2019-5-6 15:35
先检查一下N7K01和N2K01之间的Channel状态吧

两台N7K与N2K之间的Channel都没问题啊

N7K_01# show port-channel summary
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        S - Switched    R - Routed
        U - Up (port-channel)
        M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SU)     Eth      NONE      Eth1/1(P)    Eth2/1(P)   
106   Po106(SU)   Eth      NONE      Eth1/8(P)    Eth2/8(P)

N7K_01# show port-channel traffic
NOTE: Clear the port-channel member counters to get accurate statistics

ChanId      Port Rx-Ucst Tx-Ucst Rx-Mcst Tx-Mcst Rx-Bcst Tx-Bcst
------ --------- ------- ------- ------- ------- ------- -------
     1    Eth1/1  51.48%  49.51%  72.74%  61.22%  47.12%  43.86%
     1    Eth2/1  48.51%  50.48%  27.25%  38.77%  52.87%  56.13%
------ --------- ------- ------- ------- ------- ------- -------
   106    Eth2/8  17.32%  23.35%  50.25%  37.22%   9.62%  27.08%
   106    Eth1/8  82.67%  76.64%  49.74%  62.77%  90.37%  72.91%

N7K_02# show port-channel summary
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        S - Switched    R - Routed
        U - Up (port-channel)
        M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SU)     Eth      NONE      Eth1/1(P)    Eth2/1(P)      
106   Po106(SU)   Eth      NONE      Eth1/8(P)    Eth2/8(P)   

N7K_02# show port-channel traffic
NOTE: Clear the port-channel member counters to get accurate statistics

ChanId      Port Rx-Ucst Tx-Ucst Rx-Mcst Tx-Mcst Rx-Bcst Tx-Bcst
------ --------- ------- ------- ------- ------- ------- -------
     1    Eth2/1  48.22%  46.28%  35.90%  23.95%  53.68%  50.32%
     1    Eth1/1  51.77%  53.71%  64.09%  76.04%  46.31%  49.67%
------ --------- ------- ------- ------- ------- ------- -------
   106    Eth2/8   1.43%  90.84%  46.38%  63.07%  11.67%  75.13%
   106    Eth1/8  98.56%   9.15%  53.61%  36.92%  88.32%  24.86%
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-5-10 19:51:37 | 显示全部楼层
本帖最后由 wupeifeng 于 2019-5-10 19:54 编辑

当在紫线上的时候,172.26.10.143能否ping通?端口能否学习到25与26网卡的MAC地址?
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-5-11 11:55:23 | 显示全部楼层
参考我之前写的一个帖子,自己搞一搞,应该差不多能搞出来了:
http://bbs.csc-china.com.cn/foru ... read&tid=988490
先看 N7K 转发表项,如果看不出问题,就简单粗暴抓包处理。

P780 网卡如果可以抓包,就在出问题情况下,做个抓包;数据流从主到备,是否有去无回,或者没能送过去。
P780 网卡如果不能抓包,那就用 N7K 直接抓包。ELAME, 或者 ACL statistics per-entry。

如果确实定位到了是 N7K 问题,但是无法再继续深入查,欢迎开 TAC case 讨论。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-5-13 10:58:05 | 显示全部楼层
fushuang 发表于 2019-5-11 11:55
参考我之前写的一个帖子,自己搞一搞,应该差不多能搞出来了:
http://bbs.csc-china.com.cn/forum.php?mo ...

您之前发的帖子看不到了
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-5-13 11:27:47 | 显示全部楼层
xy411381121 发表于 2019-5-13 10:58
您之前发的帖子看不到了

是这个帖子,请参考。
[原创案例分享]Nexus7000 抓包工具 ELAME 应对转发丢包问题
http://bbs.csc-china.com.cn/foru ... 1&fromuid=14354
(出处: 思科社区)
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科社区  

GMT+8, 2019-5-24 17:44 , Processed in 0.103266 second(s), 56 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表