请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

   思科 CCO 登录 推荐
 找回密码
 立即注册

搜索
热搜: 邮件服务器
查看: 546|回复: 6

Cisco 2960X 配置恢复的问题

[复制链接]
发表于 2019-5-13 19:23:22 | 显示全部楼层 |阅读模式
0可用金钱
目前有两台2960交换机,其中一台平时使用copy run tftp,将配置文件备份到tftp,今天准备将配置恢复到另外一台交换机,将交换机重置并清除配置后,将tftp的配置文件拷贝到u盘,通过console连接到交换机,使用:
copy usbflash0:/sw_11-config-20190506 run,恢复配置后发现并不能恢复所有配置,除了交换机名字,IP地址外,其他例如接口VLAN都没恢复,好像是提示错误的命令。
将源交换机VLAN.DAT拷贝到目标交换机后貌似也不生效,sh vlan看不到VLAN信息。

请问下,如果要完整恢复配置需要通过什么方式?

  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-5-20 23:10:33 | 显示全部楼层
用文本编辑工具打开sw_11-config-20190506,看看里面的内容是否有乱码的情况。如果有的话,可能是tftp的编码跟2960不一致。如果没有的话,可以将里面创建和配置vlan的内容复制到一个新文件中,编辑好检查无误后再一次性刷到另外一台2960里面。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-5-21 00:09:09 | 显示全部楼层
编码问题吧?就和windows下和Linux下一样
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-5-22 10:56:55 来自手机 | 显示全部楼层
Hi
Copy run tftp 又转移到多个外部系统介质的方式,我觉得存在未知风险比较大,不能保证存储转移的时候文件系统是否对备份的文件编码格式做了任何更改,或者数据丢失等等
我之前用的开源的备份软件,还是商业的绝大部分都是都是跑脚本直接保存输出的show run内容,管理员恢复的时候都是以复制粘贴的方式恢复。
如果是重要度很高的网络设备需要最短的时间内恢复的这种设备,他也会使用copy 配置文件到设备本身的备份外置flash中,或者备用引擎的外置flash.
我觉得设备数量不是很多,建议还是直接用xshell,Securecrt 等等终端软件直接保存show run内容,然后进行恢复
Good Luck
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-5-23 09:50:49 | 显示全部楼层
谢谢各位的分享!乱码问题我看过倒是没有,黏贴的方式感觉不太妥吧,因为copy run 或者sh run出来的很多内容直接黏贴过去有很多是无法执行的,那肯定会出错啊。。。
例如:
sh run
!
interface Port-channel1
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0
no ip address
shutdown
!
interface GigabitEthernet1/0/1
switchport access vlan 20
spanning-tree portfast
!
interface GigabitEthernet1/0/2
switchport access vlan 20
spanning-tree portfast
!
interface GigabitEthernet1/0/3
switchport access vlan 20
spanning-tree portfast
!
类似这种接口配置直接黏贴过去能用?
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-5-23 09:54:15 | 显示全部楼层
mingzli 发表于 2019-5-22 10:56
Hi
Copy run tftp 又转移到多个外部系统介质的方式,我觉得存在未知风险比较大,不能保证存储转移的时候文 ...

请问您以前用的是什么开源备份软件,能分享下不,谢谢!
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-5-23 19:12:58 | 显示全部楼层
今天试了下使用Cisco kron去自动备份配置到tftp上还是很容易的,这个貌似也是可行。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科社区  

GMT+8, 2019-8-19 04:12 , Processed in 0.089490 second(s), 44 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表