请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

   思科 CCO 登录 推荐
 找回密码
 立即注册

搜索
热搜: 邮件服务器
查看: 453|回复: 8

端口聚合 channel-group 1 mode desirable

[复制链接]
发表于 2019-5-20 17:21:03 | 显示全部楼层 |阅读模式
0可用金钱
SW1和SW2的G1和G2口做端口聚合
SW1和SW3的F21和F22做端口聚合
SW3和SW4的G1和G2口做端口聚合
配置
SW1
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable

SW2
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable

SW3
interface GigabitEthernet0/1
channel-group 3 mode desirable
!
interface GigabitEthernet0/2
channel-group 3 mode desirable
!


SW4
interface GigabitEthernet0/1
channel-group 3 mode desirable
!
interface GigabitEthernet0/2
channel-group 3 mode desirable

我在SW4上配置trunk就会报错
Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.
Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.

如果我先封装成DOT1q在配置trunk的话就会报另一个错
%EC-5-CANNOT_BUNDLE2: Gig0/1 is not compatible with Po3 and will be suspended (dtp mode of Gig0/1 is on, Po3is off )

%EC-5-CANNOT_BUNDLE2: Gig0/2 is not compatible with Po3 and will be suspended (dtp mode of Gig0/2 is on, Po3is off )

%LINK-5-CHANGED: Interface Port-channel 3, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel 3, changed state to up

这是什么问题呢, 如果不我配置trunk在sw4的G1和G2口会有什么影响呢,哪个专家帮忙分析一下,最好详细一点,谢谢。
还有以上这么做端口聚合可以吗

  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-5-21 11:22:30 | 显示全部楼层
根据SW4上trunk的报错信息,应该是SW3,SW4相关端口都要配 switchport mode trunk 这一句
!
interface Port-channel1
switchport
switchport trunk allowed vlan all
switchport mode trunk
!
interface GigabitEthernet0/1
switchport trunk allowed vlan all
switchport mode trunk
channel-group 1 mode desirable
!
interface GigabitEthernet0/2
switchport trunk allowed vlan all
switchport mode trunk
channel-group 1 mode desirable
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-5-21 16:59:14 | 显示全部楼层
cruiseluo 发表于 2019-5-21 11:22
根据SW4上trunk的报错信息,应该是SW3,SW4相关端口都要配 switchport mode trunk 这一句
!
interface Por ...

我想问一下,思科设备可以这样做端口聚合吗,这样的拓扑会不会存在什么问题呢
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-5-22 09:47:05 | 显示全部楼层
相当于 interface Port-channel1 要配成 trunk 口,作为它成员的物理接口也配成 trunk 口,你把 interface Port-channel 想象成一个普通接口即可,它也可以是 trunk 口,它也需要遵守生成树协议,在物理上也不能打环。但和普通接口有一个区别,就是当它的成员口大于等于2时,成员口之间并不是环路,它在逻辑上都属于 interface Port-channel1
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-5-23 09:21:48 | 显示全部楼层
cruiseluo 发表于 2019-5-22 09:47
相当于 interface Port-channel1 要配成 trunk 口,作为它成员的物理接口也配成 trunk 口,你把 interface  ...

这四台设备链接在一起会有问题吗做聚合,我这四台设备做聚合其中有四个口是F口这样是可以的吗,谢谢
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-5-23 09:23:23 | 显示全部楼层
cruiseluo 发表于 2019-5-21 11:22
根据SW4上trunk的报错信息,应该是SW3,SW4相关端口都要配 switchport mode trunk 这一句
!
interface Por ...

我设备SW3和SW4想要配置switchport mode trunk都配置不上去的,是为什么呢
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-5-23 10:44:04 | 显示全部楼层
四个口是F口不影响配置,你配不了switchport mode trunk ,可以先把物理端口的 channel-group 3 mode desirable 配置先删掉再配。如果还是不行,就配成 switchport  mode dynamic desirable。两个物理口和 interface Port-channel 的trunk配置要一致
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-5-23 15:02:51 | 显示全部楼层
cruiseluo 发表于 2019-5-23 10:44
四个口是F口不影响配置,你配不了switchport mode trunk ,可以先把物理端口的 channel-group 3 mode desir ...

感谢,还有一个问题,能帮我解释一下switchport  mode dynamic desirable这句是什么意思吗,是不是在物理接口上配置这个后就不用配置switchport mode trunk了
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-5-25 11:03:39 | 显示全部楼层
本帖最后由 cruiseluo 于 2019-5-25 11:05 编辑

C:\Users\Banan-luochunhui2\Desktop\Trunk模式格式.png

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科社区  

GMT+8, 2019-9-19 21:58 , Processed in 0.106763 second(s), 53 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表