请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

   思科 CCO 登录 推荐
 找回密码
 立即注册

搜索
热搜: 邮件服务器
查看: 451|回复: 7

Nexus 交换机N3k 可以配置多个VRF 吗?

[复制链接]
发表于 2019-5-23 23:16:16 | 显示全部楼层 |阅读模式
0可用金钱
如题,Nexus 交换机N3k 可以配置多个VRF 吗?  比如一个management vrf , 一个keepalive link vrf , 一个default vrf ?

  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-5-25 20:24:16 | 显示全部楼层
可以。
DLN3548P-1(config)# vrf context ?
  WORD                       VRF name (Max Size 32)
  management (no abbrev)     Configurable VRF name
  test (no abbrev)           Configurable VRF name
  vpc-keepalive (no abbrev)  Configurable VRF name

10 个左右的 VRF,完全在 support 范围之内。如果没有其他高级 feature,估计能做到 1000 个以内,可以参考
https://www.cisco.com/c/en/us/td ... 985894D1E4EEA28C8EA
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分5 (1 评价)
发表于 2019-5-27 15:36:45 | 显示全部楼层
可以!楼上已经给出了
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-5-27 16:17:11 | 显示全部楼层
fushuang 发表于 2019-5-25 20:24
可以。
DLN3548P-1(config)# vrf context ?
  WORD                       VRF name (Max Size 32)

感谢专家出手解答
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-5-28 15:36:37 | 显示全部楼层
fushuang 发表于 2019-5-25 20:24
可以。
DLN3548P-1(config)# vrf context ?
  WORD                       VRF name (Max Size 32)

非常感谢专家的回复,  还有一个问题想咨询 : 就是我有一个服务器组,一共有5台服务器,都是在同一个VLAN 之内,  能不能在2台N3K 中直接做一个vPC 把5台处于同一VLAN 的服务器全部划分到1个vPC 里面?
这个vPC 关联的port-channel 可以做成access XX vlan  这样的模式吗? 不做trunk

服务器规划是2个10G SFP+ 做port-channel 上联到2台N3K 上。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-5-29 09:33:20 | 显示全部楼层
gzxsjsj_cpx 发表于 2019-5-28 15:36
非常感谢专家的回复,  还有一个问题想咨询 : 就是我有一个服务器组,一共有5台服务器,都是在同一个VLA ...

vpc domain 10
peer-gateway
peer-switch
peer-keepalive
xxx
!
inter port-c 1
switchport
switchport mode access
switchport access vlan x
vpc 1
!
nter port-c 10
switchport
switchport mode access
switchport access vlan x
vpc 10
!

可以是类似上面的配置,你说的划分到一个 VPC,是指同一个 port-channel?
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-5-29 10:35:42 | 显示全部楼层
fushuang 发表于 2019-5-29 09:33
vpc domain 10
peer-gateway
peer-switch

举例:

比如2台N3K (e1/19)跟第一1台服务器(每台双链路上行)之间的vPC 配置如下

N3K-1(config)#interface e1/19
N3K-1(config-if)#channel-group 10 mode on (接服务器我们用on 模式)
N3K-1(config-if)#no shutdown
N3K-1(config)#interface port-channel 10
N3K-1(config-if)# description Connect to R640 server
N3K-1(config-if)#switchport mode access
N3K-1(config-if)# switchport access vlan 10
N3K-1(config-if)#vpc 10

N3K-2(config)#interface e1/19
N3K-2(config-if)#channel-group 10 mode on (接服务器我们用on 模式)
N3K-2(config-if)#no shutdown
N3K-2(config)#interface port-channel 10
N3K-2(config-if)# description Connect to R640 server
N3K-2(config-if)#switchport mode access
N3K-2(config-if)# switchport access vlan 10
N3K-2(config-if)#vpc 10



B、N3K(e1/18)与R640 server-02 vpc 对接
N3K-1(config)#interface e1/18
N3K-1(config-if)#channel-group 20 mode on (接服务器我们用on 模式)
N3K-1(config-if)#no shutdown
N3K-1(config)#interface port-channel 20
N3K-1(config-if)# description Connect to R640 server-02
N3K-1(config-if)#switchport mode access
N3K-1(config-if)# switchport access vlan 10
N3K-1(config-if)#vpc 20

N3K-2(config)#interface e1/18
N3K-2(config-if)#channel-group 20 mode on (接服务器我们用on 模式)
N3K-2(config-if)#no shutdown
N3K-2(config)#interface port-channel 20
N3K-2(config-if)# description Connect to R640 server-02
N3K-2(config-if)#switchport mode access
N3K-2(config-if)# switchport access vlan 10
N3K-2(config-if)#vpc 20


像上面的配置,正常来说, 我一台服务器双链路到2台N3K , 每台服务器要起1 个vPC, 一个port-channel ,  如果服务器多的话,配置还是蛮多的, 我想确认的是,  N3K 能不能只用一个vPC 就把同一VLAN 的所有服务器对接起来, 每台服务器还是做port-channel ,  这样就不用N3K为每台服务器都创造一个vPC ,不知道我的描述是否清晰呢?
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-5-29 16:49:45 | 显示全部楼层
为啥要建那么多VRF,感觉可以换个思路去解决这个问题。就像在交换机上划分众多的VLAN,不如通过物理隔离的方式进行划分。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科社区  

GMT+8, 2019-7-23 03:07 , Processed in 0.183167 second(s), 48 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表