请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

   思科 CCO 登录 推荐
 找回密码
 立即注册

搜索
热搜: 邮件服务器
查看: 335|回复: 2

外线拨入FXO经UCM转总机不显示号码

[复制链接]
发表于 2019-5-29 09:20:50 | 显示全部楼层 |阅读模式
10可用金钱
这几天在测试经UCM转总机问题,前面加入aa的tcl脚本,通过语音按0转总机,但是总机上显示:from notavaliable
from unknow number
下面是开了debuge的日志:
List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=6000
*May 29 00:44:59.828: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=, Peer Info Type=DIALPEER_INFO_SPEECH
*May 29 00:44:59.828: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)
*May 29 00:44:59.828: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1
*May 29 00:44:59.828: //-1/xxxxxxxxxxxx/DPM/dpMatchPeers:
   Result=NO_MATCH(-1)
*May 29 00:44:59.828: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=6003, Peer Info Type=DIALPEER_INFO_SPEECH
*May 29 00:44:59.828: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=6003
*May 29 00:44:59.828: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
   Dial String=6003, Expanded String=6003, Calling Number=
   Timeout=TRUE, Is Incoming=FALSE, Peer Info Type=DIALPEER_INFO_SPEECH
*May 29 00:44:59.828: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
   Result=Success(0); Outgoing Dial-peer=6000 Is Matched
*May 29 00:44:59.828: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
*May 29 00:44:59.828: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=0
*May 29 00:44:59.828: //-1/xxxxxxxxxxxx/DPM/dpMatchPeers:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=6000

  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分5 (1 评价)
 楼主| 发表于 2019-5-29 09:23:47 | 显示全部楼层
这是路由器2921上面的配置:

Building configuration...


Current configuration : 5050 bytes
!
version 15.4
service telnet-zeroidle
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname test2921
!
boot-start-marker
boot-end-marker
!
!
enable password cisco,123
!
aaa new-model
!
!
!
!
!
!
!
aaa session-id common
!
!
!
!
!
!
!
!
!
!
!
!
ip dhcp pool test
network 192.168.8.0 255.255.255.0
default-router 192.168.8.1
dns-server 114.114.114.114 8.8.8.8
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
vpdn enable
!
!
!         
!
!
!
cts logging verbose
!
!
voice-card 0
!
!
!
voice service voip
ip address trusted list
  ipv4 192.168.3.163
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
supplementary-service h450.12
no supplementary-service sip handle-replaces
redirect ip2ip
signaling forward unconditional
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
  bind control source-interface GigabitEthernet0/2
  bind media source-interface GigabitEthernet0/2
  header-passing
  no silent-discard untrusted
!
!
voice class uri 2 sip
host ipv4:192.168.3.163
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
codec preference 3 g711alaw
codec preference 4 g722-64
video codec h264
!
voice class codec 2
video codec h264
!
voice class h323 1
  h225 timeout tcp establish 3
  h225 timeout setup 3
!
!
!
voice class custom-cptone china
dualtone busy
  frequency 450
  cadence 350 350 350 350 continuous
!
!         
!
!
voice translation-rule 1
rule 1 /^9\(.*\)$/ /\1/
!
voice translation-rule 100
rule 1 /.*/ /95594/
!
!
voice translation-profile block
translate called 1
!
voice translation-profile incoming
translate called 1
!
voice translation-profile outgoing
translate called 1
!
voice translation-profile to_pstn
translate calling 100
!
!
!
!
application
service aa flash:samesun.2.0.1.1BO.tcl
  param operator 6003
  paramspace english index 1
  paramspace english language en
  paramspace english prefix en
  param aa-pilot 62186991
!
!
license udi pid CISCO2921/K9 sn FGL190310BN
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!
!
username admin privilege 15 password 0 cisco
!
redundancy
!
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description NeiWang
ip address 192.168.8.1 255.255.255.0
ip mtu 1460
ip pim dense-mode
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
ip virtual-reassembly in
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface GigabitEthernet0/2
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username ad82187900 password 0 43064977
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip dns server
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 192.168.3.0 255.255.255.0 192.168.1.254
ip route 192.168.50.0 255.255.255.0 192.168.50.254
!
!
!
access-list 1 permit 192.168.8.0 0.0.0.255
access-list 1 permit any
!         
!
!
control-plane
!
!
voice-port 0/0/0
supervisory disconnect dualtone mid-call
supervisory custom-cptone china
cptone CN
timeouts call-disconnect 3
timeouts wait-release 3
timing hookflash-out 500
caller-id enable
!
voice-port 0/0/1
supervisory disconnect dualtone mid-call
supervisory custom-cptone china
cptone CN
timeouts call-disconnect 3
timeouts wait-release 3
timing hookflash-out 500
caller-id enable
!
voice-port 0/0/2
!
voice-port 0/0/3
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
!
voice-port 0/2/0
!
voice-port 0/2/1
!
voice-port 0/2/2
!
voice-port 0/2/3
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer voice 6000 voip
destination-pattern 6...$
session target ipv4:192.168.3.163
voice-class codec 1  
voice-class h323 1
dtmf-relay cisco-rtp h245-alphanumeric h245-signal rtp-nte
no vad
!
dial-peer voice 62186991 pots
translation-profile outgoing outgoing
service aa
destination-pattern 9T
incoming called-number .
no digit-strip
port 0/0/0
!
dial-peer voice 95594 voip
destination-pattern 95594
session target ipv4:192.168.3.163
voice-class codec 1  
voice-class h323 1
dtmf-relay cisco-rtp h245-alphanumeric h245-signal rtp-nte
no vad
!
!
!
!
gatekeeper
shutdown
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password cisco,123
transport input telnet
!
scheduler allocate 20000 1000
!
end
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-6-5 16:10:33 | 显示全部楼层
等待大神们的解答,跟着学习一下。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科社区  

GMT+8, 2019-6-20 03:40 , Processed in 0.084623 second(s), 34 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表