请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

   思科 CCO 登录 推荐
 找回密码
 立即注册

搜索
热搜: 邮件服务器
查看: 389|回复: 5

请问N2K端口怎么开启自动协商

[复制链接]
发表于 2019-7-18 19:37:19 | 显示全部楼层 |阅读模式
10可用金钱
本帖最后由 xy411381121 于 2019-7-18 19:37 编辑

型号:
cisco Nexus7000 C7010
N2K-C2248TP-1GE
系统:
  BIOS:      version 3.22.0
  kickstart: version 6.1(2)
  system:    version 6.1(2)

N7K与N2K相关配置如下:
fex 106
  pinning max-links 1
  description "TO_N2K_701"
  type N2248T

interface port-channel106
  description TO_N2K_701
  switchport
  switchport mode fex-fabric
  fex associate 106

interface Ethernet1/8
  description TO_N2K_701
  switchport
  switchport mode fex-fabric
  fex associate 106
  channel-group 106
  no shutdown

interface Ethernet2/8
  description TO_N2K_701
  switchport
  switchport mode fex-fabric
  fex associate 106
  channel-group 106
  no shutdown

interface Ethernet106/1/2
  switchport
  switchport access vlan 10
  no shutdown

目前网络出现了点儿问题,排查网络配置、网线、硬件,都没发现什么问题,后来有人说是不是N2K上端口自动协商关闭的原因(Auto-Negotiation is turned off),想先开启自动协商试试

Ethernet106/1/2 is up
admin state is up,
  Hardware: 100/1000 Ethernet, address: f84f.57b8.f8c3 (bia f84f.57b8.f8c3)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
  reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, medium is broadcast
  Port mode is access
  full-duplex, 1000 Mb/s
  Beacon is turned off
  Auto-Negotiation is turned off
  Input flow-control is off, output flow-control is on
  Auto-mdix is turned off
  Switchport monitor is off
  EtherType is 0x8100
  Last link flapped 11week(s) 0day(s)
  Last clearing of "show interface" counters never

但我们在尝试开启端口自动协商时,发现没有相关相关命令,就只配置了speed auto与duplex auto,但发现端口端口还是Auto-Negotiation is turned off
请问Auto-Negotiation is turned off可以通过命令改成开启吗?

  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-7-18 21:33:38 | 显示全部楼层
negotiate auto这个没效果?
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-7-19 02:43:53 | 显示全部楼层
LieBenSun0407 发表于 2019-7-18 21:33
negotiate auto这个没效果?

就是因为没有这条命令,所以才使用speed auto与duplex auto,但没什么效果

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-7-22 10:10:21 | 显示全部楼层
不是有一条speed命令么,试了吗?
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-7-23 19:29:09 | 显示全部楼层
我也遇到了此问题
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-7-23 22:46:00 | 显示全部楼层
liuzhi001 发表于 2019-7-22 10:10
不是有一条speed命令么,试了吗?

输入speed auto与duplex auto后,依旧是Auto-Negotiation is turned off
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科社区  

GMT+8, 2019-8-25 07:12 , Processed in 0.091616 second(s), 42 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表