请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

   思科 CCO 登录 推荐
 找回密码
 立即注册

搜索
热搜: 邮件服务器
查看: 782|回复: 10

请教一个奇怪的丢包现象

[复制链接]
发表于 2019-9-10 11:08:39 | 显示全部楼层 |阅读模式
10可用金钱
本帖最后由 xy411381121 于 2019-9-10 11:12 编辑

中心路由器思科2901,2M模块为VWIC3-2MFT-G703
分中心路由器华为NE05E-SN
路由器互联接口,均采用PPP封装方式进行2M通道互联。因为是思科与华为互联,所以建立了Multilink。
拓扑如下:



中心路由器相关配置如下:

R1:
interface Multilink1
  ip address 192.60.167.102 255.255.255.252
  ppp multilink
  ppp multilink group 1

interface GigabitEthernet0/0
  ip address 192.122.130.1 255.255.255.0
interface GigabitEthernet0/1
  ip address 192.122.131.1 255.255.255.0
interface Serial0/0/0:0
  no ip address
  encapsulation ppp
  ppp multilink
  ppp multilink group 1


ip route 192.122.126.0 255.255.255.0 Multilink1
ip route 192.122.127.0 255.255.255.0 Multilink1


R2:

interface Multilink1
  ip address 192.60.168.102 255.255.255.252
  ppp multilink
  ppp multilink group 1

interface GigabitEthernet0/0
  ip address 192.122.132.1 255.255.255.0
interface GigabitEthernet0/1
  ip address 192.122.133.1 255.255.255.0
interface Serial0/0/0:0
  no ip address
  encapsulation ppp
  ppp multilink
  ppp multilink group 1


ip route 192.122.128.0 255.255.255.0 Multilink1
ip route 192.122.129.0 255.255.255.0 Multilink1


服务器上都是手动添加的永久静态路由。
现在出现个奇怪的问题,登录思科路由器ping华为路由器广域网端口,ping 1000个大小10000的包,A网丢包3%,B网丢包4%,但是用中心服务器ping对端华为路由器广域网端口却不丢包。
用服务器ping不丢包,反而直连的路由器却出现大量丢包,请问这是什么原因啊?


附件: 您需要 登录 才可以下载或查看,没有帐号?立即注册
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-9-16 21:39:55 | 显示全部楼层
不指定包的大小的情况丢不丢包?
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-9-16 22:25:35 | 显示全部楼层
Rocky 发表于 2019-9-16 21:39
不指定包的大小的情况丢不丢包?

ping标准包不丢,ping大小1000的包也不丢
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-9-16 22:31:26 | 显示全部楼层
xy411381121 发表于 2019-9-16 22:25
ping标准包不丢,ping大小1000的包也不丢

你不是说ping1000个大小10000的包,A网丢包3%,B网丢包4%吗?
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-9-16 23:15:04 | 显示全部楼层
本帖最后由 xy411381121 于 2019-9-16 23:19 编辑
Rocky 发表于 2019-9-16 22:31
你不是说ping1000个大小10000的包,A网丢包3%,B网丢包4%吗?

对啊,ping标准包和大小为1千的包都不丢,但ping大小为1万的就丢包了。但是在服务器上ping大小为1万的包却不丢包。以B网为例,ping包情况如下:
服务器ping 大小1万的包不丢包,如下:


路由器ping 大小1万的包丢4%,而且丢的很有节奏感

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-9-17 08:58:57 | 显示全部楼层
本帖最后由 byl@qware.com 于 2019-9-17 09:01 编辑

思科交换机用的是快ping(在几毫秒之内没有应答就丢包),而华为响应的时间相对较慢,所以出现丢包现象。在命令行ping 后再加timeout(指定超时时间,设置大点数值)测试。中心服务器ping对端华为路由器广域网端口却不丢包,说明网络是没有问题的。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-9-17 12:51:08 | 显示全部楼层
byl@qware.com 发表于 2019-9-17 08:58
思科交换机用的是快ping(在几毫秒之内没有应答就丢包),而华为响应的时间相对较慢,所以出现丢包现象。在 ...

那我明天去试试,谢谢了
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-9-24 12:57:48 | 显示全部楼层
byl@qware.com 发表于 2019-9-17 08:58
思科交换机用的是快ping(在几毫秒之内没有应答就丢包),而华为响应的时间相对较慢,所以出现丢包现象。在 ...

我今天来试了下,timeout设置为3、5、10丢还是在固定位置丢包

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-9-24 17:14:50 | 显示全部楼层
xy411381121 发表于 2019-9-24 12:57
我今天来试了下,timeout设置为3、5、10丢还是在固定位置丢包

感觉应该是厂商之间的兼容问题,我工作时也经常遇到这种问题,固定位置丢包,一般都没有问题,
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-9-24 22:33:58 | 显示全部楼层
本帖最后由 xy411381121 于 2019-9-24 22:35 编辑
byl@qware.com 发表于 2019-9-24 17:14
感觉应该是厂商之间的兼容问题,我工作时也经常遇到这种问题,固定位置丢包,一般都没有问题,

我也只能跟用户这么解释了,其他对方是思科的都没问题,就这边,对方是华为的,丢包
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科社区  

GMT+8, 2019-10-15 12:55 , Processed in 0.100218 second(s), 56 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表