请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

   思科 CCO 登录 推荐
 找回密码
 立即注册

搜索
热搜: 邮件服务器
查看: 445|回复: 3

ASA5525-X NAT问题

[复制链接]
发表于 2019-9-28 01:03:02 | 显示全部楼层 |阅读模式
0可用金钱
ASA5525-X防火墙配置PAT后,在防火墙设备ping www.baidu.com,ping内网主机都没问题, 但是:内网主机无法上网,映射主机外网也无法访问(IOS软件换版本也试过)。望各位大神帮忙给分析分析 谢谢!
配置如下:
ASA Version 9.2(2)4
!
hostname HJ
domain-name hj
enable password J
xlate per-session deny tcp any4 any4
xlate per-session deny tcp any4 any6
xlate per-session deny tcp any6 any4
xlate per-session deny tcp any6 any6
xlate per-session deny udp any4 any4 eq domain
xlate per-session deny udp any4 any6 eq domain
xlate per-session deny udp any6 any4 eq domain
xlate per-session deny udp any6 any6 eq domain
names
!
interface GigabitEthernet0/0
nameif outside
security-level 0
ip address 111.207.x.x 255.255.255.248
!            
interface GigabitEthernet0/1
nameif inside
security-level 100
ip address 192.168.10.253 255.255.255.0
!
interface GigabitEthernet0/2
no nameif
no security-level
no ip address

!
boot system disk0:/asa922-4-smp-k8.bin
ftp mode passive
clock timezone BEIJING 8
dns domain-lookup outside
dns domain-lookup inside
dns server-group DefaultDNS
name-server 202.106.0.20
name-server 202.106.196.115
domain-name hjjt.com
object network Inside-Outside-all
subnet 0.0.0.0 0.0.0.0
pager lines 24
logging enable
logging timestamp
logging asdm informational
mtu outside 1500
mtu inside 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
icmp permit any outside
icmp permit any inside
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
!
object network Inside-Outside-all
nat (inside,outside) dynamic interface dns
access-group OUT in interface outside
route outside 0.0.0.0 0.0.0.0 111.207.144.205 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication enable console LOCAL
aaa authentication telnet console LOCAL
aaa authentication ssh console LOCAL
aaa authorization command LOCAL
no snmp-server location
no snmp-server contact
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 1440
ssh stricthostkeycheck
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 60
ssh version 1
ssh key-exchange group dh-group1-sha1
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept

!
class-map inspex\ction_default
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect ip-options
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny  
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip  
  inspect xdmcp
  inspect icmp
  inspect ipsec-pass-thru
  inspect pptp
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
: end


  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-9-29 09:54:52 | 显示全部楼层
nat (inside,outside) dynamic interface dns
没看到你有dns的接口啊,改成outside
nat (inside,outside) dynamic interface outside
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-9-29 18:40:28 | 显示全部楼层
object network Inside-Outside-all
nat (inside,outside) dynamic interface dns
access-group OUT in interface outside <<<<<<<没有看到你定义的OUT这个access-list呀?

如果都可以放的话,这样配置试试:
access-list OUT permit ip any any
access-group OUT in interface outside
object network Inside-Outside-all
nat (inside,outside) dynamic interface

祝你成功!
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 7 天前 | 显示全部楼层
如果内网没有重定向的服务是不需要加dns关键字,去掉应该就可以了
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科社区  

GMT+8, 2019-10-15 12:51 , Processed in 0.085089 second(s), 36 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表