请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

   思科 CCO 登录 推荐
 找回密码
 立即注册

搜索
热搜: 邮件服务器
查看: 643|回复: 1

【原创】简单实验:采用BGP信令的VPLS

[复制链接]
发表于 2019-11-9 13:41:04 | 显示全部楼层 |阅读模式
简介:
        VPLS技术属于二层分组承载技术,本质上是一种基于IP/MPLS和以太网技术的L2VPN(二层虚拟专用网)技术。其核心思想是利用信令协议在VPLS实例中的PE(运营商边缘路由器)节点之间建立及维护PW(伪线),将二层协议帧封装后在PW上传输、交换,使广域范围内多个局域网在数据链路层面被整合为一张网络,向用户提供虚拟的以太网服务。VPLS技术有效地结合了IP/MPLS、L2VPN以太网交换等多种技术的特点,支持点到点、点到多点、多点到多点的业务类型,能够在较大网络规模下支持电信级以太网服务。

采用的技术:
网桥域接口(BDI) ;多协议BGP;集成ISIS;标签分发协议(LDP)

网络拓扑:
基本配置:
R4
interface Loopback0
ip address 192.168.255.4 255.255.255.255
ip router isis underlay
!
mpls label protocol ldp
mpls ldp router-id Loopback0 force
!
router isis underlay
net 49.0192.0000.0000.0004.00
is-type level-1
metric-style wide
log-adjacency-changes
mpls ldp autoconfig level-1
!
interface GigabitEthernet3
no shutdown
ip address 192.168.0.9 255.255.255.252
ip router isis underlay
!
检查RIB以及LFIB
LSR4#sh ip route isis
      192.168.255.0/32 is subnetted, 4 subnets
i L1     192.168.255.1 [115/30] via 192.168.0.10, 18:55:47, GigabitEthernet3
i L1     192.168.255.2 [115/20] via 192.168.0.10, 18:55:51, GigabitEthernet3
i L1     192.168.255.3 [115/30] via 192.168.0.10, 18:55:51, GigabitEthernet3
======================================================
LSR4#sh mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop   
Label      Label      or Tunnel Id     Switched      interface              
26         Pop Label  192.168.0.0/30   0             Gi3        192.168.0.10
27         Pop Label  192.168.0.4/30   0             Gi3        192.168.0.10
28         16         192.168.255.1/32 0             Gi3        192.168.0.10
29         Pop Label  192.168.255.2/32 0             Gi3        192.168.0.10
30         17         192.168.255.3/32 0             Gi3        192.168.0.10
======================================================

L2VPN VPLS配置:
!
bridge irb————————————>集成路由交换
!
l2vpn vfi context vlan1
vpn id 1————————————->vpn id 需要一致
autodiscovery bgp signaling bgp—>自动发现与信令采用BGP
  ve id 4————————————->ve id 必须唯一
!
interface GigabitEthernet4
no shutdown
service instance 1 ethernet—————>使用BDI
  encapsulation untagged——————>封装无vlan tag
!
bridge-domain 1
member GigabitEthernet4 service-instance 1
member vfi vlan1
!
router bgp 65000
template peer-policy iBGP
  route-reflector-client
  send-community both //携带RT(自动)
  suppress-signaling-protocol ldp //抑制LDP信令
exit-peer-policy
!
template peer-session iBGP
  remote-as 65000
  update-source Loopback0
exit-peer-session
!
bgp router-id 192.168.255.4
bgp cluster-id 192.168.255.4
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 192.168.255.1 inherit peer-session iBGP
neighbor 192.168.255.3 inherit peer-session iBGP
!
address-family l2vpn vpls
  neighbor 192.168.255.1 activate
  neighbor 192.168.255.1 inherit peer-policy iBGP
  neighbor 192.168.255.3 activate
  neighbor 192.168.255.3 inherit peer-policy iBGP
exit-address-family

检查:

LSR4#sh mpls l2transport vc   
Local intf     Local circuit              Dest address    VC ID      Status
-------------  -------------------------- --------------- ---------- ----------
VFI vlan1      vfi                        192.168.255.1   1          UP        
VFI vlan1      vfi                        192.168.255.3   1          UP        

LSR4#sh mpls l2transport vc detail | inc stack
    Output interface: Gi3, imposed label stack {16 19}
    Output interface: Gi3, imposed label stack {17 19}

LSR4#sh bgp l2vpn vpls all summary
Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.168.255.1   4        65000    1269    1270        4    0    0 19:08:23        1
192.168.255.3   4        65000    1269    1273        4    0    0 19:08:25        1

抓包测试:



本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分4 (1 评价)
发表于 2019-11-11 10:37:24 | 显示全部楼层
感谢楼主分享,谢谢~
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科社区  

GMT+8, 2019-12-11 22:18 , Processed in 0.103420 second(s), 35 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表