请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

   思科 CCO 登录 推荐
 找回密码
 立即注册

搜索
热搜: 邮件服务器
查看: 825|回复: 2

【原创】简单实验:采用MLDP承载的组播VPN

[复制链接]
发表于 2019-11-9 16:02:39 | 显示全部楼层 |阅读模式
本帖最后由 zylccna2015 于 2019-11-9 16:05 编辑

简单实验:采用MLDP承载的组播VPN


下一代组播VPN:
   基于MP2MP LSP建立Share-MDT,用于传递信令消息和小流量数据;基于P2MP LSP建立Data-MDT,采用MDT join TLV消息动态建立Data-MDT,用于转发高带宽数据流量。一条MP2MP LSP允许业务流从多个入口节点传输到多个出口节点;一条P2MP LSP允许业务流从一个根节点(或入口节点)传输到多个叶节点(或出口节点)。在MP LSP的每一条链路上只需传输数据包的一份拷贝,不需要组播路由协议的支持。允许多条MPLSP以一个入口节点为根节点,每一条MP LSP都有它自己的标识符.MP2MP LSP由一个根节点,零个或多个传输节点以及一个或多个叶节点组成。MP2MP LSP中的叶节点需要建立两条LSP:一条下游LSP,与从根节点出发的P2MPLSP相似;一条上游LSP,用来向根节点和其它叶节点发送数据流。传输节点支持上游和下游LSP的建立并保存相应的MPLS转发状态。MP2MP LSP中数据包从根节点传输到叶节点的过程与在P2MP LSP中类似;从叶节点发送的数据流首先通过上游LSP传输到根节点,然后在根节点经下游LSP传输到其它的叶节点。P2MP LSP由一个根节点,零个或多个传输节点以及一个或多个叶节点组成。由叶节点负责P2MPLSP的建立和撤销。根节点需要建立转发状态,并将业务流映射到P2MP LSP。

采用的技术:
    多协议BGP;集成ISIS;标签分发协议(LDP、MLDP);PIM

网络拓扑:
LSR1-4为标签交换机
采用BSR方式推举RPClient 5 G1接口)
Client7 G1接口为IGMP加组端口

基本配置:

R4(R1,R3配置参考同R4)
interface Loopback0
ip address 192.168.255.4 255.255.255.255
ip router isis underlay
!
mpls label protocol ldp
mpls ldp router-id Loopback0 force
!
router isis underlay
net 49.0192.0000.0000.0004.00
is-type level-1
metric-style wide
log-adjacency-changes
mpls ldp autoconfig level-1
!
interface GigabitEthernet3
no shutdown
ip address 192.168.0.9 255.255.255.252
ip router isis underlay
!
检查RIB以及LFIB
LSR4#sh ip route isis
      192.168.255.0/32 is subnetted, 4 subnets
i L1     192.168.255.1 [115/30] via 192.168.0.10,18:55:47, GigabitEthernet3
i L1     192.168.255.2 [115/20] via 192.168.0.10,18:55:51, GigabitEthernet3
i L1     192.168.255.3 [115/30] via 192.168.0.10,18:55:51, GigabitEthernet3
======================================================
LSR4#sh mpls forwarding-table
Local      Outgoing   Prefix          Bytes Label  Outgoing   Next Hop   
Label      Label      or TunnelId     Switched      interface            
26         Pop Label  192.168.0.0/30  0             Gi3       192.168.0.10
27         PopLabel  192.168.0.4/30   0            Gi3        192.168.0.10
28         16        192.168.255.1/32 0            Gi3        192.168.0.10
29         PopLabel  192.168.255.2/32 0            Gi3        192.168.0.10
30         17        192.168.255.3/32 0            Gi3        192.168.0.10
======================================================

MPLS L3VPN ipv4单播配置:

R4(R1,R3配置参考同R4)
vrf definition MVPN
rd 65000:4
!
address-family ipv4
  route-target export 1:1
  route-target import 1:1
exit-address-family
!
interface GigabitEthernet4
vrf forwarding MVPN
ip address 10.224.4.1 255.255.255.0
!
router bgp 65000
template peer-policy iBGP
  route-reflector-client
  send-community both
exit-peer-policy
!
template peer-session iBGP
  remote-as 65000
  update-source Loopback0
exit-peer-session
!
bgp router-id 192.168.255.4
bgp cluster-id 192.168.255.4
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 192.168.255.1 inheritpeer-session iBGP
neighbor 192.168.255.3 inheritpeer-session iBGP
!
address-family vpnv4
  neighbor 192.168.255.1 activate
  neighbor 192.168.255.1send-community extended
  neighbor 192.168.255.1 inheritpeer-policy iBGP
  neighbor 192.168.255.3 activate
  neighbor 192.168.255.3send-community extended
  neighbor 192.168.255.3 inheritpeer-policy iBGP
exit-address-family
!
address-family ipv4 vrf MVPN
  redistribute connected
  neighbor 10.224.4.2 remote-as65300
  neighbor 10.224.4.2 activate
  neighbor 10.224.4.2 as-override
exit-address-family
在组播源端验证
MR#sh ip route bgp
      10.0.0.0/8 is variablysubnetted, 4 subnets, 2 masks
B        10.224.1.0/24 [20/0] via10.224.4.1, 00:55:52
B        10.224.3.0/24 [20/0] via10.224.4.1, 00:55:51
MR#ping 10.224.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.224.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/2/3 ms
MR#ping 10.224.3.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.224.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/2/3 ms
MPLS L3VPN ipv4 组播配置:

LSR134
ip multicast-routing vrf MVPN distributed
!
interface GigabitEthernet4
ip pimsparse-mode
!
router bgp 65000
  !
address-family ipv4 mvpn
  neighbor 192.168.255.1 activate
  neighbor 192.168.255.1 inheritpeer-policy iBGP
  neighbor 192.168.255.3 activate
  neighbor 192.168.255.3 inheritpeer-policy iBGP
exit-address-family
!
vrf definition MVPN
!
address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp p2mp
  mdt overlayuse-bgp

Multicast-sourceClient5Client7
ipmulticast-routing distributed
!
interfaceGigabitEthernet1
ip address 10.224.1.2 255.255.255.0
ip pim sparse-mode
!
router bgp65300
bgp router-id 10.224.1.2
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 10.224.1.1 remote-as 65000
!
address-family ipv4
  neighbor 10.224.1.1 activate
exit-address-family
Client5(RP):
ip pimbsr-candidate GigabitEthernet1 0
ip pimrp-candidate GigabitEthernet1
Client7
Interface g1
ip igmp join-group 239.0.0.1
!

检查:

抓包分析:
LSR2(interface G3)
LSR2(interface G2)

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-11-11 10:40:19 | 显示全部楼层
感谢楼主实力分享,谢谢~
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-11-11 13:50:42 | 显示全部楼层
赞一个,原创的东西真不错!
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科社区  

GMT+8, 2019-12-11 22:20 , Processed in 0.112858 second(s), 38 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表