请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

   思科 CCO 登录 推荐
 找回密码
 立即注册

搜索
热搜: 邮件服务器
查看: 457|回复: 10

WLC5508 HA 2+1 SSO 求助 UNKNOWN - Communication Down

[复制链接]
发表于 2019-11-28 17:10:23 | 显示全部楼层 |阅读模式
57可用金钱
本帖最后由 randy.yu.peng 于 2019-11-29 13:23 编辑

三台WLC5508做2+1模式
目前WLC-A和WLC-C  HA SSO peer UNKNOWN - Communication Down通讯失败。请问需要VID一样吗?

WLC-A
---------------Show boot---------------

Primary Boot Image............................... 8.3.150.0 (active)
Backup Boot Image................................ 8.0.140.0

---------------show time---------------


Time............................................. Tue Nov 26 16:47:40 2019

Timezone delta................................... 0:0
Timezone location................................ (GMT +8:00) HongKong, Bejing, Chongquing

---------------Show Inventory---------------

System Inventory
Burned-in MAC Address............................ 6C:20:56:6C:8D:A0
Power Supply 1................................... Present, OK
Power Supply 2................................... Present, OK
Maximum number of APs supported.................. 500

---------------Show udi---------------

NAME: "Chassis"    , DESCR: "Cisco 5500 Series Wireless LAN Controller"
PID: AIR-CT5508-K9,  VID: V03,  SN: FCW1652L038

---------------Show sysinfo---------------

System Information
Manufacturer's Name.............................. Cisco Systems Inc.
Product Name..................................... Cisco Controller
Product Version.................................. 8.3.150.0
Bootloader Version............................... 1.0.1
Field Recovery Image Version..................... 6.0.182.0
Firmware Version................................. FPGA 1.3, Env 1.6, USB console 1.27
OUI File Update Time............................. Sun Sep 07 10:44:07 IST 2014
                                                                               VID: V03,  SN: *******
Build Type....................................... DATA + WPS

System Name...................................... WLC-A
System Location..................................
System Contact...................................

--More-- or (q)uit
System ObjectID.................................. 1.3.6.1.4.1.9.1.1069
Redundancy Mode.................................. SSO
IP Address....................................... 192.62.254.220
IPv6 Address..................................... ::
Last Reset....................................... Software reset
System Up Time................................... 0 days 1 hrs 48 mins 53 secs
System Timezone Location......................... (GMT +8:00) HongKong, Bejing, Chongquing
System Stats Realtime Interval................... 5
System Stats Normal Interval..................... 180

Configured Country............................... CN  - China
Operating Environment............................ Commercial (0 to 40 C)
Internal Temp Alarm Limits....................... 0 to 65 C
Internal Temperature............................. +42 C
External Temperature............................. +23 C
Fan Status....................................... OK

State of 802.11b Network......................... Enabled
State of 802.11a Network......................... Enabled
Number of WLANs.................................. 7
Number of Active Clients......................... 0

OUI Classification Failure Count................. 0

--More-- or (q)uit

Burned-in MAC Address............................ 6C:20:56:6C:8D:A0
Power Supply 1................................... Present, OK
Power Supply 2................................... Present, OK
Maximum number of APs supported.................. 500
System Nas-Id.................................... WLC-A
WLC MIC Certificate Types........................ SH
---------------Show advanced backup-controller---------------

Backup Controller Configuration

AP primary Backup Controller ....................  
AP secondary Backup Controller ..................  

---------------Redundancy Information---------------

Redundancy Information
Redundancy Mode.................................. SSO ENABLED
Local State...................................... ACTIVE
Peer State....................................... UNKNOWN - Communication Down
Unit............................................. Primary
Unit ID.......................................... 6C:20:56:6C:8D:A0

--More-- or (q)uit
Redundancy State................................. Non Redundant
Mobility MAC..................................... 6C:20:56:6C:8D:A0
Redundancy Management IP Address................. 192.62.254.214
Peer Redundancy Management IP Address............ 192.62.254.213
Redundancy Port IP Address....................... 169.254.254.214
Peer Redundancy Port IP Address.................. 169.254.254.213

---------------Show port summary---------------

Port Summary
           STP   Admin   Physical   Physical   Link   Link
Pr  Type   Stat   Mode     Mode      Status   Status  Trap     POE    SFPType   
-- ------- ---- ------- ---------- ---------- ------ ------- ------- ----------
1  Normal  Forw Enable  Auto       1000 Full  Up     Enable  N/A     1000BaseSX  
2  Normal  Disa Enable  Auto       Auto       Down   Enable  N/A     1000BaseSX  
3  Normal  Disa Enable  Auto       Auto       Down   Enable  N/A     1000BaseSX  
4  Normal  Disa Enable  Auto       Auto       Down   Enable  N/A     1000BaseSX  
5  Normal  Disa Enable  Auto       Auto       Down   Enable  N/A     1000BaseSX  
6  Normal  Disa Enable  Auto       Auto       Down   Enable  N/A     1000BaseSX  
7  Normal  Disa Enable  Auto       Auto       Down   Enable  N/A     1000BaseSX  
8  Normal  Disa Enable  Auto       Auto       Down   Enable  N/A     1000BaseSX  



WLC-C   
---------------Show boot---------------

Primary Boot Image............................... 8.3.150.0 (active)
Backup Boot Image................................ 8.0.140.0

---------------show time---------------


Time............................................. Tue Nov 26 16:39:11 2019

Timezone delta................................... 0:0
Timezone location................................ (GMT +8:00) HongKong, Bejing, Chongquing

---------------Show Inventory---------------

System Inventory
Burned-in MAC Address............................ 30:F7:0D:30:F4:80
Power Supply 1................................... Present, OK
Power Supply 2................................... Absent
Maximum number of APs supported.................. 500

---------------Show udi---------------

NAME: "Chassis"    , DESCR: "Cisco 5500 Series Wireless LAN Controller"
PID: AIR-CT5508-K9,  VID: V02,  SN: FCW1634L01P

---------------Show sysinfo---------------

System Information
Manufacturer's Name.............................. Cisco Systems Inc.
Product Name..................................... Cisco Controller
Product Version.................................. 8.3.150.0
Bootloader Version............................... 1.0.1
Field Recovery Image Version..................... 6.0.182.0
Firmware Version................................. FPGA 1.3, Env 1.6, USB console 1.27
OUI File Update Time............................. Sun Sep 07 10:44:07 IST 2014
                                                                               VID: V02,  SN: *******
Build Type....................................... DATA + WPS

System Name...................................... WLC-C
System Location..................................
System Contact...................................

--More-- or (q)uit
System ObjectID.................................. 1.3.6.1.4.1.9.1.1069
Redundancy Mode.................................. SSO
IP Address....................................... 192.62.254.218
IPv6 Address..................................... ::
Last Reset....................................... Watchdog reset
System Up Time................................... 0 days 1 hrs 48 mins 45 secs
System Timezone Location......................... (GMT +8:00) HongKong, Bejing, Chongquing
System Stats Realtime Interval................... 5
System Stats Normal Interval..................... 180

Configured Country............................... CN  - China
Operating Environment............................ Commercial (0 to 40 C)
Internal Temp Alarm Limits....................... 0 to 65 C
Internal Temperature............................. +34 C
External Temperature............................. +21 C
Fan Status....................................... OK

State of 802.11b Network......................... Enabled
State of 802.11a Network......................... Enabled
Number of WLANs.................................. 2
Number of Active Clients......................... 0

OUI Classification Failure Count................. 0

--More-- or (q)uit

Burned-in MAC Address............................ 30:F7:0D:30:F4:80
Power Supply 1................................... Present, OK
Power Supply 2................................... Absent
Maximum number of APs supported.................. 500
System Nas-Id.................................... WLC-C
WLC MIC Certificate Types........................ SH
---------------Show advanced backup-controller---------------

Backup Controller Configuration

AP primary Backup Controller ....................  
AP secondary Backup Controller ..................  

---------------Redundancy Information---------------

Redundancy Information
Redundancy Mode.................................. SSO ENABLED
Local State...................................... MAINTENANCE
Peer State....................................... UNKNOWN - Communication Down
Unit............................................. Primary
Unit ID.......................................... 30:F7:0D:30:F4:80

--More-- or (q)uit
Redundancy State................................. Non Redundant
Mobility MAC..................................... 30:F7:0D:30:F4:80
Maintenance Mode................................. Enabled
Maintenance cause................................ Both WLCs are primary
Redundancy Management IP Address................. 192.62.254.213
Peer Redundancy Management IP Address............ 192.62.254.214
Redundancy Port IP Address....................... 169.254.254.213
Peer Redundancy Port IP Address.................. 169.254.254.214

---------------Show port summary---------------

Port Summary
           STP   Admin   Physical   Physical   Link   Link

--More-- or (q)uit
Pr  Type   Stat   Mode     Mode      Status   Status  Trap     POE    SFPType   
-- ------- ---- ------- ---------- ---------- ------ ------- ------- ----------
1  Normal  Forw Enable  Auto       1000 Full  Up     Enable  N/A     1000BaseSX
2  Normal  Disa Enable  Auto       Auto       Down   Enable  N/A     Not Present
3  Normal  Disa Enable  Auto       Auto       Down   Enable  N/A     Not Present
4  Normal  Disa Enable  Auto       Auto       Down   Enable  N/A     Not Present
5  Normal  Disa Enable  Auto       Auto       Down   Enable  N/A     1000BaseSX  
6  Normal  Disa Enable  Auto       Auto       Down   Enable  N/A     Not Present
7  Normal  Disa Enable  Auto       Auto       Down   Enable  N/A     1000BaseSX  
8  Normal  Disa Enable  Auto       Auto       Down   Enable  N/A     1000BaseSX  

附件: 您需要 登录 才可以下载或查看,没有帐号?立即注册
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-11-28 21:33:45 | 显示全部楼层
理由截图上已经给出了,  两个都是Primary, 一个改成secondary试试
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-11-28 21:36:09 | 显示全部楼层
---------------RedundancyInformation---------------

RedundancyInformation
RedundancyMode.................................. SSO ENABLED
LocalState...................................... ACTIVE
PeerState....................................... UNKNOWN - Communication Down
Unit.............................................Primary
UnitID.......................................... 6C:20:56:6C:8D:A0



---------------RedundancyInformation---------------

RedundancyInformation
RedundancyMode.................................. SSO ENABLED
LocalState...................................... MAINTENANCE
PeerState....................................... UNKNOWN - Communication Down
Unit.............................................Primary
UnitID.......................................... 30:F7:0D:30:F4:80

  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-11-29 09:36:20 | 显示全部楼层
haifeli 发表于 2019-11-28 21:36
---------------RedundancyInformation---------------
RedundancyInformationRedundancyMode............ ...

GUI web下配置一次,CLI下配置一次,依然这样 Unknown-Communicaton Down
CLI参考如下.
configure interface address management 9.5.56.2 255.255.255.0 9.5.56.1

configure interface address redundancy-management 9.5.56.10 peer-redundancy-management 9.5.56.11

configure redundancy unit primary

configure redundancy mode sso



Configuration on Hot Standby WLC:

configure interface address management 9.5.56.3 255.255.255.0 9.5.56.1

configure interface address redundancy-management 9.5.56.11 peer-redundancy-management 9.5.56.10

configure redundancy unit secondary

configure redundancy mode sso

配置完SSO重启顺序有要求吗?先重启primary ,还是secendry
目前LIC是  WLC-A 上100lic ,WLC-C出厂默认lic.

WLC-A 和WLC-C在 SSO之前配置不一样是否有影响?
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-11-29 09:54:13 | 显示全部楼层

我不认为SSO需要配置完全相同才能UP。
你的RP Port能ping通吗  我看上面的截图是没有ping通的?
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-11-29 10:29:11 | 显示全部楼层
本帖最后由 randy.yu.peng 于 2019-11-29 10:30 编辑
haifeli 发表于 2019-11-29 09:54
我不认为SSO需要配置完全相同才能UP。
你的RP Port能ping通吗  我看上面的截图是没有ping通的?

对,rp port 互ping只能单边通,因为生产环境,甲方配合力度不够,不能随便更改。有哪位有SSO环境可以 rp port 互ping测试下。
rp port 连接网线有特殊要求吗?直通线还是交叉线?
下面是交换机原有配置。
interface GigabitEthernet1/0/2
description To WLC 5508-A 192.168.254.220
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,14,19,20,24,35,48,52,104,112,161
switchport mode trunk
channel-group 1 mode on
!
interface GigabitEthernet1/0/3
description To WLC 5508-A 192.168.254.220
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,14,19,20,24,35,48,52,104,112,161
switchport mode trunk
channel-group 1 mode on


interface GigabitEthernet1/0/11
description To WLC 5508-C 192.168.254.218
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,24,161
switchport mode trunk




interface Port-channel1
description To WLC 5508-A 192.168.254.220
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,14,19,20,24,35,48,52,104,112,161
switchport mode trunk

上面配置是原有配置,配置SSO时,已移除portchannel
并且managert 允许VLAN 1和VLAN1000 /rp vlan ID   



  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-11-29 16:26:00 | 显示全部楼层
randy.yu.peng 发表于 2019-11-29 10:29
对,rp port 互ping只能单边通,因为生产环境,甲方配合力度不够,不能随便更改。有哪位有SSO环境可以 rp ...

RP Port需要通的,最好排查一下路径上的问题
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-12-1 22:28:15 | 显示全部楼层
haifeli 发表于 2019-11-29 16:26
RP Port需要通的,最好排查一下路径上的问题

现在是Redundancy-management interface 和Manage interface上面的地址互ping只能单边。RP在这种状况应该也不通。
Manage Interface 端口跟思科交换机做端口聚合和不做聚合都是单边能ping通。在交换机上能看到相互的MAC。Mangement interface 都在二层环境。

  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2019-12-3 08:50:14 | 显示全部楼层
randy.yu.peng 发表于 2019-12-1 22:28
现在是Redundancy-management interface 和Manage interface上面的地址互ping只能单边。RP在这种状况应该 ...

不通的话只能逐步排查了  比如交换机到WLC的连通性,有没有ACL等等
现在的资料暂时没看出来有什么问题
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2019-12-3 21:10:44 | 显示全部楼层
haifeli 发表于 2019-12-3 08:50
不通的话只能逐步排查了  比如交换机到WLC的连通性,有没有ACL等等
现在的资料暂时没看出来有什么问题

谢谢,终于弄好了。Lic问题。评估版授权不行,一定需要永久授权。 50AP真贵,100AP 价格吓死人。
This condition is only valid for the 5508 WLC, where a minimum of 50 AP Permanent licenses are needed to be converted to Standby
思科官方解释如下:
Note: You do not need to configure the unit as Secondary if it is a factory ordered HA SKU that can be ordered from release 7.3 onwards. A factory ordered HA SKU is a default Secondary unit, and will take the role of the Standby WLC the first time it is paired with an Active WLC that has a valid AP Count
License.

Changing WLC LAG state will require a WLC reload.

Switch#show etherchannel load-balance

Switch(config)#port-channel load-balance src-dst-ip

Peer RMI ICMP ping replaced with UDP messages
the RP VLAN should be excluded from the access VLAN configured on the switch for the management ports.
If you want to convert any existing WLC as a Standby WLC, do so using the config redundancy unit secondary command in the CLI. This CLI command will only work if the WLC which is intended to work as Standby has some number of permanent license count. This condition is only valid for the 5508 WLC, where a minimum of 50 AP Permanent licenses are needed to be converted to Standby. There is no restriction for other WLCs such as the 5520, WiSM2, 7500, and 8500.
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver | 思科社区  

GMT+8, 2019-12-11 21:59 , Processed in 0.111817 second(s), 54 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表