请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

搜索
热搜: 邮件服务器
查看: 338|回复: 1

【原创】双点双向路由重分发的路由反馈和次优路径处理测试(RIP和OSPF)

[复制链接]
发表于 2020-3-5 10:06:40 | 显示全部楼层 |阅读模式
本帖最后由 碧云天 于 2020-3-5 10:11 编辑

一.测试拓扑


测试总结:
1.路由反馈只会在双点并且是管理距离大的路由向管理距离小的重分发的时候,才会出现
---比如通过一个ASBR将RIP路由重分发到OSPF,管理距离110,这样就会导致另外一个ASBR上原先管理距离为120的RIP路由,被管理距离为110的OSPF路由所替代
---但是相同情况,一个ASBR将RIP路由重分发到EIGRP,却不会出现问题,因为EIGRP对于外部路由的管理距离为170,远远大于RIP的120
2.路由加表时先比较管理距离,再比较metric值,因此路由反馈只能通过修改对端ASBR的外部路由条目的管理距离实现
---还有一种比较极端的方式,就是ASBR重分发的时候打tag,对端ASBR将打tag路由全部过滤掉,这种虽然省事,但是当对端ASBR管理距离大的那侧链路出现故障的时候,它就没有冗余链路
3.解决次优路径不建议在出现次优路径的路由器上处理,而应该在ASBR上处理,如果用remote-map修改metric,可以只需再一台ASBR上配置

二.基本配置
1.R3路由器

hostname R3
interface Loopback0
    ip address 3.3.3.3 255.255.255.0
interface Ethernet0/0
    ip address 23.1.1.3 255.255.255.0
    no shutdown
interface Ethernet0/1
    ip address 13.1.1.3 255.255.255.0
    no shutdown
router rip
    version 2
    network 3.0.0.0
    network 13.0.0.0
    network 23.0.0.0
    no auto-summary
2.R1路由器
hostname R1
interface Loopback0
    ip address 1.1.1.1 255.255.255.0
interface Ethernet0/0
    ip address 14.1.1.1 255.255.255.0
    ip ospf network point-to-point
    no shutdown
interface Ethernet0/1
    ip address 13.1.1.1 255.255.255.0
    no shutdown
router ospf 1
    router-id 1.1.1.1
    passive-interface Loopback11
    network 11.11.11.11 0.0.0.0 area 0
    network 14.1.1.1 0.0.0.0 area 0
router rip
    version 2
    passive-interface Loopback0
    network 1.0.0.0
    network 13.0.0.0
    no auto-summary
3.R2路由器
hostname R2
interface Loopback0
    ip address 2.2.2.2 255.255.255.0
interface Ethernet0/0
    ip address 23.1.1.2 255.255.255.0
    no shutdown
interface Ethernet0/1
    ip address 24.1.1.2 255.255.255.0
    ip ospf network point-to-point
    no shutdown
router ospf 1
    router-id 2.2.2.2
    passive-interface Loopback22
    network 22.22.22.22 0.0.0.0 area 0
    network 24.1.1.2 0.0.0.0 area 0
router rip
    version 2
    passive-interface Loopback0
    network 2.0.0.0
    network 23.0.0.0
    no auto-summary
4.R4路由器
interface Loopback0
    ip address 4.4.4.4 255.255.255.0
interface Ethernet0/0
    ip address 14.1.1.4 255.255.255.0
    ip ospf network point-to-point
    no shutdown
interface Ethernet0/1
    ip address 24.1.1.4 255.255.255.0
    ip ospf network point-to-point
    no shutdown
router ospf 1
    router-id 4.4.4.4
    passive-interface Loopback0
    network 4.4.4.4 0.0.0.0 area 0
    network 14.1.1.4 0.0.0.0 area 0
    network 24.1.1.4 0.0.0.0 area 0
三.配置路由重分发
备注:双点双向重分发最好先顺时针,再反时针,或者先反时针,再逆时针方向,进行重分发。
1.R1配置RIP向OSPF重分发
①配置之前先查看R2的RIP路由

R2#show ip route rip | in Etherne
R        1.1.1.0 [120/2] via 23.1.1.3, 00:00:14, Ethernet0/0
R        3.3.3.0 [120/1] via 23.1.1.3, 00:00:14, Ethernet0/0
R        13.1.1.0 [120/1] via 23.1.1.3, 00:00:14, Ethernet0/0
②R1配置路由重分发
router ospf 1
    redistribute rip subnets
③这时再查看R2的路由,原先的RIP路由,都变成了OE2路由
R2#show ip route ospf | in O E2
O E2     1.1.1.0 [110/20] via 24.1.1.4, 00:00:23, Ethernet0/1
O E2     3.3.3.0 [110/20] via 24.1.1.4, 00:00:23, Ethernet0/1
O E2     13.1.1.0 [110/20] via 24.1.1.4, 00:00:23, Ethernet0/1
R2#     14.1.1.0 [110/20] via 24.1.1.4, 00:03:00, Ethernet0/1
④解决方法:
Ⅰ.R2上把R1把OSPF外部路由管理距离改成大于120

router ospf 1
    distance ospf external 121
Ⅱ.R2上把R1始发的OSPF路由管理距离改成大于120
router ospf 1
distance 121 1.1.1.1 0.0.0.0
Ⅲ.或者R2上把从R3接收的RIP路由管理距离改成小于110
router rip
    distance 109 23.1.1.3 0.0.0.0
2.R2配置OSPF向RIP重分发
备注:因为OSPF的管理距离比RIP的小,所以R2把OSPF向RIP重分发的时候,不会影响R1的路由表
①R2配置路由重分发
router rip
     redistribute ospf 1 metric 2
②验证
R3#show ip route rip | in Ethernet
R        1.1.1.0 [120/1] via 13.1.1.1, 00:00:24, Ethernet0/1
R        2.2.2.0 [120/1] via 23.1.1.2, 00:00:26, Ethernet0/0
R        4.4.4.4 [120/2] via 23.1.1.2, 00:00:26, Ethernet0/0
R        11.11.11.0 [120/2] via 23.1.1.2, 00:00:26, Ethernet0/0
R        14.1.1.0 [120/2] via 23.1.1.2, 00:00:26, Ethernet0/0
R        22.22.22.0 [120/2] via 23.1.1.2, 00:00:26, Ethernet0/0
R        24.1.1.0 [120/2] via 23.1.1.2, 00:00:26, Ethernet0/0
备注:可以看到R3增加了5条从OSPF重分发过来的路由
3.R1配置OSPF向RIP重分发
①R1配置路由重分发

router rip
     redistribute ospf 1 metric 2
②验证
R3#show ip route rip | in Ethernet
R        1.1.1.0 [120/1] via 13.1.1.1, 00:00:13, Ethernet0/1
R        2.2.2.0 [120/1] via 23.1.1.2, 00:00:13, Ethernet0/0
R        4.4.4.4 [120/2] via 13.1.1.1, 00:00:13, Ethernet0/1
R        11.11.11.0 [120/2] via 13.1.1.1, 00:00:13, Ethernet0/1
R        14.1.1.0 [120/2] via 13.1.1.1, 00:00:13, Ethernet0/1
R        22.22.22.0 [120/2] via 13.1.1.1, 00:00:13, Ethernet0/1
R        24.1.1.0 [120/2] via 13.1.1.1, 00:00:13, Ethernet0/1
R3#
5.R2配置RIP向OSPF重分发
①配置之前先查看R1的路由

R1#show ip route rip | in Ethernet
R        2.2.2.0 [120/2] via 13.1.1.3, 00:00:14, Ethernet0/1
R        3.3.3.0 [120/1] via 13.1.1.3, 00:00:14, Ethernet0/1
R        23.1.1.0 [120/1] via 13.1.1.3, 00:00:14, Ethernet0/1
R1#
②R2配置路由重分发
router ospf 1
    redistribute rip subnets
③这时再查看R2的路由,原先的RIP路由,都变成了OE2路由
R1#show ip route ospf | in O E2
O E2     2.2.2.0 [110/20] via 14.1.1.4, 00:00:13, Ethernet0/0
O E2     3.3.3.0 [110/20] via 14.1.1.4, 00:00:13, Ethernet0/0
O E2     23.1.1.0 [110/20] via 14.1.1.4, 00:00:13, Ethernet0/0
R1#
④解决方法:
Ⅰ.R1上把R1把OSPF外部路由管理距离改成大于120

router ospf 1
    distance ospf external 121
Ⅱ.或者R1上把R2始发的OSPF路由管理距离改为大于120
router ospf 1
distance 121 2.2.2.2 0.0.0.0
Ⅲ.或者R1上把从R3接收的RIP路由管理距离改为小于110
router rip
    distance 109 13.1.1.3 0.0.0.0
四.次优路径问题处理
备注:虽然次优路由可以在出现次优路径的路由器上配置,如果多个路由器出现次优路径,那就需要再每一台上设置,因此不建议。
1.R3和R4都出现了次优路由
R3#show ip route rip | in Ethernet
R        1.1.1.0 [120/1] via 13.1.1.1, 00:00:07, Ethernet0/1
R        2.2.2.0 [120/1] via 23.1.1.2, 00:00:10, Ethernet0/0
R        4.4.4.4 [120/2] via 23.1.1.2, 00:00:10, Ethernet0/0
                 [120/2] via 13.1.1.1, 00:00:07, Ethernet0/1
R        11.11.11.0 [120/2] via 23.1.1.2, 00:00:10, Ethernet0/0
                    [120/2] via 13.1.1.1, 00:00:07, Ethernet0/1
R        14.1.1.0 [120/2] via 23.1.1.2, 00:00:10, Ethernet0/0
                  [120/2] via 13.1.1.1, 00:00:07, Ethernet0/1
R        22.22.22.0 [120/2] via 23.1.1.2, 00:00:10, Ethernet0/0
                    [120/2] via 13.1.1.1, 00:00:07, Ethernet0/1
R        24.1.1.0 [120/2] via 23.1.1.2, 00:00:10, Ethernet0/0
                  [120/2] via 13.1.1.1, 00:00:07, Ethernet0/1
R3#

R4#show ip route ospf | in Ethernet
O E2     1.1.1.0 [110/20] via 24.1.1.2, 00:16:22, Ethernet0/1
                 [110/20] via 14.1.1.1, 00:37:30, Ethernet0/0
O E2     2.2.2.0 [110/20] via 24.1.1.2, 00:16:22, Ethernet0/1
                 [110/20] via 14.1.1.1, 00:14:59, Ethernet0/0
O E2     3.3.3.0 [110/20] via 24.1.1.2, 00:16:22, Ethernet0/1
                 [110/20] via 14.1.1.1, 00:14:59, Ethernet0/0
O        11.11.11.0 [110/11] via 14.1.1.1, 00:46:00, Ethernet0/0
O E2     13.1.1.0 [110/20] via 24.1.1.2, 00:16:22, Ethernet0/1
                  [110/20] via 14.1.1.1, 00:37:30, Ethernet0/0
O        22.22.22.0 [110/11] via 24.1.1.2, 00:43:05, Ethernet0/1
O E2     23.1.1.0 [110/20] via 24.1.1.2, 00:16:22, Ethernet0/1
                  [110/20] via 14.1.1.1, 00:14:59, Ethernet0/0
R4#
2.解决R3的次优路由
备注:如果rip中使用offset-list修改,则需要在两台ASBR路由器上面修改,因此使用route-map修改metric
①配置ACL匹配离R1近的OSPF域路由条目
access-list 10 permit 11.11.11.0
access-list 10 permit 14.1.1.0
②配置ACL匹配离R1远的OSPF域路由条目
access-list 20 permit 22.22.22.0
access-list 20 permit 24.1.1.0
③配置route-map,离R1近的路由metric减1,离R1远的路由metric设置为3,其他的不做处理
route-map O2R permit 10
    match ip address 10
    set metric -1
route-map O2R permit 20
    match ip address 20
    set metric +3
route-map O2R permit 30
备注:实际测试本想离R1远的路由metric也加1,但是没有成功,后面测试验证这个+3和3的意思应该是一样的,就是最终metric设置为3
④R1上修改OSPF向RIP重分发的语句
router rip
     redistribute ospf 1 metric 2 route-map O2R
⑤验证
R3#show ip route rip | in Ethernet
R        1.1.1.0 [120/1] via 13.1.1.1, 00:00:01, Ethernet0/1
R        2.2.2.0 [120/1] via 23.1.1.2, 00:00:01, Ethernet0/0
R        4.4.4.4 [120/2] via 23.1.1.2, 00:00:01, Ethernet0/0
                 [120/2] via 13.1.1.1, 00:00:01, Ethernet0/1
R        11.11.11.0 [120/1] via 13.1.1.1, 00:00:01, Ethernet0/1
R        14.1.1.0 [120/1] via 13.1.1.1, 00:00:01, Ethernet0/1
R        22.22.22.0 [120/2] via 23.1.1.2, 00:00:01, Ethernet0/0
R        24.1.1.0 [120/2] via 23.1.1.2, 00:00:01, Ethernet0/0
2.解决R3的次优路由
备注:也可以通过修改metric-type将ASBR近的RIP域路由设置为OE1,不过需要在两台ASBR分别配置,因此仍采用route-map修改metric方式
①配置ACL匹配离R1近的RIP路由条目
access-list 30 permit 1.1.1.0
access-list 30 permit 13.1.1.0
②配置ACL匹配离R1远的RIP路由条目
access-list 40 permit 2.2.2.0
access-list 40 permit 23.1.1.0
③配置route-map,离R1近的路由metric减1,离R1远的路由metric设置为21,其他的不做处理
route-map R2O permit 30
    match ip address 30
    set metric -1
route-map R2O permit 40
    match ip address 40
    set metric 21
route-map R2O permit 50
④R1上修改RIP向OSPF重分发的语句
router ospf 1
redistribute rip subnets route-map R2O
⑤验证
R4#show ip route ospf | in Ethernet
O E2     1.1.1.0 [110/1] via 14.1.1.1, 00:04:42, Ethernet0/0
O E2     2.2.2.0 [110/20] via 24.1.1.2, 00:00:10, Ethernet0/1
O E2     3.3.3.0 [110/20] via 24.1.1.2, 00:00:10, Ethernet0/1
                 [110/20] via 14.1.1.1, 00:04:42, Ethernet0/0
O        11.11.11.0 [110/11] via 14.1.1.1, 00:04:42, Ethernet0/0
O E2     13.1.1.0 [110/1] via 14.1.1.1, 00:04:42, Ethernet0/0
O        22.22.22.0 [110/11] via 24.1.1.2, 00:04:42, Ethernet0/1
O E2     23.1.1.0 [110/20] via 24.1.1.2, 00:00:10, Ethernet0/1
R4#

本帖子中包含更多资源

您需要 思科 CCO 登录 才可以下载或查看,没有帐号?思科 CCO 注册   

x
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分5 (1 评价)
发表于 2020-3-5 14:08:54 | 显示全部楼层
感谢楼主分享,谢谢~
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 思科 CCO 登录 | 思科 CCO 注册   

本版积分规则

Archiver | 思科社区  

GMT+8, 2020-4-7 14:30 , Processed in 0.101331 second(s), 33 queries .

京ICP备11014401号-17

© 2020 思科系统.版权所有 重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表