请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

搜索
热搜: 邮件服务器
查看: 397|回复: 0

【原创】修改EIGRP的distance和metric测试

[复制链接]
发表于 2020-3-10 17:45:17 | 显示全部楼层 |阅读模式
本帖最后由 碧云天 于 2020-3-10 17:54 编辑

一.测试拓扑



测试总结:
1.distance只是本地有效,EIGRP的外部路由的distance要改只能全部都改,不能只改部分。
2.路由反馈可以通过修改distance来实现,但是不能通过修改metric实现
3.尝试用EIGRP的distribute-list调用route-map在out方向修改metric没有修改成功
4.EIGRP的offset-list在in和out方向都能工作,但是只能调用ACL,如果ACL不存在,会修改所有的路由条目
5.EIGRP在重分发的时候可以通过route-map调整特殊路由的metric值,但是需要指定所有的metric变量

二.基本配置
1.R1路由器

hostname R1
int l0
    ip add 1.1.1.1 255.255.255.0
int f0/0
    ip add 12.1.1.1 255.255.255.0
    no shutdown
router eigrp 10
eigrp router-id 1.1.1.1
network 12.1.1.1 0.0.0.0
2.R2路由器
hostname R2
int l0
    ip add 2.2.2.2 255.255.255.0
int l1
    ip add 22.22.22.222 255.255.255.0
int f0/0
    ip add 12.1.1.2 255.255.255.0
    no shutdown
router eigrp 10
    eigrp router-id 2.2.2.2
    passive-interface l0
    network 12.1.1.2 0.0.0.0
    network 2.2.2.2 0.0.0.0
    passive-interface l0
    redistribute connected metric 10000 1000 1 255 1500

Bandwidth=10000( Kbits per second)
delay = 1000 (10 microsecond units)

三.修改distance测试
1.R1修改之前先查看路由表

R1#show ip route eigrp | in FastEthernet
D        2.2.2.0 [90/156160] via 12.1.1.2, 00:04:01, FastEthernet0/0
D EX     22.22.22.0 [170/514560] via 12.1.1.2, 00:01:58, FastEthernet0/0
R1#
备注:可以看到,EIGRP内部路由的管理距离为90,外部为170
2.R1修改所有EIGRP外部路由的管理距离
router eigrp 10
    distance eigrp 10 171

R1#show ip route eigrp | in FastEthernet
D        2.2.2.0 [10/156160] via 12.1.1.2, 00:00:30, FastEthernet0/0
D EX     22.22.22.0 [171/514560] via 12.1.1.2, 00:00:30, FastEthernet0/0
R1#
3.R1用ACL匹配路由,再用distance修改
access-list 10 permit 2.2.2.0
access-list 10 permit 22.22.22.0
router eigrp 10
   no distance eigrp 10 171
    distance 111 12.1.1.2 0.0.0.0 10

R1#show ip route eigrp | in  FastEthernet
D        2.2.2.0 [111/156160] via 12.1.1.2, 00:00:09, FastEthernet0/0
D EX     22.22.22.0 [170/514560] via 12.1.1.2, 00:00:09, FastEthernet0/0
R1#

metric = 256 * (10^7/最小带宽 + 延迟总和/10)
256 * ( 10^7/10^4 + (1000+100 (Eigrp内部延迟))/10)
256*(1000+1000+10)=256*2010=514560

备注:可以看到,这种方式可以用ACL匹配路由,但是只能修改EIGRP的内部路由,对外部路由无效
四.修改metric测试
1.distribute-list修改metric
①EIGRP的distribute-list的out方向无法修改metric

--R2路由器
route-map SetMetric permit 10
    set metric 10000
router eigrp 10
    distribute-list route-map SetMetric out f0/0
--R1上面的metric没有修改
R1#show ip route eigrp  | in FastEthernet
D        2.2.2.0 [111/156160] via 12.1.1.2, 00:00:19, FastEthernet0/0
D EX     22.22.22.0 [170/514560] via 12.1.1.2, 00:00:19, FastEthernet0/0
R1#
②EIGRP的distribute-list的in方向可以修改metric
--R1路由器

route-map SetMetric permit 10
    set metric 10000
router eigrp 10
    no distance 111 12.1.1.2 0.0.0.0 10
    distribute-list route-map SetMetric in f0/0
--R1上面的metric已经修改
R1#show ip route eigrp  | in FastEthernet
D        2.2.2.0 [90/2560000] via 12.1.1.2, 00:00:25, FastEthernet0/0
D EX     22.22.22.0 [170/2560000] via 12.1.1.2, 00:00:25, FastEthernet0/0
R1#
--并且可以针对不同路由条目设置不同的metric
access-list 10 permit 2.2.2.0
access-list 20 permit 22.22.22.0
route-map SetMetric permit 10
    match ip address 10
    set metric 10000
route-map SetMetric permit 20
    match ip address 20
    set metric 20000
route-map SetMetric permit 30
router eigrp 10
    distribute-list route-map SetMetric in f0/0

R1#show ip route eigrp  | in FastEthernet
D       2.2.2.0 [90/2560000] via 12.1.1.2, 00:02:25, FastEthernet0/0
D EX    22.22.22.0 [170/5120000] via 12.1.1.2, 00:02:25, FastEthernet0/0
R1#
备注:可以看到设置一个metric值的时候,是总的种子metric,乘以256就是现在显示的metric
另外,测试发现,设置的种子metric,如果计算后metric比之前的metric小,则不会改变

2.offset-list修改metric
①EIGRP的offset-list的out方向修改metric
--修改之前R1路由表

R1#show ip route eigrp | in FastEthernet
D        2.2.2.0 [90/156160] via 12.1.1.2, 00:04:17, FastEthernet0/0
D EX     22.22.22.0 [170/514560] via 12.1.1.2, 00:04:17, FastEthernet0/0
R1#
--R2路由器
no access-list 10
access-list 10 permit 2.2.2.0
router eigrp 10
offset-list 10 out 40
--修改之后R1路由表   
R1#show ip route eigrp | in FastEthernet
D        2.2.2.0 [90/156200] via 12.1.1.2, 00:00:07, FastEthernet0/0
D EX     22.22.22.0 [170/514560] via 12.1.1.2, 00:05:21, FastEthernet0/0
R1#
--R2路由器配置offset-list out
no access-list 20
access-list 20 permit 22.22.22.0
router eigrp 10
offset-list 20 out 400
--R2修改之后R1路由表   
R1#show ip route eigrp | in FastEthernet
D        2.2.2.0 [90/156160] via 12.1.1.2, 00:00:10, FastEthernet0/0
D EX     22.22.22.0 [170/514960] via 12.1.1.2, 00:00:10, FastEthernet0/0
R1#
备注:一个进程只能有一个offset-list语句,用来增加metric,这个不用繁琐的计算
②EIGRP的offset-list的in方向修改metric
--修改之前R1路由表

与上面相同,参考上面
--R2路由器配置offset-list out
no access-list 10
access-list 10 permit 2.2.2.0
router eigrp 10
offset-list 10 in 40
--R2修改之后R1路由表   
R1#show ip route eigrp | in FastEthernet
D        2.2.2.0 [90/156200] via 12.1.1.2, 00:00:28, FastEthernet0/0
D EX     22.22.22.0 [170/514960] via 12.1.1.2, 00:00:28, FastEthernet0/0
R1#
3.redistribute的时候调用route-map修改metric
①先清除R1之前的offset-list配置
router eigrp 10
  no offset-list 10 in 40
②R2添加环回口,再清除R2之前的offset-list配置
int l2
    ip add 100.1.1.2 255.255.255.0
router eigrp 10
no offset-list 20 out 400
③修改之前查看R1的路由表
R1#show ip route eigrp | in FastEthernet
D        2.2.2.0 [90/156200] via 12.1.1.2, 00:00:06, FastEthernet0/0
D EX     22.22.22.0 [170/514560] via 12.1.1.2, 00:00:06, FastEthernet0/0
D EX     100.1.1.0 [170/514560] via 12.1.1.2, 00:00:06, FastEthernet0/0
R1#
④R2重新配置redistribute
no access-list 20
no route-map SetMetric
access-list 20 permit 22.22.22.0
route-map SetMetric permit 10
    match ip address 20
    set metric 20000 1000 1 255 1500
route-map SetMetric permit 20
router eigrp 10
    no redistribute connected metric 10000 1000 1 255 1500

    redistribute connected metric 10000 1000 1 255 1500 route-map SetMetric

备注:route-map设置metric值的时候,不能只设置一个,如果设置一个,会导致无法重分发,或者重分发也没有修改metric
--R2修改之后R1路由表  
R1#show ip route eigrp | in FastEthernet
D        2.2.2.0 [90/156200] via 12.1.1.2, 00:00:03, FastEthernet0/0
D EX     22.22.22.0 [170/386560] via 12.1.1.2, 00:00:03, FastEthernet0/0
D EX     100.1.1.0 [170/514560] via 12.1.1.2, 00:00:03, FastEthernet0/0
R1#
备注:可以看到已经成功被修改



本帖子中包含更多资源

您需要 思科 CCO 登录 才可以下载或查看,没有帐号?思科 CCO 注册   

x
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分5 (1 评价)
您需要登录后才可以回帖 思科 CCO 登录 | 思科 CCO 注册   

本版积分规则

Archiver | 思科社区  

GMT+8, 2020-4-7 14:58 , Processed in 0.095251 second(s), 29 queries .

京ICP备11014401号-17

© 2020 思科系统.版权所有 重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表