请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

搜索
热搜: 邮件服务器
查看: 344|回复: 8

用SNMP无法访问B路由器端口状态,(A路由器正常)

[复制链接]
发表于 2020-3-18 00:02:19 | 显示全部楼层 |阅读模式
0可用金钱
坛主好
           我用的是两台CISCO3850路由器作为主和备,我的问题是:
通过SNMP只能访问到A路由器端口状态,无法访问B路由器端口状态,不知问题出在那里

A路由器
interface Vlan13
ip address 10.10.12.251 255.255.255.0
standby 1 ip 10.10.12.249
standby 1 priority 105
standby 1 preempt
B路由器
interface Vlan13
ip address 10.10.12.252 255.255.255.0
standby 1 ip 10.10.12.249
standby 1 preempt

snmp-server community public RO
snmp-server enable traps snmp linkdown linkup coldstart warmstart
snmp-server host 10.10.10.151 FTE  snmp
snmp-server host 10.10.10.153 FTE  snmp

  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2020-3-18 09:30:09 | 显示全部楼层
通过SNMP查询2台路由器时,填写的2台路由器IP分别是什么呢?

不要用VRRP的VIP地址去访问,而是其它管理VLAN的IP;
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2020-3-18 17:49:02 来自手机 | 显示全部楼层
YilinChen 发表于 2020-3-18 09:30
通过SNMP查询2台路由器时,填写的2台路由器IP分别是什么呢?

不要用VRRP的VIP地址去访问,而是其它管理VL ...

分别为 ip address 10.10.12.251和ip address 10.10.12.252
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2020-3-18 17:54:55 来自手机 | 显示全部楼层
uddudd84352 发表于 2020-3-18 17:49
分别为 ip address 10.10.12.251和ip address 10.10.12.252

因为两台路由器的standby的ip是一个10.10.12.249
共用了10.10.12.249一个ip
麻烦您给解答一下
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2020-3-18 17:59:12 来自手机 | 显示全部楼层
uddudd84352 发表于 2020-3-18 17:54
因为两台路由器的standby的ip是一个10.10.12.249
共用了10.10.12.249一个ip
麻烦您给解答一下

如果用vlan的ip只能看到当前用的路由器的状态,备用的路由器的端口状态还是看不到
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2020-3-18 19:30:36 | 显示全部楼层
uddudd84352 发表于 2020-3-18 17:54
因为两台路由器的standby的ip是一个10.10.12.249
共用了10.10.12.249一个ip
麻烦您给解答一下

不能只用10.10.12.249 来检查信息呀
VRRP本身就是主备,10.10.12.249这个IP在角色为MASTER设备 A上,自然SNMP查询 10.10.12.249只会显示设备 A的信息;
如果你主备换一下,换成设备 B为MASTER,你再用SNMP查询 10.10.12.249,你会发现变成设备 B的信息了

正确做法是分别查询2台设备本身不同的IP地址,并且不建议是VRRP所属VLAN的地址,而是另外新创建一个管理VLAN的VTI接口IP
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2020-3-18 20:20:54 | 显示全部楼层
我现在是用两个IP 10.10.12.251和10.10.12.252查询的,只能访问到主的那台,备的是看不到的,不知道
该怎么办,麻烦您给的事例好吗,谢谢
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2020-3-21 21:29:50 | 显示全部楼层
麻烦高手帮忙解决
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2020-3-22 09:15:08 | 显示全部楼层
楼上已经给了。新建管理VLAN 不要用生产 和管理用一个VALN
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 思科 CCO 登录 | 思科 CCO 注册   

本版积分规则

Archiver | 思科社区  

GMT+8, 2020-4-7 14:26 , Processed in 0.106427 second(s), 51 queries .

京ICP备11014401号-17

© 2020 思科系统.版权所有 重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表