请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

搜索
热搜: 邮件服务器
查看: 895|回复: 3

【原创】N7K配置OSPFv3和IPv6 BGP与重分布

[复制链接]
发表于 2020-3-26 23:00:24 | 显示全部楼层 |阅读模式
一、场景说明
本次文档发布是基于实际现网要求启用IPv6网络,需在N7K设备上配置OSPFv3与BGP IPv6地址族,并且需要在两个路由协议下分别进行重发布各自学习到的相关路由。拓扑组网中N7K属于中间ASBR设备,本文档只涉及N7K设备上的相关配置,上下行设备暂且忽略。
二、相关配置
2.1接口配置
interface vlanxx
no shutdown
vrf VRFx
ipv6 address xxxx:xxxx::xx/127

2.2OSPFv3配置
ipv6 prefix-list bgp_to_ospf seq 10 permit  xxx:xxxx:xxxx:xxxx::/64

route-map bgp_to_ospf permit 10
match ipv6  address prefix-list bgp_to_ospf
match route-type external internal //这里一定要配置路由类型,否则bgp路由不会重发不到OSPFv3里面,在OSPF进程中也就学不到bgp过来的路由。

router ospfv3 1 //ospfv3进程号
vrf VRFx //设备配置了vrf,这里需要再相关的vrf下进行配置
    auto-cost reference-bandwidth 100000
    passive-interface default
address-family ipv6 unicast
redistribute bgp 1 route-map bgp_to_ospf


2.3BGP IPv6地址族配置
ipv6 prefix-list ospf_to_bgp seq 10 permit  xxx:xxxx:xxxx:xxxx::/64

route-map ospf_to_bgp permit 10
match ipv6 address prefix-list ospf_to_bgp

router bgp 1
router-id x.x.x.x //router-id是32的ipv4地址
address-family ipv6 unicast
vrf VRFx //这里也是进到相应的VRF下进行配置
    address-family ipv6 unicast
redistribute ospfv3 1 route-map ospf_to_bgp
neighbor xxxx:xxxx:xxxx::x remote-as xy//指定ipv6邻居地址和对端bgp as号
password xxxxxxxx //设置bgp认证秘钥
    address-family ipv6 unicast //这条命令也一定要敲,亲测 否则bgp协商不起来
exit

三、结束

关于N7K的相关配置基本上都完成了,配置过程中需要注意的几点都在命令后加了注释,



  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分5 (2 评价)
发表于 2020-3-27 08:58:43 | 显示全部楼层
感谢楼主分享,谢谢~
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2020-4-3 08:31:58 | 显示全部楼层

谢谢版主分享!
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2020-4-10 11:07:56 | 显示全部楼层
要注意路由协议。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 思科 CCO 登录 | 思科 CCO 注册   

本版积分规则

Archiver | 思科社区  

GMT+8, 2020-5-29 08:30 , Processed in 0.094147 second(s), 36 queries .

京ICP备11014401号-17

© 2020 思科系统.版权所有 重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表