请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

搜索
热搜: 邮件服务器
查看: 370|回复: 3

【原创】 CISCO CME+CUE配置实例分享

[复制链接]
发表于 2020-9-10 11:49:01 | 显示全部楼层 |阅读模式

VG2951#show run
VG2951#show running-config
Building configuration...

Current configuration : 21701 bytes
!
version 15.5
service config
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname VG2951
!
boot-start-marker
boot system flash:c2951-universalk9-mz.SPA.155-3.M6.bin
boot-end-marker
!
!
card type e1 0 0  
!
no aaa new-model
ethernet lmi ce
clock timezone UTC 8 0
network-clock-participate wic 0
network-clock-select 1 E1 0/0/0
!
!
!
!
!
!         
!
!
!
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-net5
!
!
!
voice-card 0
dsp services dspfarm
no local-bypass
!
!
!
voice service pots
fax rate disable
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol none
sip
  bind control source-interface GigabitEthernet0/1
  bind media source-interface GigabitEthernet0/1
  registrar server
!
!
!
!
voice register pool-type  8831
xml-config maxNumCalls 6
xml-config busyTrigger 2
phoneload-support
telnet-support
num-lines 5
description 8831
reference-pooltype 9971
!
voice register pool-type  8851
xml-config maxNumCalls 6
xml-config busyTrigger 2
num-lines 5
description Cisco IP Phone 8851
reference-pooltype 8961
!
voice register global
mode cme
source-address 10.10.10.x port 5060
max-dn 100
max-pool 100
load 7821 sip78xx.10-3-1-12
load 7861 sip78xx.10-3-1-12
authenticate register
timezone 42
time-format 24
date-format Y/M/D
voicemail xx22
url directory http://10.10.10.25X/directory
tftp-path flash:
create profile sync 0001793521457302dD2
ntp-server 10.10.10.X mode unicast
conference hardware
!
voice register dn  1
number xx03
call-forward b2bua noan xx22 timeout 15
allow watch
name Meeting Room 3
label Meeting Room 3
!
voice register dn  2
number xx01
call-forward b2bua noan xx22 timeout 15
allow watch
name Meeting Room  1
label Meeting Room 1
!
voice register dn  3
number xx20
call-forward b2bua noan xx22 timeout 15
allow watch
name Office1
label Office1
!
voice register pool  1
busy-trigger-per-button 2
id mac XXXXXXXX
type 8831
number 1 dn 1
dtmf-relay rtp-nte
username user1 password 123
call-forward b2bua noan xx22 timeout 15
codec g711ulaw
!
voice register pool  2
busy-trigger-per-button 2
id mac XXXXXXX
type 8831
number 1 dn 2
dtmf-relay rtp-nte
username user2 password 123
call-forward b2bua noan xx22 timeout 15
codec g711ulaw
!
voice register pool  3
busy-trigger-per-button 2
id mac XXXXXXXX
type 7821
number 1 dn 3
dtmf-relay rtp-nte
username user3 password 123
call-forward b2bua noan xx22 timeout 15
codec g711ulaw
!
!
voice translation-rule 1
rule 1 /^xxXX6/ /6/
!
voice translation-rule 2
rule 1 /^6/ /xxXX6/
!
voice translation-rule 3
rule 1 /^.*/ /9&/
!
voice translation-rule 8888
rule 1 /^xxXXxx00/ /8888/
!
!
voice translation-profile 8888
translate called 8888
!
voice translation-profile incoming-call
translate calling 3
translate called 1
!
voice translation-profile outgoing-call
translate calling 2
!
!
!
hw-module ism 0
!
hw-module pvdm 0/0
!
!
redundancy
!
!
controller E1 0/0/0
framing NO-CRC4
pri-group timeslots 1-31
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!         
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface ISM0/0
ip address 10.10.9.xxx 255.255.255.0
service-module ip address 10.10.9.xxx   255.255.255.0
!Application: CUE Running on ISM
service-module ip default-gateway 10.10.9.xxxxx
!
interface GigabitEthernet0/1
ip address 10.10.10.xxxx 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
interface ISM0/1
no ip address
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
no cdp enable
  no clns route-cache
!
interface Vlan1
no ip address
!
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
ip http path flash0:
!
ip ftp username cisco
ip ftp password 7 01100F175804EA3
ip route 0.0.0.0 0.0.0.0 10.10.10.x
ip route 10.10.9.xxxx   255.255.255.255 ISM0/0
ip ssh server algorithm encryption aes128-ctr aes192-ctr aes256-ctr
ip ssh client algorithm encryption aes128-ctr aes192-ctr aes256-ctr
!
!
nls resp-timeout 1
cpd cr-id 1
!
tftp-server flash:kern2.78xx.10-3-1-12.sbn
tftp-server flash:kern78xx.10-3-1-12.sbn
tftp-server flash:rootfs2.78xx.10-3-1-12.sbn
tftp-server flash:rootfs78xx.10-3-1-12.sbn
tftp-server flash:sip78xx.10-3-1-12.loads
tftp-server flash:sboot2.78xx.10-3-1-12.sbn
tftp-server flash:sboot78xx.10-3-1-12.sbn
!
control-plane
!
!
voice-port 0/0/0:15
!
voice-port 0/1/0
cptone CN
!
voice-port 0/1/1
!
voice-port 0/1/2
compand-type a-law
cptone CN
!
voice-port 0/1/3
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
sccp local GigabitEthernet0/1
sccp ccm 10.10.10.x identifier 1 priority 1 version 7.0
sccp ip precedence 1
sccp
!
sccp ccm group 1
bind interface GigabitEthernet0/1
associate ccm 1 priority 1
associate profile 1 register 2951CFB
associate profile 2 register 2951XCD
!
!
!
dspfarm profile 2 transcode  
codec g729abr8
codec g729ar8
codec g711alaw
codec g711ulaw
codec g729r8
shutdown
!
dspfarm profile 1 conference  
codec g729br8
codec g729r8
codec g729abr8
codec g729ar8
codec g711alaw
codec g711ulaw
maximum sessions 8
associate application SCCP
!
dial-peer voice 9xxXX pots
description Out-to-PSTN
translation-profile outgoing outgoing-call
destination-pattern 9T
direct-inward-dial
port 0/0/0:15
!         
dial-peer voice 98541 pots
translation-profile incoming incoming-call
incoming called-number .
direct-inward-dial
port 0/0/0:15
!
dial-peer voice xxxx pots
destination-pattern xxxx
port 0/1/2
!
dial-peer voice xx22 voip
description Voice Mail Service
destination-pattern xx22
session protocol sipv2
session target ipv4:10.10.9.2xx
incoming called-number 199[89]....
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 8888 voip
description AA Service
destination-pattern 8888
session protocol sipv2
session target ipv4:10.10.9.2xx
dtmf-relay sip-notify
codec g711ulaw
no vad
!
!
sip-ua
mwi-server ipv4:10.10.9.2xx expires 3600 port 5060 transport udp
!
!
!
gatekeeper
shutdown
!
!
telephony-service
sdspfarm units 2
sdspfarm transcode sessions 8
sdspfarm tag 1 2951CFB
sdspfarm tag 2 2951XCD
conference hardware
authentication credential admin cisco
max-ephones 10
max-dn 10
ip source-address 10.10.10.2xxx port 2000
service phone webAccess 0
service phone displayOnTime 00:00
service phone displayOnDuration 00:00
service phone displayIdleTimeout 00:01
service phone daysDisplayNotActive 1,2,3,4,5,6,7
url services http://10.10.9.2xx/voiceview/common/login.do
url authentication http://10.10.9.xxx/CCMCIP/authenticate.asp  
time-zone 42
voicemail xx22
max-conferences 8 gain -6
web admin system name admin password cisco
dn-webedit
time-webedit
transfer-system full-consult
create cnf-files version-stamp 7960 Oct 12 2020  11:15:18
!
!
ephone-dn  1  octo-line
number 4321
conference ad-hoc
no huntstop
!
!
ephone-dn  2  octo-line
number 4322
conference ad-hoc
no huntstop
!
!
ephone-dn  5
number 1998.... no-reg primary
mwi on
!
!
ephone-dn  6
number 1999.... no-reg primary
mwi off
!


  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2020-9-10 15:35:14 | 显示全部楼层
哇,还有这个分享
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2020-9-10 15:59:13 | 显示全部楼层
大哥你也来个说明下啊。。。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2020-9-11 08:38:03 | 显示全部楼层
大哥你来说一下各个命令做什么用的呀
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 思科 CCO 登录 | 思科 CCO 注册   

本版积分规则

Archiver | 思科社区  

GMT+8, 2020-9-26 12:19 , Processed in 0.107090 second(s), 36 queries .

京ICP备11014401号-17

© 2020 思科系统.版权所有 重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表