请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

搜索
热搜: 邮件服务器
查看: 453|回复: 10

请教高手,交换机报错不太看得懂

[复制链接]
发表于 2020-10-12 17:17:28 | 显示全部楼层 |阅读模式
10可用金钱
vlan 20 is flapping between port Po1 and port Gi0/20
Jul 19 2020 21:11:57.365: %SW_MATM-4-MACFLAP_NOTIF: Host e007.1bf2.0f96 in vlan 20 is flapping between port Po1 and port Gi0/20
Jul 19 2020 21:11:57.633: %SW_MATM-4-MACFLAP_NOTIF: Host e007.1bf2.ff42 in vlan 20 is flapping between port Po1 and port Gi0/19
Jul 20 2020 00:16:18.382: %SW_MATM-4-MACFLAP_NOTIF: Host e007.1bf2.ff42 in vlan 20 is flapping between port Po1 and port Gi0/19
Jul 20 2020 00:16:18.382: %SW_MATM-4-MACFLAP_NOTIF: Host e007.1bf2.0f96 in vlan 20 is flapping between port Po1 and port Gi0/20
Jul 20 2020 02:19:12.010: %SW_MATM-4-MACFLAP_NOTIF: Host e007.1bf2.ff42 in vlan 20 is flapping between port Po1 and port Gi0/19
Jul 20 2020 03:20:39.600: %SW_MATM-4-MACFLAP_NOTIF: Host e007.1bf2.ff42 in vlan 20 is flapping between port Po1 and port Gi0/19
Jul 20 2020 04:22:05.848: %SW_MATM-4-MACFLAP_NOTIF: Host e007.1bf2.ff42 in vlan 20 is flapping between port Po1 and port Gi0/19
Jul 20 2020 04:22:06.183: %SW_MATM-4-MACFLAP_NOTIF: Host e007.1bf2.0f96 in vlan 20 is flapping between port Po1 and port Gi0/20
Jul 20 2020 05:23:32.674: %SW_MATM-4-MACFLAP_NOTIF: Host e007.1bf2.ff42 in vlan 20 is flapping between port Po1 and port Gi0/19
Jul 20 2020 06:24:59.937: %SW_MATM-4-MACFLAP_NOTIF: Host e007.1bf2.0f96 in vlan 20 is flapping between port Po1 and port Gi0/20
Jul 20 2020 07:26:27.066: %SW_MATM-4-MACFLAP_NOTIF: Host e007.1bf2.0f96 in vlan 20 is flapping between port Po1 and port Gi0/20
Jul 20 2020 08:27:53.741: %SW_MATM-4-MACFLAP_NOTIF: Host e007.1bf2.ff42 in vlan 20 is flapping between port Po1 and port Gi0/19
Jul 20 2020 08:27:53.943: %SW_MATM-4-MACFLAP_NOTIF: Host e007.1bf2.0f96 in vlan 20 is flapping between port Po1 and port Gi0/20
Jul 20 2020 09:29:20.837: %SW_MATM-4-MACFLAP_NOTIF: Host e007.1bf2.ff42 in vlan 20 is flapping between port Po1 and port Gi0/19
Jul 20 2020 09:29:21.315: %SW_MATM-4-MACFLAP_NOTIF: Host e007.1bf2.0f96 in vlan 20 is flapping between port Po1 and port Gi0/20
Jul 20 2020 10:30:47.865: %SW_MATM-4-MACFLAP_NOTIF: Host e007.1bf2.ff42 in vlan 20 is flapping between port Po1 and port Gi0/19
Jul 20 2020 10:30:48.167: %SW_MATM-4-MACFLAP_NOTIF: Host e007.1bf2.0f96 in vlan 20 is flapping between port Po1 and port Gi0/20

  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2020-10-12 17:57:22 | 显示全部楼层
查下拓扑 有没有打环
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2020-10-12 18:22:17 | 显示全部楼层
有打环的可能,最好上个拓扑,有没有双网卡的服务器?
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2020-10-12 20:35:19 | 显示全部楼层
Jul 19 2020 21:11:57.633: %SW_MATM-4-MACFLAP_NOTIF: Host e007.1bf2.ff42 in vlan 20 is flapping between port Po1 and port Gi0/19

这一条信息说明, vlan20中的mac地址 'Host e007.1bf2.ff42 ' 在接口Po1和G0/19 学到.  
通常网络环路后,会出现这种问题.  一个MAC 应该只在在固定的接口学到.

您可以检查一下生成树, 和这些mac地址应该从哪个接口学到.
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2020-10-13 08:49:12 | 显示全部楼层
这明显是链路汇聚没有做好
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2020-10-13 10:40:16 | 显示全部楼层
以下是配置:
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 10,20 priority 24576
!
vlan internal allocation policy ascending
!
ip ssh authentication-retries 5
ip ssh version 2
!
!
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/1
switchport access vlan 10
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet0/2
switchport access vlan 10
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet0/3
switchport access vlan 10
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet0/4
switchport access vlan 10
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet0/5
switchport access vlan 10
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet0/6
switchport access vlan 10
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet0/7
switchport access vlan 10
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet0/8
switchport access vlan 10
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet0/9
switchport access vlan 10
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet0/10
switchport access vlan 10
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet0/11
switchport access vlan 10
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet0/12
switchport access vlan 10
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet0/13
switchport access vlan 10
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet0/14
switchport access vlan 10
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet0/15
switchport access vlan 10
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet0/16
switchport access vlan 10
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet0/17
switchport access vlan 10
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet0/18
switchport access vlan 10
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet0/19
switchport access vlan 20
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet0/20
switchport access vlan 20
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet0/21
switchport access vlan 20
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet0/22
switchport access vlan 20
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet0/23
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface GigabitEthernet0/24
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface GigabitEthernet0/25
!         
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
!
interface Vlan1
no ip address
!
interface Vlan10
description link DB-NETWORK
ip address 172.16.1.2 255.255.255.0
!
interface Vlan20
description link RAC-Heart-Network
no ip address
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2020-10-13 10:50:23 | 显示全部楼层
拓补图,是双网卡引起的吗,应用没有出现问题

本帖子中包含更多资源

您需要 思科 CCO 登录 才可以下载或查看,没有帐号?思科 CCO 注册   

x
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2020-10-13 11:11:22 | 显示全部楼层
VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
             Address     5835.d980.8d00
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     5835.d980.8d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Po1                 Desg FWD 3         128.56   P2p


         
VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    24586
             Address     5835.d980.8d00
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    24586  (priority 24576 sys-id-ext 10)
             Address     5835.d980.8d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/1               Desg FWD 4         128.1    P2p
Gi0/2               Desg FWD 4         128.2    P2p
Gi0/3               Desg FWD 4         128.3    P2p
Gi0/4               Desg FWD 4         128.4    P2p
Gi0/5               Desg FWD 4         128.5    P2p
Gi0/6               Desg FWD 4         128.6    P2p
Gi0/7               Desg FWD 4         128.7    P2p
Gi0/13              Desg FWD 4         128.13   P2p
Gi0/14              Desg FWD 4         128.14   P2p
Gi0/15              Desg FWD 4         128.15   P2p
Po1                 Desg FWD 3         128.56   P2p


         
VLAN0020
  Spanning tree enabled protocol ieee
  Root ID    Priority    24596
             Address     5835.d980.8d00
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    24596  (priority 24576 sys-id-ext 20)
             Address     5835.d980.8d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/19              Desg FWD 4         128.19   P2p
Gi0/20              Desg FWD 4         128.20   P2p
Po1                 Desg FWD 3         128.56   P2p
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2020-10-13 13:27:21 | 显示全部楼层
从报错的信息来看,e007.1bf2.ff42  这个Mac 地址 分别从 Po1 和 GE 0/19 接口学到了,是不是成环了?
好好的查下~
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2020-10-14 17:17:42 | 显示全部楼层
标准的做法:中间那两台交换机做成堆叠虚拟成一台交换机;服务器1(服务器2的网卡配置和服务器1一样)如果是linux操作系统,那么网卡的 Bonding modes 就采用 mode 6,堆叠交换机和服务器1两个网卡相连的两个端口配置到同一个Port-channel下。
目前的配置其实中间那两台交换机分别是独立的交换机,服务器两个网卡到交换机的连接是依靠生成树来做冗余,这样做的话服务器在任意时刻只有一个网卡工作,另一个处于阻塞状态。如果不想出现频繁摆动的现象,那么就要按vlan指定好根交换机以及相关端口的cost。
一般来说,如果服务器的双网卡的 Bonding modes 指定为mode 6,不管交换机侧对应端口是否配Port-channel,都不会出现flat告警。也就是说你现在交换机的配置都不变,只改动服务器双网卡的配置即可。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 思科 CCO 登录 | 思科 CCO 注册   

本版积分规则

Archiver | 思科社区  

GMT+8, 2020-10-29 20:55 , Processed in 0.109085 second(s), 54 queries .

京ICP备11014401号-17

© 2020 思科系统.版权所有 重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表