请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

搜索
热搜: 邮件服务器
查看: 461|回复: 6

3750X交换机vlan之间不通

[复制链接]
发表于 2020-12-21 14:21:45 | 显示全部楼层 |阅读模式
0可用金钱
划分了vlan,开启了dhcp,G1口和G7口接的电脑,24口接的路由器,现在vlan下的电脑都能访问外网,电脑能ping通vlan的网关,但ping不通下面分配的IP,看网上的教程说开启 ip routing  还是不行


no aaa new-model
switch 1provision ws-c3750g-24t
system mturouting 1500
ip subnet-zero
ip routing
!
ip dhcp poolvlan2
   network 192.168.2.0 255.255.255.0
   default-router 192.168.2.254
   dns-server 192.168.1.1
!
ip dhcp poolvlan4
   network 192.168.4.0 255.255.255.0
   default-router 192.168.4.254
   dns-server 192.168.1.1
!
!no file verifyauto
spanning-treemode pvst
spanning-treeextend system-id
!
vlan internalallocation policy ascending
!
interfaceGigabitEthernet1/0/1
switchport access vlan 2
switchport mode access
!
interfaceGigabitEthernet1/0/7
switchport access vlan 4
switchport mode access
!
interfaceGigabitEthernet1/0/24
no switchport
ip address 192.168.1.2 255.255.255.0
!         
interface Vlan1
no ip address
!
interface Vlan2
ip address 192.168.2.254 255.255.255.0
!
interface Vlan4
ip address 192.168.4.254 255.255.255.0
!
ip classless
ip route 0.0.0.00.0.0.0 192.168.1.1
ip http server
!
!
control-plane

  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2020-12-21 14:24:34 | 显示全部楼层
两台电脑互相ping不通,搞了几天了还是不行,三层交换机vlan之间不是本来就是通的吗,真是搞不懂了
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2020-12-21 15:43:47 | 显示全部楼层
正常情况下是可以通的啊,也没太大的问题,接PC的接口配置下spanning-tree portfast 算是个优化
个人感觉是电脑防火墙的问题吧?建议被ping一台关闭防火墙测试一下。
还可通过任意一台pc去ping另一个网关的ip地址,
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2020-12-21 16:42:52 | 显示全部楼层
还真是防火墙的问题,关了就好了,谢谢大佬回复
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2020-12-22 10:13:41 | 显示全部楼层
是新设备吗?
我记得每个接口下面,需要敲,“switch port”来激活交换机端口的。
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2020-12-25 10:26:14 | 显示全部楼层
防火墙的问题
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2020-12-30 21:53:07 | 显示全部楼层
应该是电脑上防火墙开着,所以无法ping通
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 思科 CCO 登录 | 思科 CCO 注册   

本版积分规则

Archiver | 思科社区  

GMT+8, 2021-1-23 18:05 , Processed in 0.074905 second(s), 44 queries .

京ICP备11014401号-17

© 2020 思科系统.版权所有 重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表