请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

搜索
热搜: 邮件服务器
查看: 544|回复: 6

思科9300 RIP协议疑惑

[复制链接]
发表于 2020-12-26 14:10:33 | 显示全部楼层 |阅读模式
1可用金钱
我选择的 是ver2 ,为什么network 感觉还是有类地址,不支持掩码,发送两个 10.67.x.0 的地址 被合并成 10.0.0.0了

按理说V1是有类地址,V2应该是无类地址,能精确到掩码啊
interface Vlan705
description Route_Vlan_A21-A21
ip address 10.67.2.17 255.255.255.252
!
interface Vlan706
description Route_Vlan_A21-A22
ip address 10.67.2.21 255.255.255.252
!
router rip
version 2
network 10.0.0.0
no auto-summary

  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2020-12-28 10:34:41 | 显示全部楼层
show ip route呢?
RIP的配置应该OK的哦
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2020-12-29 22:47:26 | 显示全部楼层
你在配置 10.67.x.0 的地址 时是不是后面没有加掩码
应该配置
network 10.67.1.0 0.0.0.255
network 10.67.2.0 0.0.0.255
……

如果在配置时没有加掩码,那么默认还是主类地址
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2021-1-5 07:57:27 | 显示全部楼层
141655176876927 发表于 2020-12-29 22:47
你在配置 10.67.x.0 的地址 时是不是后面没有加掩码
应该配置
network 10.67.1.0 0.0.0.255

RIP 不支持配掩码
test-10.67.1.65(config-router)#network 10.67.7.0 0.0.0.255
                                                 ^
% Invalid input detected at '^' marker.

test-10.67.1.65(config-router)#network 10.67.7.0 255.255.255.0
                                                 ^
% Invalid input detected at '^' marker.

test-10.67.1.65(config-router)#network 10.67.7.0              
test-10.67.1.65(config-router)#network 10.67.8.0              
test-10.67.1.65(config-router)#
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2021-1-12 10:19:22 | 显示全部楼层
模糊的记忆,好像RIP V2需要激活一下,
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
发表于 2021-1-21 09:00:19 | 显示全部楼层
添加一条no auto-summary,不要汇总,项目上好久没有使用过RIP,你试一下
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
 楼主| 发表于 2021-1-21 16:12:26 | 显示全部楼层
tony_tan 发表于 2021-1-21 09:00
添加一条no auto-summary,不要汇总,项目上好久没有使用过RIP,你试一下

缺省就是关闭自动汇总
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)
您需要登录后才可以回帖 思科 CCO 登录 | 思科 CCO 注册   

本版积分规则

Archiver | 思科社区  

GMT+8, 2021-3-5 06:42 , Processed in 0.074703 second(s), 45 queries .

京ICP备11014401号-17

© 2020 思科系统.版权所有 重要声明 | 保密声明 | 隐私权政策 | 商标 |

快速回复 返回顶部 返回列表