请选择 进入手机版 | 继续访问电脑版

设为首页 收藏本站
思科社区 关注
思科社区

   思科 CCO 登录 推荐
 找回密码
 立即注册

搜索
热搜: 邮件服务器

VxLAN over IPSec测试

已有 128 次阅读2019-11-6 16:55 |个人分类:VXLAN|系统分类:分享| VXLAN, VPN

一.概述
     eve可以模拟CSR1000v,如是利用它测试了一下vxlan,特记录下来。IPsec只是为了使得两边的VTEP的loopback接口地址能够互通,一般情况在内网不会使用ipsec,只需设置 ingress-replication地址为物理口地址。
二.拓扑
    
三.配置步骤
1.基本配置
①R1路由器
hostname R1
interface Ethernet0/0
    ip address 192.168.1.1 255.255.255.0
②VTEP1路由器(CSR1000v)
hostname VTEP1
interface Loopback1
    ip address 10.1.1.1 255.255.255.255
interface GigabitEthernet2
    ip address 202.100.1.1 255.255.255.0
    no shutdown
ip route 0.0.0.0 0.0.0.0 202.100.1.10
③Internet路由器
hostname Internet
interface Ethernet0/0
    ip address 202.100.1.10 255.255.255.0
interface Ethernet0/1
    ip address 202.100.2.10 255.255.255.0
    no shutdown
④VTEP2路由器(CSR1000v)
hostname VTEP2
interface Loopback1
    ip address 12.1.1.1 255.255.255.255
interface GigabitEthernet1
    ip address 202.100.2.1 255.255.255.0
    no shutdown
⑤R2路由器
hostname R2
interface Ethernet0/0
    ip address 192.168.1.2 255.255.255.0
2.ipsec配置
①VTEP1路由器
crypto isakmp policy 10
    encr 3des
    hash md5
    authentication pre-share
crypto isakmp key cisco address 202.100.2.1    
crypto ipsec transform-set transet esp-3des esp-md5-hmac
    mode transport
crypto ipsec profile ipsecpro
    set transform-set transet
interface Tunnel1
    ip address 172.16.1.1 255.255.255.0
    tunnel source GigabitEthernet2
    tunnel mode ipsec ipv4
    tunnel destination 202.100.2.1
    tunnel protection ipsec profile ipsecpro
router eigrp 100
    network 10.1.1.1 0.0.0.0
    network 172.16.1.1 0.0.0.0
    passive-interface Loopback1
②VTEP2路由器
crypto isakmp policy 10
    encr 3des
    hash md5
    authentication pre-share
crypto isakmp key cisco address 202.100.1.1    
crypto ipsec transform-set transet esp-3des esp-md5-hmac
    mode transport
crypto ipsec profile ipsecpro
    set transform-set transet
interface Tunnel1
    ip address 172.16.1.2 255.255.255.0
    tunnel source GigabitEthernet2
    tunnel mode ipsec ipv4
    tunnel destination 202.100.2.1
    tunnel protection ipsec profile ipsecpro
router eigrp 100
    network 12.1.1.1 0.0.0.0
    network 172.16.1.2 0.0.0.0
    passive-interface Loopback1
3.vxlan配置
①VTEP1路由器
interface nve1
    no ip address
    source-interface Loopback1
    member vni 5010
      ingress-replication 12.1.1.1
interface GigabitEthernet1
    no ip address
    no shutdown
    service instance 1 ethernet
      encapsulation untagged
bridge-domain 10
    member vni 5010
    member GigabitEthernet1 service-instance 1
②VTEP2路由器
interface nve1
    no ip address
    source-interface Loopback1
    member vni 5010
      ingress-replication 10.1.1.1
interface GigabitEthernet2
    no ip address
    no shutdown
    service instance 1 ethernet
      encapsulation untagged
bridge-domain 10
    member vni 5010
    member GigabitEthernet2 service-instance 1
四.验证
①R1能直接ping通R2直连地址
R1#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/2/6 ms
②R1能tenlnet R2直连地址
R1#telnet 192.168.1.2
Trying 192.168.1.2 ... Open


User Access Verification

Username: admin
Password:
R2#show user
R2#show users
    Line       User       Host(s)              Idle       Location
   0 con 0                idle                 00:00:19   
*  2 vty 0     admin      idle                 00:00:00 192.168.1.1

  Interface    User               Mode         Idle     Peer Address

R2#






  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5
平均得分0 (0 评价)

路过

鸡蛋

鲜花

握手

雷人

评论 (0 个评论)

facelist

您需要登录后才可以评论 登录 | 立即注册

Archiver | 思科社区  

GMT+8, 2019-11-23 01:43 , Processed in 0.052760 second(s), 22 queries .

京ICP备09041801号-187

版权所有 :copyright:1992-2019 思科系统  重要声明 | 保密声明 | 隐私权政策 | 商标 |

返回顶部